Opened 13 years ago

Closed 12 years ago

#14643 closed defect (invalid)

KDE3 install fail (kdeutils)

Reported by: k0l0b0k.void@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: kdeutils kde install error Cc:
Port:

Description

Hi All! I'm trying to install kde3 on my Intel Mac Leopard 10.5.2 (just for fun :), and gives this error on kdeutils installing step:

Error: Target org.macports.destroot returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeutils3/work/kdeutils-3.5.8 && ./InstallScript.sh" returned error 1
Command output:   MACOSX_DEPLOYMENT_TARGET: $MACOSX_DEPLOYMENT_TARGET
  PATH:                     $PATH
  PKG_CONFIG_PATH:          $PKG_CONFIG_PATH
  CONFIGURE_PARAMS:         $CONFIGURE_PARAMS
  UNSERMAKEFLAGS:           $UNSERMAKEFLAGS
  MAKEFLAGS:                $MAKEFLAGS

END
the following environment is being used:

  ACLOCALFLAGS:             
  CFLAGS:                   -Os -fPIC
  CPPFLAGS:                  -I/opt/local/include/freetype2 -I/opt/local/include -fno-common -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/opt/local/include -I/usr/X11R6/include
  CXXFLAGS:                 -Os -fPIC
  FREETYPE_CONFIG:          /opt/local/bin/freetype-config
  LDFLAGS:                  -L/opt/local/lib -Wl,-dylib_file,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
  LIBS:                      -L/opt/local/lib -L/usr/X11R6/lib
  MACOSX_DEPLOYMENT_TARGET: 10.5
  PATH:                     /opt/local/bin:/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/usr/X11R6/bin
  PKG_CONFIG_PATH:          /opt/local/lib/pkgconfig:
  CONFIGURE_PARAMS:         --includedir=/opt/local/include --libdir=/opt/local/lib --prefix=/opt/local --with-extra-libs=/opt/local/lib --with-extra-includes=/opt/local/include --enable-mt --with-pic --enable-rpath --enable-shared=yes --enable-static=no --mandir=/opt/local/share/man --with-xinerama --with-pam --disable-final --with-ssl-dir=/opt/local --with-ssl --disable-dependency-tracking --enable-gcc-hidden-visibility --with-qt-dir=/opt/local/lib/qt3
  UNSERMAKEFLAGS:            -p
  MAKEFLAGS:                


	./build-helper.sh install kdeutils3 3.5.8 0 unsermake -p -j1 install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeutils3/work/destroot kgpg_SUBDIR_included_TRUE='#' kgpg_SUBDIR_included_FALSE=
01% 20% 20% 20% 25% 26% installing ./kdelirc/irkick/irkick.la 
install: ./kdelirc/irkick/.libs/irkick.lai: No such file or directory
Error creating /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeutils3/work/destroot/opt/local/lib/kde3/irkick.la. Exit status 71.
kdeutils3-3.5.8-0 install failed!

Error: The following dependencies failed to build: kdeutils3
Error: Status 1 encountered during processing.

And so, resolve this trouble is difficult for me at now, because Midnight Commander, installed by macports (thanks!) distorts their view when trying to show this folder: _opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeutils3 (may be it is very long for him?)

Change History (3)

comment:1 Changed 13 years ago by takanori@…

I tried to install kdeutils3 on my Mac, but I couldn't reproduce it.

takanori@pc192168024053$ uname -a
Darwin pc192168024053.miko.org 9.2.2 Darwin Kernel Version 9.2.2: Tue Mar  4 21:17:34 PST 2008; root:xnu-1228.4.31~1/RELEASE_I386 i386
takanori@pc192168024053$ gcc --version
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5478)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

takanori@pc192168024053$ port installed kde*
The following ports are currently installed:
  kdebase3 @3.5.8_0 (active)
  kdelibs3 @3.5.8_2+darwin_9 (active)
  kdeutils3 @3.5.8_0 (active)

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:3 Changed 12 years ago by takanori@…

Resolution: invalid
Status: newclosed

No response from the reporter.

Note: See TracTickets for help on using tickets.