Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#14886 closed defect (fixed)

pandoc fails to build

Reported by: shreevatsa.public@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: jgm@…, ryandesign (Ryan Schmidt), mike@…
Port:

Description

The port pandoc fails with:

Text/Pandoc/Definition.hs:92:32:    parse error on input `-- ^ Link target (URL, title)'
haddock: Failed to check module: Text.Pandoc.Definition

Attachments (2)

patch-Text-Pandoc-Definition.hs (448 bytes) - added by jgm@… 12 years ago.
patch file - for files subdirectory
Portfile-pandoc.diff (369 bytes) - added by jgm@… 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: jgm@… added

Cc maintainer.

comment:2 Changed 12 years ago by jgm@…

It seems that the very latest version of haddock in macports is stricter than previous versions. There was a minor haddock error in Text/Pandoc/Definition.hs, which can be fixed by the patch below. The problem will be fixed in 0.47, which I hope to release before long.

John

--- Definition.hs       2007-11-29 00:09:07.000000000 -0800
+++ Definition.new.hs   2008-03-31 13:21:55.000000000 -0700
@@ -89,7 +89,8 @@
 -- | Type of quotation marks to use in Quoted inline.
 data QuoteType = SingleQuote | DoubleQuote deriving (Show, Eq, Read)

-type Target = (String, String)  -- ^ Link target (URL, title)
+-- | Link target (URL, title).
+type Target = (String, String)

 -- | Inline elements.
 data Inline

comment:3 Changed 12 years ago by jgm@…

I'm attaching a patch file and a patch to the Portfile that should fix the problem.

Changed 12 years ago by jgm@…

patch file - for files subdirectory

Changed 12 years ago by jgm@…

Attachment: Portfile-pandoc.diff added

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

I was going to try to test this fix but I can't because build dependency ghc won't build for me. :(

comment:5 in reply to:  4 Changed 12 years ago by mike@…

I had previously built and installed ghc. I can confirm that the patches work, having applied it to my local repository and successfully built and install pandoc. Suggest acceptance.

comment:6 Changed 12 years ago by mike@…

Cc: mike@… added

Cc Me!

comment:7 Changed 12 years ago by danielluke (Daniel J. Luke)

Owner: changed from macports-tickets@… to dluke@…
Status: newassigned

Looking at this now...

comment:8 Changed 12 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: assignedclosed

patch committed in r37362

comment:9 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.