Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#14890 closed submission (fixed)

request for new port: kdevelop

Reported by: jon@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: t.m.guymer@…, ak.ml@…
Port: kdevplatform kdevelop

Description

Can someone make a Portfile for the "kdevelop" IDE.

http://www.kdevelop.org/

Currently we have to use Fink to get this :-(

Attachments (4)

Portfile-kdevplatform (852 bytes) - added by nicos_pavlov@… 9 years ago.
Portfile-kdevelop (812 bytes) - added by nicos_pavlov@… 9 years ago.
Portfile-kdevplatform-2 (1.1 KB) - added by nicos_pavlov@… 9 years ago.
Portfile-kdevelop-2 (1.3 KB) - added by nicos_pavlov@… 9 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Milestone: Port SubmissionsPort Requests

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Type: enhancementrequest

comment:3 Changed 10 years ago by (none)

Milestone: Port Requests

Milestone Port Requests deleted

comment:4 Changed 9 years ago by nicos_pavlov@…

I prepared portfiles for KDevelop in the framework of kde4. Please find its portfile, along with the one of kdevplatform on which it depends attached. Builds fine and tested with OS 10.6, built universally.

Changed 9 years ago by nicos_pavlov@…

Attachment: Portfile-kdevplatform added

Changed 9 years ago by nicos_pavlov@…

Attachment: Portfile-kdevelop added

comment:5 Changed 9 years ago by nicos_pavlov@…

Cc: nicos_pavlov@… added

Cc Me!

comment:6 Changed 9 years ago by mf2k (Frank Schima)

Port: kdevplatform kdevelop added
Type: requestsubmission
Version: 1.6.0

Changed 9 years ago by nicos_pavlov@…

Attachment: Portfile-kdevplatform-2 added

comment:7 Changed 9 years ago by nicos_pavlov@…

My apologies, I have been slightly clumsy when submitting the Portfiles (no long description, doubled dependencies with kde4.1 group). Those details are corrected with the Portfiles-2

comment:8 Changed 9 years ago by mlund@…

This is good news. Regarding dependencies perhaps it would be a good idea to specify what is required for building and what is required for running - see:

http://techbase.kde.org/KDevelop4/requirements

comment:9 Changed 9 years ago by nicos_pavlov@…

As a matter of fact, they are specified. Either directly, or implicitly by the requirements of kde4 1.1 PortGroup, or by the requirement of Macports to have XCode installed for compilers. I however added a subversion version to explicitly require svn support.

comment:10 Changed 9 years ago by mlund@…

It seems safer to let your port rely directly on the dependencies such that if someone changes for example the kdelib portfile, your port will not be broken. According to the kdevelop website, boost (which is tedious to compile) is required for building only - not for running. This could be implemented like this:

depends_build port:boost port:cmake etc. etc.
depends_run port:kdelib port:kdevplatform port:qt4

The problem is not huge, since there is currently no binary repository for macports and most people of course do their own build. But that could change in the future!

Changed 9 years ago by nicos_pavlov@…

Attachment: Portfile-kdevelop-2 added

comment:11 Changed 9 years ago by nicos_pavlov@…

This is indeed true for boost, but unfortunately not for kdelibs4 or kdevplatform, which are required both at compilation and run time, as represented by depends_lib and not depends_run.

For the rest, I honestly do not get the issue. It is not related to changes on kdelibs4, but on the PortGroup kde4 1.1. What is the point of portgroups if not to rely on them to ease Portfile creation ? Furthermore, the fact of doubling dependencies is I think contrary to the policy of Portfiles as done presently (see for example kdebase4-runtime, which do not explicitely require cmake or qt4-mac because it uses kde4 portgroup).
Anyway, I did purposely put openmaintainer as a keyword, so feel free to propose changes directly in the Portfile.

comment:12 Changed 9 years ago by mlund@…

You're right - I only today found out about the portgroup concept when updating a port from autotools to cmake. Handy. The portfiles look good to me.

comment:13 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: t.m.guymer@… added

Has duplicate #31437.

comment:14 Changed 8 years ago by t.m.guymer@…

What is the status of this portfile now?

kdevelop is not in the port lists and neither is kdevplatform.

If someone wants to install KDevelop using MacPorts how does one do it now?

comment:15 Changed 8 years ago by NicosPavlov

Cc: nicos_pavlov@… removed
Owner: changed from macports-tickets@… to nicos@…
Status: newassigned

As I recently got the commit rights, I will be able to create the ports. It is however required to update them for the present version of KDE beforehand.

comment:16 Changed 8 years ago by ak.ml@…

Cc: ak.ml@… added

Cc Me!

comment:17 Changed 8 years ago by NicosPavlov

Resolution: fixed
Status: assignedclosed

kdevplatform added in r84830, kdevelop added in r84831.

comment:18 Changed 8 years ago by t.m.guymer@…

Thank you :)

Note: See TracTickets for help on using tickets.