Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14937 closed defect (fixed)

Still problems building inkscape on OS X 10.4.11 Intel

Reported by: MartinBuchmann (Martin Buchmann) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

Hi,

after the upgrade to version 0.46 I am still not able to install th inkscape port on my MacBook. This is what I end up with:

make[2]: *** [extension/internal/pdfinput/svg-builder.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_inkscape/work/inkscape-0.46" && make all " returned error 2
Command output: extension/internal/pdfinput/pdf-parser.h:299: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:300: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:303: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:304: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:305: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:306: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:309: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:310: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:311: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:312: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:316: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:317: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:318: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:319: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:327: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:329: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:330: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:333: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:334: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:337: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:338: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:341: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:342: error: 'Object' has not been declared
extension/internal/pdfinput/pdf-parser.h:343: error: 'Object' has not been declared
extension/internal/pdfinput/svg-builder.cpp: In member function 'gchar* Inkscape::Extension::Internal::SvgBuilder::_createTilingPattern(GfxTilingPattern*, GfxState*, bool)':
extension/internal/pdfinput/svg-builder.cpp:659: error: no matching function for call to 'PdfParser::parse(Object*)'
extension/internal/pdfinput/pdf-parser.h:162: note: candidates are: void PdfParser::parse(int*, GBool)
make[2]: *** [extension/internal/pdfinput/svg-builder.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Warning: the following items did not execute (for inkscape): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing

I will attach a complete log file of the install command.

Best regards

Martin

Attachments (2)

inkscape.log (978.9 KB) - added by MartinBuchmann (Martin Buchmann) 13 years ago.
Portfile.diff (535 bytes) - added by neric27@… 13 years ago.
Patch to automatically replace the include

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by MartinBuchmann (Martin Buchmann)

Attachment: inkscape.log added

comment:1 Changed 13 years ago by neric27@…

Hi,
the problem is that Object.h from python25 is included instead of Object.h of libpoppler.
It's caused by the order of the -I directives. The way I tried is to point to the full path of the Object.h

For a quick fix, edit the file pdf-parser.h

sudo vi /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_inkscape/work/inkscape-0.46
src/extension/internal/pdfinput/pdf-parser.h

line 30

#include "/opt/local/include/poppler/Object.h"

instead of

#include "Object.h"


Then, retry to update

sudo port upgrade inkscape

Cheers,

comment:2 Changed 13 years ago by MartinBuchmann (Martin Buchmann)

Hi,

great, that works like a charm for me :-)

Thanks for the hint

Martin

comment:3 Changed 13 years ago by yaseppochi (Stephen J. Turnbull)

Just to confirm that this bought me a successful build, too, on OS X 10.4.11 PPC (iBook G4).

Thanks!

comment:4 Changed 13 years ago by neric27@…

Ok, it's great [[BR]] So here is a patch to the Portfile to do it automatically

Changed 13 years ago by neric27@…

Attachment: Portfile.diff added

Patch to automatically replace the include

comment:5 Changed 13 years ago by gui-dos (Guido Soranzio)

Resolution: fixed
Status: newclosed

Fixed in r36064, thanks.

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.