Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14979 closed defect (duplicate)

expect 5.43.0 build fails

Reported by: max@… Owned by: markd@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: expect Cc:
Port:

Description

$ sudo port install expect
--->  Fetching expect
--->  Verifying checksum(s) for expect
--->  Extracting expect
--->  Configuring expect
--->  Building expect with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_expect/work/expect-5.43" && make all " returned error 2
Command output: 	   else true; fi ; \
	   /usr/bin/gcc-4.0 -c  -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_expect/work/tcl8.4.14/generic   -DEXP_VERSION=\"5.43.0\" -DSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DEXECSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DTCL_DEBUGGER -DUSE_NON_CONST -DSTTY_BIN=\"/bin/stty\" -O2 -O2 -pipe     -DDFLT_STTY="\"sane\""  exp_chan.c -o shared/exp_chan.o ; \
	fi
/usr/bin/gcc-4.0 -c  -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_expect/work/tcl8.4.14/generic   -DEXP_VERSION=\"5.43.0\" -DSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DEXECSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DTCL_DEBUGGER -DUSE_NON_CONST -DSTTY_BIN=\"/bin/stty\" -O2 -O2 -pipe    -DDFLT_STTY="\"sane\""  Dbg.c
Dbg.c: In function 'PrintStackBelow':
Dbg.c:469: warning: passing argument 3 of 'print_objv' discards qualifiers from pointer target type
if [ "xlibexpect5.43.a" != "xlibexpect5.43.a" ] ; then \
	   if [ ! -d shared ] ; then \
		mkdir shared ; \
	   else true; fi ; \
	   /usr/bin/gcc-4.0 -c  -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_expect/work/tcl8.4.14/generic   -DEXP_VERSION=\"5.43.0\" -DSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DEXECSCRIPTDIR=\"/opt/local/lib/expect5.43\" -DTCL_DEBUGGER -DUSE_NON_CONST -DSTTY_BIN=\"/bin/stty\" -O2 -O2 -pipe     -DDFLT_STTY="\"sane\""  Dbg.c -o shared/Dbg.o ; \
	fi
rm -f libexpect5.43.a
ar cr libexpect5.43.a exp_command.o expect.o pty_termios.o exp_inter.o exp_regexp.o exp_tty.o exp_log.o exp_main_sub.o exp_pty.o exp_trap.o exp_console.o exp_strf.o exp_glob.o exp_win.o exp_clib.o exp_closetcl.o exp_memmove.o exp_tty_comm.o exp_select.o exp_event.o exp_chan.o Dbg.o
ranlib: file: libexpect5.43.a(exp_regexp.o) has no symbols
ranlib: file: libexpect5.43.a(exp_closetcl.o) has no symbols
ranlib: file: libexpect5.43.a(exp_memmove.o) has no symbols
ranlib libexpect5.43.a
ranlib: file: libexpect5.43.a(exp_regexp.o) has no symbols
ranlib: file: libexpect5.43.a(exp_closetcl.o) has no symbols
ranlib: file: libexpect5.43.a(exp_memmove.o) has no symbols
/usr/bin/gcc-4.0 -O2 -O2 -pipe     -prebind -headerpad_max_install_names -Wl,-search_paths_first  -o expect exp_main_exp.o libexpect5.43.a -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_tcl/work/tcl8.5.2/unix -ltcl8.5 -L/opt/local/lib   -framework CoreFoundation  
Undefined symbols:
  "_Tcl_CloseObjCmd", referenced from:
      _Exp_CloseObjCmd in libexpect5.43.a(exp_command.o)
  "_Tcl_ReturnObjCmd", referenced from:
      _Exp_InterReturnObjCmd in libexpect5.43.a(exp_command.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [expect] Error 1

Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Cc: markd@… removed
Owner: changed from macports-tickets@… to markd@…

comment:2 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: duplicate
Status: newclosed

Duplicate of #13827.

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.