Opened 13 years ago

Closed 13 years ago

Last modified 5 years ago

#15141 closed defect (duplicate)

gtk2 2.12.9_0 +no_x11 fails to build

Reported by: damjan.marion@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: gtk2

Description (last modified by ryandesign (Ryan Schmidt))

GTK2 cannot be built when no_x11 variant is used with following error:

pango must be installed with the no_x11 variant enabled.

But pango is built with no_x11.

# port installed | grep pango
  pango @1.20.2_0+no_x11 (active)

Seems that error message is misplaced in Portfile and it should be before closing bracket. Following patch solves this issue:

--- Portfile.orig	2008-04-27 18:23:44.000000000 +0200
+++ Portfile	2008-04-27 18:25:43.000000000 +0200
@@ -116,8 +116,8 @@
     pre-fetch {
         if {[file exists ${prefix}/lib/libpangox-1.0.dylib]} {
             ui_error "Please uninstall or deactivate the pango port and reinstall it by running `port install pango +no_x11`."
-        }
         error "pango must be installed with the no_x11 variant enabled."
+        }
     }
 }

Change History (3)

comment:1 Changed 13 years ago by damjan.marion@…

--- Portfile.orig	2008-04-27 18:23:44.000000000 +0200
+++ Portfile	2008-04-27 18:25:43.000000000 +0200
@@ -116,8 +116,8 @@
     pre-fetch {
         if {[file exists ${prefix}/lib/libpangox-1.0.dylib]} {
             ui_error "Please uninstall or deactivate the pango port and reinstall it by running `port install pango +no_x11`."
-        }
         error "pango must be installed with the no_x11 variant enabled."
+        }
     }
 }

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #15111.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: gtk2 added
Note: See TracTickets for help on using tickets.