Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15300 closed defect (worksforme)

Error: Checksum (md5) mismatch for g95_source.tgz

Reported by: psq100@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

~ $ sudo port install g95
Password:
--->  Verifying checksum(s) for g95
Error: Checksum (md5) mismatch for g95_source.tgz
Error: Checksum (sha1) mismatch for g95_source.tgz
Error: Checksum (rmd160) mismatch for g95_source.tgz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.

Change History (8)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to takeshi@…

Assigning to maintainer. Have you tried sudo port clean --all g95 in case your local copy of the tarball is truncated or otherwise corrupt?

comment:2 in reply to:  1 Changed 12 years ago by psq100@…

Replying to jmr@macports.org:

Assigning to maintainer. Have you tried sudo port clean --all g95 in case your local copy of the tarball is truncated or otherwise corrupt?

~ $ sudo port clean --all g95
Password:
--->  Cleaning g95
~ $ sudo port install g95
--->  Fetching g95
--->  Attempting to fetch gcc-core-4.0.3.tar.gz from ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.0.3/
--->  Attempting to fetch g95_source.tgz from ftp://anonymous%40g95.org:none@ftp.g95.org/v0.91/
--->  Verifying checksum(s) for g95
Error: Checksum (md5) mismatch for g95_source.tgz
Error: Checksum (sha1) mismatch for g95_source.tgz
Error: Checksum (rmd160) mismatch for g95_source.tgz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.

comment:3 Changed 12 years ago by tenomoto (Takeshi Enomoto)

I downloaded afresh and confirmed that the source has not been replaced. Can you manually find the md5 sum as follows?

$ md5 /opt/local/var/macports/distfiles/g95/g95_source.tgz 
MD5 (/opt/local/var/macports/distfiles/g95/g95_source.tgz) = ¥
35e1852e09b69555bc07f30d0ab4b6ba

comment:4 in reply to:  3 Changed 12 years ago by psq100@…

Replying to takeshi@macports.org:

I downloaded afresh and confirmed that the source has not been replaced. Can you manually find the md5 sum as follows?

~ $ md5 /opt/local/var/macports/distfiles/g95/g95_source.tgz 
Md5 (/opt/local/var/macports/distfiles/g95/g95_source.tgz) = b67c32fdec63d8d11d3f4003765a38cd
~ $ tar ztf /opt/local/var/macports/distfiles/g95/g95_source.tgz
g95-0.91/
g95-0.91/primary.c
... 
g95-0.91/match.c
g95-0.91/ggc-page40.c
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers

gzip: stdin: invalid compressed data--crc error

gzip: stdin: invalid compressed data--length error
tar: Child returned status 1
tar: Error exit delayed from previous errors
~ $ 

I cannot download correct tarball. I installed a package "wget". It was installed normally. Then I have made the following:

~ $ wget ftp://anonymous%40g95.org:none@ftp.g95.org/v0.91/g95_source.tgz
--2008-05-17 13:20:10--  ftp://anonymous%40g95.org:*password*@ftp.g95.org/v0.91/g95_source.tgz
           => `g95_source.tgz'
Resolving ftp.g95.org... 69.89.19.165
Connecting to ftp.g95.org|69.89.19.165|:21... connected.
Logging in as anonymous@g95.org ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /v0.91 ... done.
==> SIZE g95_source.tgz ... 1298703
==> PASV ... done.    ==> RETR g95_source.tgz ... done.
Length: 1298703 (1.2M)

100%[======================================>] 1,298,703   99.1K/s   in 13s     

2008-05-17 13:20:27 (94.4 KB/s) - `g95_source.tgz' saved [1298703]

~ $ md5 g95_source.tgz 
MD5 (g95_source.tgz) = b97ed5b7e4dc9469cfaee36c0fcad87c


~ $ wget ftp://anonymous%40g95.org:none@ftp.g95.org/v0.91/g95_source.tgz
--2008-05-17 13:20:38--  ftp://anonymous%40g95.org:*password*@ftp.g95.org/v0.91/g95_source.tgz
           => `g95_source.tgz.1'
Resolving ftp.g95.org... 69.89.19.165
Connecting to ftp.g95.org|69.89.19.165|:21... connected.
Logging in as anonymous@g95.org ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /v0.91 ... done.
==> SIZE g95_source.tgz ... 1298703
==> PASV ... done.    ==> RETR g95_source.tgz ... done.
Length: 1298703 (1.2M)

100%[======================================>] 1,298,703    119K/s   in 21s     

2008-05-17 13:21:03 (59.4 KB/s) - `g95_source.tgz.1' saved [1298703]

~ $ md5 g95_source.tgz.1 
MD5 (g95_source.tgz.1) = a194cecedc6c78113e7a9a7198768b20
~ $ 

Has twice downloaded one, but md5 the sums differ

comment:5 Changed 12 years ago by tenomoto (Takeshi Enomoto)

Resolution: worksforme
Status: newclosed

Since the md5 sum in g95's Portfile is correct, I close this ticket.

comment:6 Changed 12 years ago by jmroot (Joshua Root)

That FTP site has caused problems before (with proxies). Maybe it should just be removed now that there is a HTTP source in the portfile.

comment:7 Changed 12 years ago by tenomoto (Takeshi Enomoto)

Removed FTP site as suggested. Thanks.

comment:8 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.