Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15714 closed defect (fixed)

encfs: configure fails

Reported by: raimue (Rainer Müller) Owned by: kballard (Lily Ballard)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: sanchom (Sancho McCann)
Port: encfs

Description

EncFS fails with a strange error in configure for me.

Here is the relevant output from configure:

checking for boostlib >= 1.33... yes
configure: WARNING: BOOST_CPPFLAGS -I/opt/local/include
checking whether the Boost::Serialization library is available... yes
configure: error: Could not link against  !

And now the part from config.log:

configure:22433: checking for boostlib >= 1.33 
configure:22497: ccache /usr/bin/g++-4.0 -c -pipe -O2 -I/opt/local/include -D__FreeBSD__=10 -I/opt/loc
al/include conftest.cpp >&5
configure:22504: $? = 0
configure:22510: result: yes
configure:22708: WARNING: BOOST_CPPFLAGS -I/opt/local/include
configure:22716: checking whether the Boost::Serialization library is available
configure:22754: ccache /usr/bin/g++-4.0 -c -pipe -O2 -I/opt/local/include -D__FreeBSD__=10 -I/opt/local/include conftest.cpp >&5
configure:22761: $? = 0 
configure:22783: result: yes
configure:23027: error: Could not link against  !

So compiling was successful, but it is assuming linking failed for some reason. I'll attach the full config.log for further reference.

Attachments (1)

config.log (38.9 KB) - added by raimue (Rainer Müller) 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by raimue (Rainer Müller)

Attachment: config.log added

comment:1 Changed 12 years ago by jason.dusek@…

This has come up on other systems, for example Gentoo.

comment:2 Changed 12 years ago by raimue (Rainer Müller)

Also seems to work fine after I installed boost +complete, I did not have the +complete variant at the time reporting the issue.

$ port installed boost
The following ports are currently installed:
  boost @1.35.0_2+complete+darwin_9+python25 (active)

comment:3 Changed 12 years ago by raimue (Rainer Müller)

Cc: sanchom@… added

Has duplicate #15348.

A comment there noted that reverting to boost 1.34 helps as well. Since this seems to be a problem with boost, I am cc'ing boost's maintainer.

comment:4 Changed 12 years ago by raimue (Rainer Müller)

Keywords: encfs removed
Port: encfs added

comment:5 Changed 12 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

I am unable to reproduce, seems to work now.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.