Opened 12 years ago

Closed 10 years ago

#15752 closed defect (fixed)

firefox-x11 2.0.0.13 gmake no rule to make target "config/Makefile.in", needed by "config/Makefile"

Reported by: vaneijck@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: firefox-x11

Description (last modified by jmroot (Joshua Root))

Hi,

I can't get my firefox-x11 build on Leopard Macports 1.6 (intel macbook pro). On another computer I managed to get it going with firefox 2.0.0.7 even with the "build_number" error, so I think the problem is in the Makefile and not related to the build_number.

Strangely, I've not found any bug-reports on this anywhere and I can't find any obvious reasons/problems inside the Makefile itself.

I've tried a clean+install to recompile, doesn't work. Can anyone help or suggest where to look?

thanks in advance,

Lambert van Eijck

--->  Building firefox-x11 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_firefox-x11/work/mozilla" && make all " returned error 2
Command output: cat: ./config/build_number: No such file or directory
rm -f -rf ./dist/sdk
rm -f -rf ./dist/include
/opt/local/bin/gmake -C config export
cat: ../config/build_number: No such file or directory
gmake[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_firefox-x11/work/mozilla/config'
gmake[1]: *** No rule to make target `config/Makefile.in', needed by `config/Makefile'.  Stop.
gmake[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_firefox-x11/work/mozilla/config'
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Attachments (1)

config.log (35.3 KB) - added by vaneijck@… 12 years ago.
config.log from the macports tree: firefox-x11 (mozilla subdir)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Please attach $(port work firefox-x11)/mozilla/config.log.

Changed 12 years ago by vaneijck@…

Attachment: config.log added

config.log from the macports tree: firefox-x11 (mozilla subdir)

comment:2 in reply to:  1 Changed 12 years ago by vaneijck@…

Replying to jmr@macports.org:

Please attach $(port work firefox-x11)/mozilla/config.log.

done. thanks

comment:3 Changed 12 years ago by vaneijck@…

similarly 'port install seamonkey' fails with the same error for the mozilla subdirectory.

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:5 Changed 11 years ago by tobypeterson

Keywords: intel makefile.in removed
Version: 1.6.0

Still an issue? firefox-x11 is at 3.something now

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: firefox-x11 removed
Owner: changed from macports-tickets@… to jeremyhu@…
Port: firefox-x11 added
Version: 1.6.0

comment:7 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

Closing due to age. As Toby mentioned over a year ago, we're on 3.x now (which builds fine for me)

Note: See TracTickets for help on using tickets.