Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#15817 closed defect (duplicate)

pgplot build fails on Mac OS X 10.5.4 intel

Reported by: shirose@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port:

Description

% sudo port install pgplot
--->  Fetching aquaterm
--->  Attempting to fetch aquaterm_src.1.0.1.tar.gz from http://downloads.sourceforge.net/aquaterm
--->  Verifying checksum(s) for aquaterm
--->  Extracting aquaterm
--->  Configuring aquaterm
--->  Building aquaterm with target -buildstyle Deployment -target AquaTerm
--->  Staging aquaterm into destroot
--->  Installing aquaterm 1.0.1_0
--->  Activating aquaterm 1.0.1_0
--->  Cleaning aquaterm
--->  Fetching pgplot
--->  Attempting to fetch pgplot5.2.tar.gz from ftp://ftp.astro.caltech.edu/pub/pgplot/
--->  Verifying checksum(s) for pgplot
--->  Extracting pgplot
--->  Applying patches to pgplot
--->  Configuring pgplot
--->  Building pgplot with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_Users_shirose_src_macports-trunk_dports_graphics_pgplot/work/pgplot/build:pgplot" && make all " returned error 2
Command output: /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:90: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:93: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:94: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:95: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:97: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:98: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:99: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:100: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:102: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:103: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:104: error: expected ';' before '__attribute__'
In file included from /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h:88,
                 from ../drivers/aqdriv.m:1:
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:75: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:76: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:77: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:78: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:83: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:84: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:85: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:88: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:89: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:91: error: expected ';' before '__attribute__'
In file included from /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h:127,
                 from ../drivers/aqdriv.m:1:
/System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:126: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:132: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:153: error: expected ';' before '__attribute__'
/System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:154: error: expected ';' before '__attribute__'
make: *** [aqdriv.o] Error 1

Error: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: duplicate
Status: newclosed

This is a duplicate of #14494.
Unfortunately, I am unable to add reported to CC of older ticket.
Please add yourself for any updates.

comment:3 in reply to:  2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Replying to mcalhoun@…:

Unfortunately, I am unable to add reported to CC of older ticket.

Please ignore.
Reporter added to CC of older ticket.

comment:4 Changed 12 years ago by shirose@…

Build failure with +universal (x86_64 i386):

% sudo port install pgplot +aquaterm+gcc43+universal
Password:
---> Fetching pgplot
---> Attempting to fetch pgplot522.tar.gz from ftp://ftp.astro.caltech.edu/pub/pgplot/
---> Verifying checksum(s) for pgplot
---> Extracting pgplot
---> Applying patches to pgplot
---> Configuring pgplot
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_Volumes_SSD_src_macports-trunk_dports_graphics_pgplot/work/build" && /opt/local/var/macports/build/_Volumes_SSD_src_macports-trunk_dports_graphics_pgplot/work/pgplot/makemake /opt/local/var/macports/build/_Volumes_SSD_src_macports-trunk_dports_graphics_pgplot/work/pgplot darwin --disable-dependency-tracking " returned error 1
Command output: The third argument for darwin must be one of the following configuration types:
marcports - XINCL="-I/opt/local/include -DPG_PPU -isysroot /Developer/SDKs/MacOSX10.5.sdk -I/opt/local/include"

Error: Status 1 encountered during processing.

comment:5 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.