Opened 13 years ago

Closed 11 years ago

#16006 closed defect (fixed)

texlive_base and t1utils both provide ${prefix}/bin/t1ascii

Reported by: ryandesign (Ryan Schmidt) Owned by: milosh@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: nerdling (Jeremy Lavergne), takanori@…, blb@…, bts@…
Port: texlive_base, t1utils

Description

The texlive_base and t1utils ports both provide a file called ${prefix}/bin/t1ascii. Which is authoritative? Should one of these ports not be installing this file?

Change History (10)

comment:1 Changed 12 years ago by milosh@…

Port: texlive_base t1utils added

In fact, texlive_base seems to install all that t1utils is supposed to provide (according to the web page, I don't use t1utils and hve not installed it): t1ascii, t1binary, t1asm, t1disasm, t1mac, t1unmac. I don't know if it makes sense to install them outside of texlive. If no, I suppose t1utils should be deleted. If yes, I will tell texlive not to install them.

comment:2 Changed 12 years ago by raimue (Rainer Müller)

I assume t1utils is still there for users of teTeX.

Only the port mftrace depends on texlive and t1utils. There is a pending patch at #15878.

comment:3 Changed 12 years ago by oksmith77

lilypond depends on mftrace. mftrace depends on t1utils. texlive installs the same code for t1utils independent of the the already installed port. texlive should modified so that it doesn't independently install t1utils but instead depends on t1utils in keeping with the spirit and purpose of MacPorts.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:5 Changed 12 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

Cc Me!

comment:6 Changed 12 years ago by blb@…

Cc: takanori@… blb@… added

The patch from #15878 was partially undone in r48798 as I'm guessing pTeX doesn't include the t1utils stuff. This means mftrace will again run into the texlive+t1utils conflict if kpsewhich isn't already provided by something other than texlive. Can we remove t1utils from mftrace and instead have pTeX depend on it?

comment:7 Changed 12 years ago by nerdling (Jeremy Lavergne)

Version: 1.7.01.7.1

Any updates on this?

comment:8 Changed 12 years ago by bts@…

Cc: bts@… added

Cc Me!

comment:9 in reply to:  6 Changed 11 years ago by takanori@…

Sorry, I overlooked this ticket.

Replying to blb@…:

I'm guessing pTeX doesn't include the t1utils stuff.

Right. Like teTeX, pTeX does not contain t1utils. That's why I added the dependency.

# I couldn't imagine that it cause some issue.. My bad. X-(

Can we remove t1utils from mftrace and instead have pTeX depend on it?

It sounds good. Perhaps it is the best short-term solution.

comment:10 Changed 11 years ago by takanori@…

Resolution: fixed
Status: newclosed

Fixed in r58024 and r67935.

Note: See TracTickets for help on using tickets.