Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#16062 closed defect (duplicate)

syncing fails for subversion mports tree

Reported by: jochen@… Owned by: macports-dev@…
Priority: Low Milestone:
Component: base Version: 1.6.0
Keywords: Cc:
Port:

Description

Trying to update my local tree fails with the following error

> port -dv sync
DEBUG: Synchronizing ports tree(s)
Synchronizing local ports tree from file:///Users/jochen/source/macports/dports
DEBUG: /usr/bin/svn update --non-interactive /Users/jochen/source/macports/dports
DEBUG: changing euid/egid - current euid: 957 - current egid: 700
svn: This client is too old to work with working copy '/Users/jochen/source/macports'; please get a newer Subversion client
DEBUG: shell command "/usr/bin/svn update --non-interactive /Users/jochen/source/macports/dports" returned error 1
Command output: svn: This client is too old to work with working copy '/Users/jochen/source/macports'; please get a newer Subversion client

    while executing
"system $svn_commandline"
DEBUG: Synchronization of the local ports tree failed doing an svn update
    while executing
"mportsync"
port sync failed: Synchronization of the local ports tree failed doing an svn update

because "port sync" does not obey PATH

> where svn
/opt/local/bin/svn
/usr/bin/svn
/usr/texbin/svn

How do I tell port to specifically use /opt/local/bin/svn (which is newer than the Apple supplied one)?

Change History (8)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

The problem is that macports::findBinary first tries the path that autoconf found at build time. That's usually a good thing (consistency), but not in this case. Try removing the ${macports::autoconf::svn_path} from macports.tcl line 1379 (trunk), or line 1317 (1.6.0).

comment:2 Changed 13 years ago by jochen@…

Can I do this in the live system, or do I have to reinstall MacPorts afterward again?

I have changed it in the two files

/Volumes/Users/jochen/source/macports/base/src/macports1.0/macports.tcl
/opt/local/var/macports/sources/rsync.macports.org/release/base/src/macports1.0/macports.tcl

but still get the same error

comment:3 Changed 13 years ago by raimue (Rainer Müller)

You have to edit /Library/Tcl/macports1.0/macports_autoconf.tcl. Of course this will get overwritten if you install again.

You can also use

SVN=/opt/local/bin/svn ./configure --prefix=/opt/local

if you are doing a source install.

comment:4 Changed 13 years ago by jochen@…

Ok, so I have edited

/Library/Tcl/macports1.0/macports_autoconf.tcl

to change svn_path to the following

variable svn_path "/opt/local/bin/svn"

That works... It would be nice to get this generally fixed for the next release, though.

Thank you for your help.

comment:5 in reply to:  4 Changed 13 years ago by afb@…

Priority: NormalLow

Replying to jochen@macports.org:

It would be nice to get this generally fixed for the next release, though.

What would be the "general fix" ? Move from configure to macports.conf, or ?

comment:6 Changed 13 years ago by afb@…

Resolution: duplicate
Status: newclosed

This is the same issue as #15868

comment:7 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:8 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.