Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#16298 closed enhancement (duplicate)

Control of dependencies for Macports

Reported by: mcklaren@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: Cc:
Port:

Description

Macports should has a better control of dependencies when we like uninstall a program. For example if i like install the packages foo, i do sudo port install foo and automaticly install all dependencies necesary for the package perfect but if Do i like uninstall the packages ? sudo port uninstall foo only deinstall foo but i before in the install foo to installed B,C,D macports should deinstall (for example with the option sudo port uninstall --with-unused-dependencies foo) B,C,D always that this dependencies isn't used by other packages. With this option we can have a system very clean of unused dependencies.

I think that this option it can add in futures version of macports if is possible. Thank you very much.

Change History (2)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Type: defectenhancement

Duplicate of #15260.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.