Opened 17 years ago

Closed 16 years ago

#1638 closed defect (duplicate)

kdebase3 fails to compile

Reported by: ian@… Owned by: ranger@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

kdebase3 fails to compile in the current dport. Text of error messages follows. All deps compiled and installed without any problem.


---> Fetching kdebase3 ---> Attempting to fetch kdebase-3.1.2.tar.bz2 from http://ftp.rutgers.edu/pub/kde/stable/3.1.2/ src ---> Attempting to fetch kde-admindir-20030601.tar.bz2 from http://ranger.befunk.com/fink/ ---> Attempting to fetch detect-autoconf.tar.bz2 from http://ranger.befunk.com/darwin/ ---> Verifying checksum for kdebase3 ---> Extracting kdebase3 ---> Configuring kdebase3 ---> Building kdebase3 with target all apidox Error: Target com.apple.build returned: shell command "cd "/Users/marlier/darwinports/dports/x11/ kdebase3/work/kdebase-3.1.2" && CPPFLAGS='-I/usr/X11R6/include -I/usr/include -I/usr/include/ qt3 -no-cpp-precomp -fno-common' LDFLAGS='-L/usr/X11R6/lib' LIBS='-L/usr/lib' DYLD_LIBRARY_PATH='/usr/lib' make all apidox" returned error 2 Command output: In file included from favicons.cpp:34: /usr/include/kio/job.h:151: error: declaration of C function `KIO::StatJob*

KIO::stat(const KURL&, bool, short int, bool = true)' conflicts with

/usr/include/kio/job.h:136: error: previous declaration `KIO::StatJob*

KIO::stat(const KURL&, bool = true)' here

/usr/include/kio/job.h:290: error: declaration of C function `KIO::CopyJob*

KIO::copy(const KURL::List&, const KURL&, bool = true)' conflicts with

/usr/include/kio/job.h:276: error: previous declaration `KIO::CopyJob*

KIO::copy(const KURL&, const KURL&, bool = true)' here

/usr/include/kio/job.h:303: error: declaration of C function `KIO::CopyJob*

KIO::move(const KURL::List&, const KURL&, bool = true)' conflicts with

/usr/include/kio/job.h:295: error: previous declaration `KIO::CopyJob*

KIO::move(const KURL&, const KURL&, bool = true)' here

/usr/include/kio/job.h:318: error: declaration of C function `KIO::CopyJob*

KIO::link(const KURL::List&, const KURL&, bool = true)' conflicts with

/usr/include/kio/job.h:313: error: previous declaration `KIO::CopyJob*

KIO::link(const KURL&, const KURL&, bool = true)' here

/usr/include/kio/job.h:333: error: declaration of C function `KIO::DeleteJob*

KIO::del(const KURL::List&, bool = false, bool = true)' conflicts with

/usr/include/kio/job.h:332: error: previous declaration `KIO::DeleteJob*

KIO::del(const KURL&, bool = false, bool = true)' here

In file included from /usr/include/kdedmodule.h:27,

from favicons.h:24, from favicons.moc:11, from favicons.cpp:36:

/usr/include/ksharedptr.h:97: error: template with C linkage make[3]: * [favicons.lo] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Change History (2)

comment:1 Changed 17 years ago by toby@…

Owner: changed from darwinports-bugs@… to ranger@…

comment:2 Changed 16 years ago by toby@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 578 *

Note: See TracTickets for help on using tickets.