Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16414 closed defect (duplicate)

mjpegtools FTBFS motionsearch

Reported by: liontooth@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: filippo.natali@…
Port: mjpegtools

Description (last modified by jmpp@…)

# uname -a
Darwin dcl01 9.4.0 Darwin Kernel Version 9.4.0: Mon Jun  9 19:30:53 PDT 2008; root:xnu-1228.5.20~1/RELEASE_I386 i386
# port install mjpegtools
--->  Fetching mjpegtools
--->  Verifying checksum(s) for mjpegtools
--->  Extracting mjpegtools
--->  Applying patches to mjpegtools
--->  Configuring mjpegtools
--->  Building mjpegtools with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_mjpegtools/work/mjpegtools-1.6.2" && make all LIBTOOL=/opt/local/bin/glibtool ASFLAGS="-f macho" " returned error 2
Command output:         fi
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../utils  -I/opt/local/include -L/opt/local/lib  -O2 -L/opt/local/lib -Wall -Wunused -MT mpegtimecode.o -MD -MP -MF ".deps/mpegtimecode.Tpo" \
          -c -o mpegtimecode.o `test -f 'mpegtimecode.c' || echo './'`mpegtimecode.c; \
        then mv -f ".deps/mpegtimecode.Tpo" ".deps/mpegtimecode.Po"; \
        else rm -f ".deps/mpegtimecode.Tpo"; exit 1; \
        fi
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../utils  -I/opt/local/include -L/opt/local/lib  -O2 -L/opt/local/lib -Wall -Wunused -MT yuv4mpeg.o -MD -MP -MF ".deps/yuv4mpeg.Tpo" \
          -c -o yuv4mpeg.o `test -f 'yuv4mpeg.c' || echo './'`yuv4mpeg.c; \
        then mv -f ".deps/yuv4mpeg.Tpo" ".deps/yuv4mpeg.Po"; \
        else rm -f ".deps/yuv4mpeg.Tpo"; exit 1; \
        fi
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../utils  -I/opt/local/include -L/opt/local/lib  -O2 -L/opt/local/lib -Wall -Wunused -MT yuv4mpeg_ratio.o -MD -MP -MF ".deps/yuv4mpeg_ratio.Tpo" \
          -c -o yuv4mpeg_ratio.o `test -f 'yuv4mpeg_ratio.c' || echo './'`yuv4mpeg_ratio.c; \
        then mv -f ".deps/yuv4mpeg_ratio.Tpo" ".deps/yuv4mpeg_ratio.Po"; \
        else rm -f ".deps/yuv4mpeg_ratio.Tpo"; exit 1; \
        fi
rm -f libmjpegutils.a
ar cru libmjpegutils.a mjpeg_logging.o mpegconsts.o mpegtimecode.o yuv4mpeg.o yuv4mpeg_ratio.o 
ranlib libmjpegutils.a
if /opt/local/bin/glibtool --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../utils  -I/opt/local/include -L/opt/local/lib  -O2 -L/opt/local/lib -Wall -Wunused -MT motionsearch.lo -MD -MP -MF ".deps/motionsearch.Tpo" \
          -c -o motionsearch.lo `test -f 'motionsearch.c' || echo './'`motionsearch.c; \
        then mv -f ".deps/motionsearch.Tpo" ".deps/motionsearch.Plo"; \
        else rm -f ".deps/motionsearch.Tpo"; exit 1; \
        fi
glibtool: compile: unable to infer tagged configuration
glibtool: compile: specify a tag with `--tag'
make[3]: *** [motionsearch.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Keywords: ticketformatting added

comment:2 Changed 13 years ago by jmpp@…

Description: modified (diff)
Keywords: ticketformatting removed

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Port: mjpegtools added
Resolution: duplicate
Status: newclosed

Looks like a duplicate of #12961.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.