Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16609 closed submission (fixed)

snoopy-2.9.95 Warcraft III Hosting Utility

Reported by: pandagoat@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: warcraft banlist autorefresher Cc:
Port: snoopy

Description

A program to help people host Warcraft III games but more generally, play Warcraft III. It has many utilities if you host or do not.

Attachments (3)

snoopy.tcl (1.0 KB) - added by pandagoat@… 13 years ago.
portfile
Portfile.diff (1.9 KB) - added by ryandesign (Ryan Schmidt) 13 years ago.
Portfile-snoopy.diff (1.9 KB) - added by pandagoat@… 12 years ago.
Patch file for a newer version of snoopy. I was not sure if the patch needed to patch the very first Portfile I submitted or the newest patched Portfile. So this patch is for the original that I submitted. I removed the applying the .diff for brain.c since I have the fix in the code.

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by pandagoat@…

Attachment: snoopy.tcl added

portfile

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Port: snoopy added
Status: newassigned

Changed 13 years ago by ryandesign (Ryan Schmidt)

Attachment: Portfile.diff added

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Thanks for the new port! I committed it in r40136, however I did have to make substantial changes. The file you submitted didn't even pass a port lint check, much less build the software correctly (at least not for me on a MacBook Pro with Mac OS X 10.4.11, Xcode 2.5 and MacPorts 1.6.0). I consulted Snoopy's Installing on Mac OS X page to make my changes.

  • changed glib2-devel dependency to glib2 (unless there was a reason you needed the development version of glib2 instead of the stable one?)
  • added dependencies on gettext and libiconv because snoopy-nox does link with them
  • added dependency on dsniff to get tcpkill
  • added dependency on latest gcc available in MacPorts
  • removed invalid configure phase (you probably meant this to be configure.env instead of configure but the LIBS declaration is unnecessary and the CC declaration is better handled via configure.compiler
  • added patch to fix 'PTRACE_ATTACH' undeclared error (even though 2.9.95 already includes the patch given on the page; not sure why it doesn't work)
  • obfuscated maintainer email
  • added rmd160 checksum
  • fixed typo in long description
  • removed invalid master site
  • added livecheck

I attached a full diff of exactly what I changed.

comment:3 in reply to:  2 Changed 13 years ago by pandagoat@…

Replying to ryandesign@…: Thanks I did not really know what I was doing. For example, I though glib2-devel is the development package (to compile things using glib2) and just glib2 is the static libraries. I have no practical access to a mac and am ignorant about macs, and people were asking how to compile snoopy on their mac, but the process is complicated; so, I wanted to try mac ports, and I just submitted something to see what happens.

I was not expecting this; I really appreciate you fixing it for me and accepting the submission :).

Thanks, again.

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

You did remarkably well for not having access to a Mac to test it on. :)

-devel packages are different in MacPorts than they are in some other package managers. Documentation about this has unfortunately not made it into the Guide yet, but you can read about it in ticket #14540.

MacPorts can actually be installed on operating systems other than Mac OS X, but most port maintainers only test on Mac OS X so some ports might not work on other OSes. In fact I just changed snoopy in r40147 so that we only apply the Mac-specific patch on Mac OS X...

comment:5 in reply to:  4 Changed 13 years ago by pandagoat@…

There have been a few people unable to get this to work. One person has this: ---> Configuring expat Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man " returned error 77 Command output: checking build system type... powerpc-apple-darwin9.4.0 checking host system type... powerpc-apple-darwin9.4.0 checking for gcc... /usr/bin/gcc-4.0 checking for C compiler default output file name... configure: error: C compiler cannot create executables See `config.log' for more details.

Error: The following dependencies failed to build: dsniff libnet libtool automake autoconf help2man gettext expat libiconv gperf ncurses ncursesw p5-locale-gettext perl5.8 m4 netinet-headers libnids libpcap gcc43 gmp mpfr glib2 pkgconfig libgeoip Error: Status 1 encountered during processing.

Another has a more massive output when compiling gcc 4.3: % sudo port install snoopy ---> Building gcc43 with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build" && make all " returned error 2 Command output: LIBCXXFLAGS="-O2 -g -O2 -fno-implicit-templates ${flags}" \

LDFLAGS=" ${flags}" \ MULTIFLAGS="${flags}" \ DESTDIR="" \ INSTALL="/usr/bin/install" \ INSTALL_DATA="/usr/bin/install -m 644" \ INSTALL_PROGRAM="/usr/bin/install" \ INSTALL_SCRIPT="/usr/bin/install" \ all); then \

true; \

else \

exit 1; \

fi; \

else true; \ fi; \

fi; \

done; \

fi

make[5]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build/i386-apple-darwin8.11.1/x86_64/libgcc' make[5]: * No rule to make target `all'. Stop. make[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build/i386-apple-darwin8.11.1/x86_64/libgcc' make[4]: * [multi-do] Error 1 make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build/i386-apple-darwin8.11.1/libgcc' make[3]: * [all-multi] Error 2 make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build/i386-apple-darwin8.11.1/libgcc' make[2]: * [all-stage1-target-libgcc] Error 2 make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build' make[1]: * [stage1-bubble] Error 2 make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc43/work/build' make: * [all] Error 2

Error: The following dependencies failed to build: gcc43 Error: Status 1 encountered during processing.

I'm not sure what the problem is. Is it a problem with the portfile or a problem with gcc 4.3 in macports?

comment:6 Changed 13 years ago by blb@…

The message

checking for C compiler default output file name... configure: error: C compiler cannot create executables

usually indicates Xcode is not installed, since MacPorts builds from source it is needed.

Can't say about the gcc43 error, looks like the actual error message was probably lost without debug output. Using sudo port -d install gcc43 should reveal the actual error.

comment:7 Changed 13 years ago by ryandesign (Ryan Schmidt)

Enclose literal output in {{{ and }}} so it doesn't get mangled. See WikiFormatting.

I agree with Bryan: the first user needs to install Xcode. The second user I don't know, but the failing port is gcc43, not snoopy, so file a ticket against gcc43 or ask on the mailing list.

This ticket -- to create a port for snoopy -- has been resolved. If there are any issues with the port or feature requests, file new tickets.

Changed 12 years ago by pandagoat@…

Attachment: Portfile-snoopy.diff added

Patch file for a newer version of snoopy. I was not sure if the patch needed to patch the very first Portfile I submitted or the newest patched Portfile. So this patch is for the original that I submitted. I removed the applying the .diff for brain.c since I have the fix in the code.

comment:8 Changed 12 years ago by pandagoat@…

I've released 2.9.97 now. It seems no one saw the patch I made for 2.9.96, so I will not make one this time and just post this. Could you update the portfile to this? Nothing needs to be changed except the version, checksums, and removing the brain_portability.diff.

comment:9 Changed 12 years ago by raimue (Rainer Müller)

Please open new tickets for Port Updates. This one is marked closed and therefore it's not likely a committer notices it.

comment:10 Changed 12 years ago by jmroot (Joshua Root)

Type: enhancementsubmission

comment:11 Changed 12 years ago by (none)

Milestone: Port Submissions

Milestone Port Submissions deleted

Note: See TracTickets for help on using tickets.