Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16688 closed defect (fixed)

gail +quartz conflicts with gtk2 +quartz

Reported by: mf2k (Frank Schima) Owned by: nox@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: vincent-opdarw@…
Port: gail, gtk2

Description

I'm attempting to install gail +quartz but there appears to be a conflict with gtk2 +quartz.

Here is the output:

--->  Activating gail @1.22.1_0+quartz
Error: Target org.macports.activate returned: Image error: /opt/local/include/gail-1.0/gail/gailwidget.h is being used by the active gtk2 port.  Please deactivate this port first, or use the -f flag to force the activation.
Error: Status 1 encountered during processing.
$ port installed gtk2
The following ports are currently installed:
  gtk2 @2.14.3_0+no_x11+quartz (active)

Change History (7)

comment:1 Changed 13 years ago by nox@…

Cc: vincent-opdarw@… added

GAIL has been incorporated in GTK+ 2.14. This port needs to be removed. For the time being you should just force the activation.

Added libgtkhtml maintainer to cc

comment:2 Changed 13 years ago by nox@…

Status: newassigned

comment:3 Changed 13 years ago by mf2k (Frank Schima)

libgnomecanvas also depends on gail.

comment:4 Changed 13 years ago by nox@…

I know, but it has no maintainer.

comment:5 Changed 13 years ago by nox@…

comment:6 Changed 13 years ago by nox@…

Resolution: fixed
Status: assignedclosed

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.