Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#16701 closed defect (duplicate)

port upgrade installed memory not releasing (PPC)

Reported by: artrigue@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: Cc:
Port:

Description

with -d I don´t see anything particular going on, it just keeps running until suddenly it stops:

DEBUG: epoch: in tree: 0 installed: 0
DEBUG: nspr 4.7_1 exists in the ports tree
DEBUG: nspr 4.7_1 is installed
DEBUG: No need to upgrade! nspr 4.7_1 >= nspr 4.7_1
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/databases/db46
tclsh(6113,0xa000ed88) malloc: *** vm_allocate(size=475136) failed (error code=3)
tclsh(6113,0xa000ed88) malloc: *** error: can't allocate region
tclsh(6113,0xa000ed88) malloc: *** set a breakpoint in szone_error to debug
unable to alloc 471346 bytes

The thing is, watching my memory usage, with istat widget, while it runs, it looks like no memory is being used at all until suddenly, it spikes. (this takes a while, I just check in every 15 minutes) Its not a slow rampup on the graph, it is flat until it spikes.

Another thing, I just want to check because its big, look at that malloc. Does it request half a meg each port, just to verify port versions?

sudo port selfupdate
Password for admin: 

MacPorts base version 1.600 installed

Downloaded MacPorts base version 1.600

The MacPorts installation is not outdated and so was not updated
selfupdate done!

I tried tcl just at 8.5.4 and with the +memdebug +threads ... just hoping that might be the issue.

Change History (7)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: artrigue@… removed
Milestone: Port BugsMacPorts base bugs
Priority: HighNormal

Port(1) always runs with /usr/bin/tclsh, so it's not going to be using Tcl 8.5.4 without some hackery.

comment:2 Changed 12 years ago by artrigue@…

hmmm, well I posted that bit because I had just read a previous ticket with memory issues with port where someone suggested updating tcl to 8.5.4 and trying again.. and the submitter responded that it worked.

Do you know how I can check the tclsh version in /usr/bin ..? To late tonight for me to fidget with it, maybe tomorrow :)

comment:3 Changed 12 years ago by blb@…

Using

echo 'puts $tcl_patchLevel' | /usr/bin/tclsh

should tell you Tcl's version (8.4.7 if you're on 10.5).

Note that the +memdebug is really only useful for actually tracking down memory issues. After having tried to use it some with port, and having it generate many, many megs of output, I put it on the back burner.

comment:4 in reply to:  3 Changed 12 years ago by artrigue@…

Replying to blb@…

I did have a 8.4 release ... although this is 10.4.11. I have rerun it with the tcl I´d gotten from ports, but it looks to have the same issue, with maybe one and a half gigs of ram tied up right now. It hasnt spiked quite as fast on the graphic... that makes me think I just didnt view the memory chart often enough last time: it does only update while you are watching it — kinda a useful feature.

Thank you for the insight on memdebug, I´ll remove that!

comment:5 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:6 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #12022.

comment:7 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.