Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#16861 closed enhancement (wontfix)

[ruby] Please revert lang/ruby to 1.8.6p287

Reported by: roberto@… Owned by: kimuraw (kimura wataru)
Priority: High Milestone:
Component: ports Version: 1.6.0
Keywords: ruby Cc: febeling@…, raimue (Rainer Müller)
Port: ruby

Description

1.8.7 is a version that should probable never been released at all, incorporating language changes from 1.9 that many people/software are not really ready to embrace, use and support. There is a consensus on the ruby-talk list about that (see http://www.ruby-forum.com/topic/168054 as an example).

Latest is p287 in the 1.8.6 line.

Thanks.

Change History (14)

comment:1 Changed 10 years ago by myschizobuddy@…

if there is consensus then Ruby developers should issue a statement that 1.8.6p287 is the latest stable and you shouldn't use 1.8.7. So far they haven't done that.

comment:2 Changed 10 years ago by febeling@…

Owner: changed from macports-tickets@… to kimuraw@…

comment:3 Changed 10 years ago by febeling@…

Port: ruby added

comment:4 Changed 10 years ago by febeling@…

Cc: febeling@… added

Cc Me!

comment:5 Changed 10 years ago by kimuraw (kimura wataru)

Status: newassigned

I've accepted this ticket.

I think it is better to enable to select 1.8.7 or 1.8.6 than revert to 1.8.6. I'll try to support 1.8.6 with macports.

comment:6 Changed 10 years ago by roberto@…

I can live with the choice, could you make 1.8.6 the default again? Regards.

comment:7 Changed 10 years ago by febeling@…

I'm not entirely convinced that we should revert, but I don't feel sure either. The whole stable/unstable release issue with ruby is quite opaque to me. I was always wondering if you get better insights if you speak Japanese and can read the original list, but we have somebody who can :)

Now the question is how to resolve the problem with port sporting deps like port:ruby. Using a variant or using some sort of proxy port file which only consists out of 2 mutually exclusive variants. Maybe plain variants are just easier, but I read once on the list that it is not acceptable to install differnt version depending on variant. Can't fully recall the reasoning, unfortunately.

I once submitted a portgroup for proxy port file, will port the link in a bit.

comment:8 Changed 10 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Instead of port:ruby you could use bin:${prefix}/bin/ruby:ruby, which means the ruby binary could be provided by another port. But that would require changing all dependencies.

comment:9 in reply to:  7 Changed 10 years ago by febeling@…

#16336 is the ticket discussing the problem of multiple port, including two possible solutions as patches. I do realize it is not an immediate solution :)

comment:10 Changed 10 years ago by wsiegrist@…

FWIW, We noticed a significant performance regression between 1.8.6-p114 and 1.8.7-p72 when using Rails 2.1.

comment:11 Changed 10 years ago by febeling@…

I raised concerns with this downgrade, but I wasn't aware that Rails doesn't work with it, duh. So maybe we should really downgrade. Additionally we could make 1.8.7 become ruby-devel, a variation that is used elsewhere. I seem to remember we didn't want variants that effect to installing a different version of the same package, but I don't know where exactly.

To become more specific, Rails <2.1.2 had this problem using ruby187:

http://rails.lighthouseapp.com/projects/8994/tickets/867-undefined-method-length-for-enumerable

Current rails port is 2.1.0, which is from end of may. So current rails and ruby don't match. :/

Rails officially recommends 1.8.6 therefore as well. There is a strong case for downgrading now, imho.

http://www.rubyonrails.org/down

comment:12 Changed 10 years ago by blb@…

There is now a ruby186 port (added in r45292), which can be used if necessary.

comment:13 Changed 9 years ago by febeling@…

Resolution: wontfix
Status: assignedclosed

With the ruby186 port in place this should be closed I guess.

comment:14 Changed 9 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.