Opened 13 years ago

Closed 3 years ago

Last modified 3 years ago

#16954 closed defect (duplicate)

rsync always used for selfupdate, which has issues when behind a firewall

Reported by: asbjorn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: rsync svn update selfupdate sync Cc: cooljeanius (Eric Gallager)
Port:

Description

I've followed the description given in How to use svn for syncing the ports tree and while port -d sync yields:

EBUG: Synchronizing ports tree(s)
Synchronizing local ports tree from file:///opt/local/var/macports/sources/svn.macports.org/trunk/dports
DEBUG: /usr/bin/svn update --non-interactive /opt/local/var/macports/sources/svn.macports.org/trunk/dports
DEBUG: changing euid/egid - current euid: 0 - current egid: 0

Fetching external item into '/opt/local/var/macports/sources/svn.macports.org/trunk/dports/sysutils/MacPorts/files'
External at revision 41076.

At revision 41076.

MacPorts still seems to be updating through rsync:

DEBUG: Rebuilding the MacPorts base system if needed.
DEBUG: Synchronizing ports tree(s)
Synchronizing local ports tree from file:///opt/local/var/macports/sources/svn.macports.org/trunk/dports
DEBUG: /usr/bin/svn update --non-interactive /opt/local/var/macports/sources/svn.macports.org/trunk/dports
DEBUG: changing euid/egid - current euid: 0 - current egid: 0

Fetching external item into '/opt/local/var/macports/sources/svn.macports.org/trunk/dports/sysutils/MacPorts/files'
External at revision 41076.

At revision 41076.
DEBUG: MacPorts base dir: /opt/local/var/macports/sources/rsync.macports.org/release/base
DEBUG: Setting user: root

MacPorts base version 1.600 installed
DEBUG: Updating using rsync
rsync: failed to connect to rsync.macports.org: Operation timed out (60)
rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-35.2/rsync/clientserver.c(105) [receiver=2.6.9]
DEBUG: Error: rsync failed in selfupdate
    while executing
"macports::selfupdate [array get global_options]"
Error: /opt/local/bin/port: port selfupdate failed: Error: rsync failed in selfupdate

Why is this? How can I avoid rsync alltogether? I'm behind a firewall and would like MacPorts to update through svn instead of rsync (or at least rsync against my locally svn-updated repository) since rsync won't work.

Change History (6)

comment:1 Changed 13 years ago by blb@…

Component: portsbase
Summary: rsync behind firewall problemrsync always used for selfupdate, which has issues when behind a firewall

Was the latter output from running selfupdate? I believe that it still uses rsync regardless of how you have the ports tree installed on your system. At least if I'm reading the source right.

Since you're running MacPorts 1.6, selfupdate won't be doing anything right now since that's the current versioned release. Long term, syncing for selfupdate via other means should be supported.

comment:2 Changed 13 years ago by asbjorn@…

Yes, the latter is output from selfupdate. I thought that selfupdate was required to be in sync with the latest ports, but obviously that's not the case(?). I'll be looking forward to a future version of MacPorts that can sync directly for selfupdate via SVN, then. Thanks!

comment:3 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:4 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 3 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #38265.

comment:6 Changed 3 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.