Opened 13 years ago

Closed 12 years ago

#17059 closed defect (invalid)

py-setuptools confused about MACOSX_DEPLOYMENT_TARGET

Reported by: yaseppochi (Stephen J. Turnbull) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: py-setuptools

Description

Mac OS X 10.4.11 on PPC (iBook G4)
May have been 10.3 in the distant past but I think it was acquired with 10.4 on it.

Python versions available (I don't know what port would find):

chibi:MacPorts steve$ which python
/opt/local/bin/python
chibi:MacPorts steve$ ls -l `which python`
lrwxr-xr-x   1 steve  staff  24 Oct  9 23:45 /opt/local/bin/python -> /opt/local/bin/python2.4
chibi:MacPorts steve$ which python2.2
no python2.2 in /usr/local/bin /opt/local/bin /opt/local/sbin /usr/X11R6/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/texbin
chibi:MacPorts steve$ which python2.3
/opt/local/bin/python2.3
chibi:MacPorts steve$ which python2.4
/opt/local/bin/python2.4
chibi:MacPorts steve$ which python2.5
/opt/local/bin/python2.5
chibi:MacPorts steve$ which python2.6
no python2.6 in /usr/local/bin /opt/local/bin /opt/local/sbin /usr/X11R6/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/texbin
chibi:MacPorts steve$ which python3.0
no python3.0 in /usr/local/bin /opt/local/bin /opt/local/sbin /usr/X11R6/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/texbin
chibi:MacPorts steve$ ls {/bin,/usr/bin,/usr/local/bin}/*python*
ls: /bin/*python*: No such file or directory
ls: /usr/local/bin/*python*: No such file or directory
/usr/bin/python         /usr/bin/pythonw
/usr/bin/python2.3      /usr/bin/pythonw2.3

Error from "port upgrade py-setuptools":

chibi:MacPorts steve$ port upgrade py-setuptools
--->  Fetching py-setuptools
--->  Verifying checksum(s) for py-setuptools
--->  Extracting py-setuptools
--->  Applying patches to py-setuptools
--->  Configuring py-setuptools
--->  Building py-setuptools
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_Users_steve_Software_MacPorts_dports_python_py-setuptools/work/setuptools-0.6c8" && /opt/local/bin/python2.4 setup.py build " returned error 1
Command output: Traceback (most recent call last):
  File "setup.py", line 7, in ?
    execfile(convert_path('setuptools/command/__init__.py'), d)
  File "setuptools/command/__init__.py", line 13, in ?
    from distutils.command.bdist import bdist
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/distutils/command/bdist.py", line 29, in ?
    class bdist (Command):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/distutils/command/bdist.py", line 33, in bdist
    user_options = [('bdist-base=', 'b',
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/distutils/util.py", line 78, in get_platform
    cfgvars = get_config_vars()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/distutils/sysconfig.py", line 488, in get_config_vars
    func()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/distutils/sysconfig.py", line 373, in _init_posix
    raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.4" but "10.3" during configure

Error: Unable to upgrade port: 1

Change History (8)

comment:1 Changed 13 years ago by yaseppochi (Stephen J. Turnbull)

Oh, yeah, this is port from subversion last updated on August 3, 2008, and all installed ports are current from subversion as of October 30, except py-setuptools and ghc.

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Did you build python24 with MP 1.6? Trunk sets MDT to the OS version it's running on, whereas 1.6 doesn't set it, so python probably defaults to 10.3.

comment:3 Changed 13 years ago by yaseppochi (Stephen J. Turnbull)

I don't think so. All my MacPorts pythons were built in 2008, python2.3 in March, python2.4 in July, python2.5 in August. I've been running port from subversion, updated every month or so, on this box since day 1.

How do I find out what Python thinks it is?

comment:4 Changed 13 years ago by jmroot (Joshua Root)

Looks like the definition is stored in /opt/local/lib/python2.4/config/Makefile.

comment:5 Changed 13 years ago by yaseppochi (Stephen J. Turnbull)

OK, the definition from configure stored in .../python2.4/config/Makefile was MACOSX_DEPLOYMENT_TARGET=10.3. I've just started a "port -f upgrade python24", and confirmed that in the configure'd Makefile, MACOSX_DEPLOYMENT_TARGET=10.4.

"To everything (churn, churn, churn) there is a reason (churn, churn, churn)," and with the musical interlude and the Python upgrade finished, the value in .../python2.4/config/Makefile now is MACOSX_DEPLOYMENT_TARGET=10.4, and I've confirmed that py-setuptools (and bittorrent, which now fails the same way) can be "port upgrade"ed successfully.

Thank you for your help with this issue!

I can't explain why MACOSX_DEPLOYMENT_TARGET=10.3 was in an installation less than 5 months old when this system has been running 10.4 for at least 18 months. Maybe it used to be overridden/hardcoded in older versions of port and/or the Portfile?

comment:6 Changed 13 years ago by blb@…

My guess is that when you first built python24, that was before port explicitly set MDT, so python24 probably set it to 10.3 (which is the good minimum value to use for MDT).

comment:7 Changed 13 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Looks like this was fixed by rebuilding python24.

Note: See TracTickets for help on using tickets.