Opened 12 years ago

Closed 12 years ago

#17173 closed defect (invalid)

kdelibs 3.5.8-3 Build error - linking problems

Reported by: coleman@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: coleman@…
Port: kdelibs3

Description

I am ultimately trying to build kcachegrind but it looks like kdelibs3 has a problem. I noticed there are other bugs submitted relating to 3.5.8 but different build errors so I created a new ticket. Please label as a duplicate is this is improper etiquette.

Here is the summarized build log for kdelibs3

[ SNIP ]

Command output: 22% linking ./kdecore/libkdecore.la
/bin/sh ./libtool --mode=link --tag=CXX g++ -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Os -Os -fPIC -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -fvisibility=hidden -fvisibility-inlines-hidden -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DQT_THREAD_SUPPORT -I/usr/include/gssapi -I/opt/local/include/freetype2 -I/opt/local/include -fno-common -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/opt/local/include -I/usr/X11R6/include -L/opt/local/lib -Wl,-dylib_file,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib -L/opt/local/lib/qt3/lib -R /opt/local/lib -R /opt/local/lib -R /opt/local/lib/qt3/lib -R /usr/X11/lib -R /opt/local/lib -L/usr/X11/lib -L/opt/local/lib -version-info 6:0:2 -no-undefined -o ./kdecore/libkdecore.la -rpath /opt/local/lib ./kdecore/malloc/libklmalloc.la ./kdecore/network/libkdecorenetwork.la ./kdecore/svgicons/libkdesvgicons.la -lz ./dcop/libDCOP.la ./libltdl/libltdlc.la -lXext -lresolv -lutil -L/opt/local/lib -lart_lgpl_2 -lm -lidn ./kdefx/libkdefx.la -lz ./kdecore/libintl.lo ./kdecore/kapplication.lo ./kdecore/kdebug.lo ./kdecore/netwm.lo ./kdecore/kconfigbase.lo ./kdecore/kconfig.lo ./kdecore/ksimpleconfig.lo ./kdecore/kconfigbackend.lo ./kdecore/kmanagerselection.lo ./kdecore/kdesktopfile.lo ./kdecore/kstandarddirs.lo ./kdecore/ksock.lo ./kdecore/kpty.lo ./kdecore/kprocess.lo ./kdecore/kprocctrl.lo ./kdecore/klocale.lo ./kdecore/krfcdate.lo ./kdecore/kiconeffect.lo ./kdecore/kicontheme.lo ./kdecore/kiconloader.lo ./kdecore/kwin.lo ./kdecore/kwinmodule.lo ./kdecore/krootprop.lo ./kdecore/kcharsets.lo ./kdecore/kckey.lo ./kdecore/kshortcut.lo ./kdecore/kkeynative_x11.lo ./kdecore/kkeyserver_x11.lo ./kdecore/kaccelaction.lo ./kdecore/kshortcutmenu.lo ./kdecore/kaccelbase.lo ./kdecore/kaccel.lo ./kdecore/kglobalaccel_x11.lo ./kdecore/kglobalaccel.lo ./kdecore/kstdaccel.lo ./kdecore/kshortcutlist.lo ./kdecore/kcrash.lo ./kdecore/kurl.lo ./kdecore/kregexp.lo ./kdecore/kglobal.lo ./kdecore/kglobalsettings.lo ./kdecore/kallocator.lo ./kdecore/kvmallocator.lo ./kdecore/kmimesourcefactory.lo ./kdecore/kinstance.lo ./kdecore/kpalette.lo ./kdecore/kipc.lo ./kdecore/klibloader.lo ./kdecore/ktempfile.lo ./kdecore/kuniqueapplication.lo ./kdecore/kaccelmanager.lo ./kdecore/ksavefile.lo ./kdecore/krandomsequence.lo ./kdecore/kstringhandler.lo ./kdecore/kcompletion.lo ./kdecore/kcmdlineargs.lo ./kdecore/kaboutdata.lo ./kdecore/kcompletionbase.lo ./kdecore/knotifyclient.lo ./kdecore/kaudioplayer.lo ./kdecore/kdcoppropertyproxy.lo ./kdecore/ksockaddr.lo ./kdecore/kextsock.lo ./kdecore/netsupp.lo ./kdecore/kprocio.lo ./kdecore/kbufferedio.lo ./kdecore/kpixmapprovider.lo ./kdecore/kurldrag.lo ./kdecore/kmdcodec.lo ./kdecore/ksocks.lo ./kdecore/ksycoca.lo ./kdecore/ksycocadict.lo ./kdecore/ksycocafactory.lo ./kdecore/ksycoca_skel.lo ./kdecore/kxmessages.lo ./kdecore/kstartupinfo.lo ./kdecore/kcatalogue.lo ./kdecore/kasyncio.lo ./kdecore/kmultipledrag.lo ./kdecore/kstaticdeleter.lo ./kdecore/kappdcopiface.lo ./kdecore/kappdcopiface_skel.lo ./kdecore/kclipboard.lo ./kdecore/kcheckaccelerators.lo ./kdecore/kdeversion.lo ./kdecore/kdebugdcopiface.lo ./kdecore/kdebugdcopiface_skel.lo ./kdecore/kcalendarsystem.lo ./kdecore/kcalendarsystemgregorian.lo ./kdecore/kcalendarsystemhijri.lo ./kdecore/kcalendarsystemhebrew.lo ./kdecore/kcalendarsystemfactory.lo ./kdecore/kmacroexpander.lo ./kdecore/kidna.lo ./kdecore/ktempdir.lo ./kdecore/kshell.lo ./kdecore/kmountpoint.lo ./kdecore/kcalendarsystemjalali.lo ./kdecore/kprotocolinfo_kdecore.lo ./kdecore/kprotocolinfofactory.lo ./kdecore/kxerrorhandler.lo ./kdecore/kuser.lo ./kdecore/kconfigskeleton.lo ./kdecore/kconfigdialogmanager.lo ./kdecore/klockfile.lo ./kdecore/kqiodevicegzip_p.lo ./kdecore/ktimezones.lo ./kdecore/fakes.lo ./kdecore/vsnprintf.lo -L/opt/local/lib -L/usr/X11R6/lib
libtool: link: warning: `/opt/local/lib/libqt-mt.la' seems to be moved
libtool: link: warning: `/opt/local/lib/libqt-mt.la' seems to be moved
rm -fr ./kdecore/.libs/libkdecore.lax
mkdir ./kdecore/.libs/libkdecore.lax
rm -fr ./kdecore/.libs/libkdecore.lax/libklmalloc.a
mkdir ./kdecore/.libs/libkdecore.lax/libklmalloc.a
Extracting /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/malloc/.libs/libklmalloc.a
(cd ./kdecore/.libs/libkdecore.lax/libklmalloc.a && ar x /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/malloc/.libs/libklmalloc.a)
rm -fr ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a
mkdir ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a
Extracting /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/network/.libs/libkdecorenetwork.a
(cd ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a && ar x /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/network/.libs/libkdecorenetwork.a)
rm -fr ./kdecore/.libs/libkdecore.lax/libkdesvgicons.a
mkdir ./kdecore/.libs/libkdecore.lax/libkdesvgicons.a
Extracting /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/svgicons/.libs/libkdesvgicons.a
(cd ./kdecore/.libs/libkdecore.lax/libkdesvgicons.a && ar x /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./kdecore/svgicons/.libs/libkdesvgicons.a)
rm -fr ./kdecore/.libs/libkdecore.lax/libltdlc.a
mkdir ./kdecore/.libs/libkdecore.lax/libltdlc.a
Extracting /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./libltdl/.libs/libltdlc.a
(cd ./kdecore/.libs/libkdecore.lax/libltdlc.a && ar x /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs3/work/kdelibs-3.5.8/./libltdl/.libs/libltdlc.a)
g++ -dynamiclib -single_module  -o ./kdecore/.libs/libkdecore.4.2.0.dylib  ./kdecore/.libs/libintl.o ./kdecore/.libs/kapplication.o ./kdecore/.libs/kdebug.o ./kdecore/.libs/netwm.o ./kdecore/.libs/kconfigbase.o ./kdecore/.libs/kconfig.o ./kdecore/.libs/ksimpleconfig.o ./kdecore/.libs/kconfigbackend.o ./kdecore/.libs/kmanagerselection.o ./kdecore/.libs/kdesktopfile.o ./kdecore/.libs/kstandarddirs.o ./kdecore/.libs/ksock.o ./kdecore/.libs/kpty.o ./kdecore/.libs/kprocess.o ./kdecore/.libs/kprocctrl.o ./kdecore/.libs/klocale.o ./kdecore/.libs/krfcdate.o ./kdecore/.libs/kiconeffect.o ./kdecore/.libs/kicontheme.o ./kdecore/.libs/kiconloader.o ./kdecore/.libs/kwin.o ./kdecore/.libs/kwinmodule.o ./kdecore/.libs/krootprop.o ./kdecore/.libs/kcharsets.o ./kdecore/.libs/kckey.o ./kdecore/.libs/kshortcut.o ./kdecore/.libs/kkeynative_x11.o ./kdecore/.libs/kkeyserver_x11.o ./kdecore/.libs/kaccelaction.o ./kdecore/.libs/kshortcutmenu.o ./kdecore/.libs/kaccelbase.o ./kdecore/.libs/kaccel.o ./kdecore/.libs/kglobalaccel_x11.o ./kdecore/.libs/kglobalaccel.o ./kdecore/.libs/kstdaccel.o ./kdecore/.libs/kshortcutlist.o ./kdecore/.libs/kcrash.o ./kdecore/.libs/kurl.o ./kdecore/.libs/kregexp.o ./kdecore/.libs/kglobal.o ./kdecore/.libs/kglobalsettings.o ./kdecore/.libs/kallocator.o ./kdecore/.libs/kvmallocator.o ./kdecore/.libs/kmimesourcefactory.o ./kdecore/.libs/kinstance.o ./kdecore/.libs/kpalette.o ./kdecore/.libs/kipc.o ./kdecore/.libs/klibloader.o ./kdecore/.libs/ktempfile.o ./kdecore/.libs/kuniqueapplication.o ./kdecore/.libs/kaccelmanager.o ./kdecore/.libs/ksavefile.o ./kdecore/.libs/krandomsequence.o ./kdecore/.libs/kstringhandler.o ./kdecore/.libs/kcompletion.o ./kdecore/.libs/kcmdlineargs.o ./kdecore/.libs/kaboutdata.o ./kdecore/.libs/kcompletionbase.o ./kdecore/.libs/knotifyclient.o ./kdecore/.libs/kaudioplayer.o ./kdecore/.libs/kdcoppropertyproxy.o ./kdecore/.libs/ksockaddr.o ./kdecore/.libs/kextsock.o ./kdecore/.libs/netsupp.o ./kdecore/.libs/kprocio.o ./kdecore/.libs/kbufferedio.o ./kdecore/.libs/kpixmapprovider.o ./kdecore/.libs/kurldrag.o ./kdecore/.libs/kmdcodec.o ./kdecore/.libs/ksocks.o ./kdecore/.libs/ksycoca.o ./kdecore/.libs/ksycocadict.o ./kdecore/.libs/ksycocafactory.o ./kdecore/.libs/ksycoca_skel.o ./kdecore/.libs/kxmessages.o ./kdecore/.libs/kstartupinfo.o ./kdecore/.libs/kcatalogue.o ./kdecore/.libs/kasyncio.o ./kdecore/.libs/kmultipledrag.o ./kdecore/.libs/kstaticdeleter.o ./kdecore/.libs/kappdcopiface.o ./kdecore/.libs/kappdcopiface_skel.o ./kdecore/.libs/kclipboard.o ./kdecore/.libs/kcheckaccelerators.o ./kdecore/.libs/kdeversion.o ./kdecore/.libs/kdebugdcopiface.o ./kdecore/.libs/kdebugdcopiface_skel.o ./kdecore/.libs/kcalendarsystem.o ./kdecore/.libs/kcalendarsystemgregorian.o ./kdecore/.libs/kcalendarsystemhijri.o ./kdecore/.libs/kcalendarsystemhebrew.o ./kdecore/.libs/kcalendarsystemfactory.o ./kdecore/.libs/kmacroexpander.o ./kdecore/.libs/kidna.o ./kdecore/.libs/ktempdir.o ./kdecore/.libs/kshell.o ./kdecore/.libs/kmountpoint.o ./kdecore/.libs/kcalendarsystemjalali.o ./kdecore/.libs/kprotocolinfo_kdecore.o ./kdecore/.libs/kprotocolinfofactory.o ./kdecore/.libs/kxerrorhandler.o ./kdecore/.libs/kuser.o ./kdecore/.libs/kconfigskeleton.o ./kdecore/.libs/kconfigdialogmanager.o ./kdecore/.libs/klockfile.o ./kdecore/.libs/kqiodevicegzip_p.o ./kdecore/.libs/ktimezones.o ./kdecore/.libs/fakes.o ./kdecore/.libs/vsnprintf.o  ./kdecore/.libs/libkdecore.lax/libklmalloc.a/malloc.o  ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kbufferedsocket.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kclientsocketbase.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kdatagramsocket.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/khttpproxysocketdevice.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kresolver.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kresolvermanager.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kresolverstandardworkers.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kresolverworkerbase.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kreverseresolver.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kserversocket.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksocketaddress.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksocketbase.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksocketbuffer.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksocketdevice.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksockssocketdevice.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/ksrvresolverworker.o ./kdecore/.libs/libkdecore.lax/libkdecorenetwork.a/kstreamsocket.o  ./kdecore/.libs/libkdecore.lax/libkdesvgicons.a/ksvgiconengine.o ./kdecore/.libs/libkdecore.lax/libkdesvgicons.a/ksvgiconpainter.o  ./kdecore/.libs/libkdecore.lax/libltdlc.a/ltdl.o   -L/opt/local/lib -L/opt/local/lib/qt3/lib -L/usr/X11/lib -L/usr/X11R6/lib ./dcop/.libs/libDCOP.dylib /opt/local/lib/libqt-mt.dylib /usr/X11/lib/libGL.dylib /usr/X11/lib/libXmu.dylib /opt/local/lib/libXrender.dylib /usr/X11/lib/libXrandr.dylib /usr/X11/lib/libXcursor.dylib /usr/X11/lib/libXinerama.dylib /opt/local/lib/libXft.dylib /opt/local/lib/libfreetype.dylib /opt/local/lib/libfontconfig.dylib /usr/X11/lib/libXext.dylib /usr/X11/lib/libX11.dylib /usr/X11/lib/libSM.dylib /usr/X11/lib/libICE.dylib /opt/local/lib/libpng12.dylib /opt/local/lib/libz.dylib /usr/X11/lib/libX11.6.2.0.dylib /usr/X11/lib/libXau.6.0.0.dylib /usr/X11/lib/libXdmcp.6.0.0.dylib /usr/X11/lib/libSM.6.0.0.dylib /usr/X11/lib/libICE.6.3.0.dylib -ldl /usr/X11/lib/libXext.6.4.0.dylib -lresolv -lutil /opt/local/lib/libart_lgpl_2.dylib -lm /opt/local/lib/libidn.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib ./kdefx/.libs/libkdefx.dylib -lz  -Wl,-dylib_file -Wl,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib -install_name  /opt/local/lib/libkdecore.4.dylib -Wl,-compatibility_version -Wl,7 -Wl,-current_version -Wl,7.0
Undefined symbols:
  "syslog(int, char const*, ...)", referenced from:
      kdbgstream::flush()      in kdebug.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
Error creating ./kdecore/libkdecore.la. Exit status 1.
kdelibs3-3.5.8-3 make failed!

Warning: the following items did not execute (for kdelibs3): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

I have tried running a selfupdate, upgrading all outdated packages, cleaning the build directory for kdelibs3 and trying again but to no avail. Looks like the issue is the function syslog() which I am no certain as to why that would not be linked in.

Change History (7)

comment:1 Changed 12 years ago by blb@…

Are you running 10.4 or 10.5 and what version of Xcode do you have installed?

comment:2 in reply to:  1 Changed 12 years ago by coleman@…

Replying to blb@…:

Are you running 10.4 or 10.5 and what version of Xcode do you have installed?

Sorry should have included that in the initial report:

Mac OS X: 10.5.5 XCode: 3.1

comment:3 Changed 12 years ago by blb@…

That is most odd, syslog() should be in libSystem which should be linked in (it also provides string functions which are used by the same file that's using that syslog()). Compiling here (also 10.5.5, Xcode 3.1.1), it builds just fine.

Just to be absolutely sure, what is the result of running:

nm /usr/lib/libSystem.B.dylib |grep _syslog

comment:4 in reply to:  3 Changed 12 years ago by coleman@…

Replying to blb@…:

That is most odd, syslog() should be in libSystem which should be linked in (it also provides string functions which are used by the same file that's using that syslog()). Compiling here (also 10.5.5, Xcode 3.1.1), it builds just fine.

Just to be absolutely sure, what is the result of running:

nm /usr/lib/libSystem.B.dylib |grep _syslog
000d81ca T _asl_syslog_faciliy_name_to_num
0002ddb2 T _asl_syslog_faciliy_num_to_name
0005ae76 T _syslog

Very strange indeed. I don't see libsystem in the build log but does it need to be there? Problem with my setup then I guess.

comment:5 Changed 12 years ago by blb@…

libSystem is usually linked by default unless specifically told not to, and I didn't see that switch on the command. Also, I compared your failed link line with the build here, they are identical. I'm not sure what the issue could be at this point.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 12 years ago by takanori@…

Resolution: invalid
Status: newclosed

KDE 3.5.8 is too old. Please try the latest version.

Note: See TracTickets for help on using tickets.