Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17377 closed defect (fixed)

pango doesn't like ccache

Reported by: garribald@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: pango ccache Cc:
Port: pango, pango-devel

Description

The pango portfile should disable ccache usage. I get the following error if ccache is used (also got the error in the past versions, not sure, when it has started):

book:~ test$ sudo port upgrade pango
Password:
--->  Fetching pango
--->  Attempting to fetch pango-1.22.3.tar.bz2 from http://mandril.creatis.insa-lyon.fr/linux/gnome.org/sources/pango/1.22
--->  Verifying checksum(s) for pango
--->  Extracting pango
--->  Applying patches to pango
--->  Configuring pango
--->  Building pango with target all
--->  Staging pango into destroot
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsyn
c.macports.org_release_ports_x11_pango/work/pango-1.22.3" && nice -n 18 make install DESTDIR=/opt/local/var/macports/build/_opt_loca
l_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/destroot " returned error 2
Command output: Making install in pango
make  install-recursive
Making install in opentype
make[4]: Nothing to be done for `install-exec-am'.
make[4]: Nothing to be done for `install-data-am'.
Making install in mini-fribidi
make[4]: Nothing to be done for `install-exec-am'.
make[4]: Nothing to be done for `install-data-am'.
make[3]: *** No rule to make target `/Users/test/.ccache/pangocairo.tmp.book.local.20166.i', needed by `libpangocairo_1_0_la-pangocairo-context.lo'.  Stop.
make[2]: *** [install-recursive] Error 1
make[1]: *** [install] Error 2
make: *** [install-recursive] Error 1

I ran into this also in the past, but never came around to post a ticket, also because the workaround (disabling ccache via macports.conf) is a fast one. But before this will stop a bigger overnight upgrade marathon ...

I cleaned at one time ccache before upgrading to the 1.22.0 version, i think, and still ran into the error. IMHO the

"configure.ccache no"

should be set in the portfile.

OS X 10.4.11

Change History (3)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to ryandesign@…

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: pango-devel added
Resolution: fixed
Status: newclosed

Thanks for the report. I know very little about ccache and have never tried to use it, so thanks for letting me know it doesn't work with pango. I disabled it in r42606.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.