Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#17587 closed defect (worksforme)

AquaTerm Won't Run

Reported by: joseph@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: aquaterm

Description

AquaTerm doesn't seem to want to open, saying, 'You cannot open the application "AquaTerm.app" because it may be damaged or incomplete.'

I've downloaded the official binary from the AquaTerm web site, and it works fine.

I don't have the know how to debug if you can't reproduce, but would be happy to work with someone who does. joseph at josephholsten com

Attachments (1)

aquaterm_build.log (20.0 KB) - added by joseph@… 13 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by blb@…

Owner: changed from macports-tickets@… to davidm@…

If you open Console (/Applications/Utilities), then try again, is anything relevant logged? What version of Mac OS X are you using? What is the output of port installed aquaterm? PowerPC or Intel?

comment:2 Changed 13 years ago by joseph@…

If you open Console (/Applications/Utilities), then try again, is anything relevant logged?

Nothing of changed from opening Aquaterm.app in system.log, console.log, or anything else I checked.

What version of Mac OS X are you using? PowerPC or Intel?

% uname -a
Darwin localhost 8.11.1 Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007; root:xnu-792.25.20~1/RELEASE_I386 i386 i386

That is Mac OS 10.4.11 on Intel.

What is the output of port installed aquaterm?

% port installed aquaterm
The following ports are currently installed:
  aquaterm @1.0.1_3 (active)

I've attached a build log, via

% port clean --all aquaterm
--->  Cleaning aquaterm
% port -d build aquaterm >&| aquaterm_build.log

Nothing seems out of the ordinary, but what do I know?

I noticed that the official release of AquaTerm.app has Contents/MacOS/AquaTerm, but the version made by macports doesn't.

% diff -r /Applications/AquaTerm.app /Applications/MacPorts/AquaTerm.app
Only in /Applications/AquaTerm.app/Contents: MacOS

I tried to build manually from aquaterm_src.1.0.1.tar.gz by

% tar zxpf aquaterm_src.1.0.1.tar.gz
% cd aquaterm
% make -f distroMakefile BUILD_DIR=build/Deployment SYMROOT=build SRCROOT=.
...
freeze -v ./installer/installer.packproj
make: freeze: Command not found
make: *** [pkg] Error 127

that is, I get an error since I don't have a freeze command, which my google-fu indicates is from Iceberg.

Well, no matter, all that seems to be needed is the the actual build command, so replace the above with

% tar zxpf aquaterm_src.1.0.1.tar.gz
% cd aquaterm
% xcodebuild -target AquaTerm -configuration Deployment
=== BUILDING NATIVE TARGET AQTFwk WITH CONFIGURATION Deployment ===
...
=== BUILDING NATIVE TARGET AquaTerm WITH CONFIGURATION Deployment ===
...
** BUILD SUCCEEDED **
% diff -r /Applications/AquaTerm.app build/Deployment/AquaTerm.app  
Only in /Applications/AquaTerm.app/Contents: MacOS

that is, xcodebuild isn't generating Contents/MacOS/AquaTerm either.

And that indicates I don't know what I'm doing or something is wrong with my Xcode install. My installed version of Xcode is 2.4.1 (762).

Changed 13 years ago by joseph@…

Attachment: aquaterm_build.log added

comment:3 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:4 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Sorry about the delay.
I am not sure the maintainer responds to bug reports anymore.
A new version of MacPorts has been released since the ticked was opened.
By any chance, has that fixed the problem?

comment:5 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: changed from davidm@… to mcalhoun@…

comment:6 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: newclosed

Closing ticket.
If the problem persists, please feel free to reopen.

comment:7 in reply to:  6 ; Changed 13 years ago by joseph@…

Replying to mcalhoun@…:

Closing ticket.
resolution set to worksforme

Can I verify when you build, you get a AquaTerm.app that contains a Contents/MacOS directory? I'll leave closed if so.

comment:8 in reply to:  7 ; Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Replying to joseph@…:

Can I verify when you build, you get a AquaTerm.app that contains a Contents/MacOS directory? I'll leave closed if so.

I can not seem to reproduce your problem.
On my machine, AquaTerm.app contains Contents/MacOS and functions properly.

Nothing jumps out as being problematic with the aquaterm_build.log you submitted.
Just to cover all the bases, are you using the latest XCode available on your OS?

comment:9 in reply to:  8 Changed 13 years ago by joseph@…

Replying to mcalhoun@…:

Just to cover all the bases, are you using the latest XCode available on your OS?

No, but I'm going to upgrade to Leopard this week, so we can just leave this mystery unanswered. Thanks for your help.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.