Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#17827 closed defect (fixed)

gnokii-0.6.8 build faliure - libtool error

Reported by: tobie@… Owned by: mpal1+bugzilla@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: gnokii libtool version mismatch Cc: jmroot (Joshua Root)
Port: gnokii

Description

hi, I'm working with a fresh install of macports 1.7.0 on OS X 10.5.6. I'm trying to install Gnokii and see the following error during build:

[CRD:~] tob% sudo port install gnokii
--->  Fetching gnokii
--->  Verifying checksum(s) for gnokii
--->  Extracting gnokii
--->  Configuring gnokii
--->  Building gnokii
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_comms_gnokii/work/gnokii-0.6.8" && make all " returned error 2
Command output: make -C common/phones
/bin/sh ../../libtool --mode=compile /usr/bin/gcc-4.0 -O2  -I../../include -I/usr/X11/include -I/opt/local/include -I/System/Library/Frameworks/CoreFoundation.framework/Headers -I/usr/X11/include -o generic.lo -c generic.c
../../libtool: line 457: CDPATH: command not found
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_comms_gnokii/work/gnokii-0.6.8/libtool: line 457: CDPATH: command not found
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_comms_gnokii/work/gnokii-0.6.8/libtool: line 1135: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make[1]: *** [generic.lo] Error 63
make: *** [common/phones] Error 2

Previously, install would fail during extraction as the path to ltmain.sh was wrong:

--->  Extracting gnokii
Error: Target org.macports.extract returned: error copying "/opt/local/share/libtool/ltmain.sh": no such file or directory
Error: Status 1 encountered during processing.

I kludged this by duplicating "ltmain.sh" from "/opt/local/share/libtool/config/"

Change History (6)

comment:1 Changed 11 years ago by tobie@…

Cc: tobie@… added

Cc Me!

comment:2 Changed 11 years ago by blb@…

See #17833.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Cc: tobie@… removed
Owner: changed from macports-tickets@… to mpal1+bugzilla@…

Should be able to either autoreconf to work with libtool 2, or depend on libtool1 and copy its ltmain.sh.

comment:4 in reply to:  3 Changed 11 years ago by tobie@…

Replying to jmr@…:

Should be able to either autoreconf to work with libtool 2, or depend on libtool1 and copy its ltmain.sh.

Thanks, I'm new to this, can you point me to documentation that describes autoreconf, so I can use libtool 2?

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Cc: jmr@… added
Resolution: fixed
Status: newclosed

Fixed in r45082 by updating to 0.6.27 (maintainer timeout).

comment:6 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.