Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#18250 closed defect (duplicate)

xfig is linking against system x11 libraries

Reported by: jjstickel@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: x11 Cc: pguyot (Paul Guyot), blue_wind_cwb-porto@…, stefan@…, jihema@…, clarkeje@…
Port: xfig

Description

The port xfig is linking against system x11 libraries, even though I am not using the system_x11 variant:

$ otool -L /opt/local/bin/xfig
/opt/local/bin/xfig:
        /opt/local/lib/libjpeg.62.dylib (compatibility version 63.0.0, current version 63.0.0)
        /usr/X11R6/lib/libXpm.4.dylib (compatibility version 4.11.0, current version 4.11.0)
        /opt/local/lib/libpng12.0.dylib (compatibility version 35.0.0, current version 35.0.0)
        /opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
        /usr/X11R6/lib/libXi.6.dylib (compatibility version 6.0.0, current version 6.0.0)
        /opt/local/lib/libXaw3d.7.dylib (compatibility version 7.0.0, current version 7.0.0)
        /usr/X11R6/lib/libXmu.6.dylib (compatibility version 6.2.0, current version 6.2.0)
        /usr/X11R6/lib/libXt.6.dylib (compatibility version 6.0.0, current version 6.0.0)
        /usr/X11R6/lib/libSM.6.dylib (compatibility version 6.0.0, current version 6.0.0)
        /usr/X11R6/lib/libICE.6.dylib (compatibility version 6.3.0, current version 6.3.0)
        /usr/X11R6/lib/libXext.6.dylib (compatibility version 6.4.0, current version 6.4.0)
        /usr/X11R6/lib/libX11.6.dylib (compatibility version 6.2.0, current version 6.2.0)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.11)
        /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

resulting in a segfault / bus error:

$ xfig
Warning: No type converter registered for 'translations' to 'InitialResourcesPersistent' conversion.
Warning: No type converter registered for 'TranslationTable' to 'Translations' conversion.
Warning: No type converter registered for 'String' to 'Color' conversion.
Warning: No type converter registered for 'TranslationTable' to 'Color' conversion.
Warning: No type converter registered for 'TranslationTable' to 'InitialResourcesPersistent' conversion.
Warning: No type converter registered for 'translations' to 'Meta' conversion.
Bus error

I am on Tiger (10.4.11)

Attachments (1)

patch-Imakefile.diff (2.4 KB) - added by jjstickel@… 12 years ago.
patch of the Imakefile patch

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to pguyot@…

Changed 12 years ago by jjstickel@…

Attachment: patch-Imakefile.diff added

patch of the Imakefile patch

comment:2 Changed 12 years ago by jjstickel@…

The attached patch to the Imakefile patch file fixed this for me. Seems a little strange to patch a patch... let me know if you simply want the new patch file.

comment:3 Changed 12 years ago by blue_wind_cwb-porto@…

Cc: blue_wind_cwb-porto@… added

Cc Me!

comment:4 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Cc: pguyot@… added
Owner: changed from pguyot@… to jeremyhu@…

comment:5 Changed 12 years ago by stefan@…

Cc: stefan@… added

Cc Me!

comment:6 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from jeremyhu@… to pguyot@…

The attached patch is fine... but the xfig port is broken beyond this. You need to:

reinplace "s|/bin/sh /usr/X11R6/bin/mkdirhier|mkdirhier|g" ${worksrcpath}/Imakefile

as well.

punting to maintainer

comment:7 Changed 12 years ago by jihema@…

Cc: jihema@… added

Cc Me!

comment:8 Changed 12 years ago by clarkeje@…

Cc: clarkeje@… added

Cc Me!

comment:9 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #18093.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.