Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#18816 closed defect (fixed)

encfs 1.5 does not run

Reported by: mf2k (Frank Schima) Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: chris.lasher@…, hai9796@…, abh (Ask Bjørn Hansen)
Port: encfs

Description

I see the following error when running encfs 1.5:

$ encfs
dyld: Symbol not found: __ZNK5boost13serialization6detail27extended_type_info_typeid_012is_less_thanERKNS0_18extended_type_infoE
  Referenced from: /opt/local/lib/libencfs.4.dylib
  Expected in: dynamic lookup

Trace/BPT trap

Attachments (1)

Portfile.diff (392 bytes) - added by jlucg@… 11 years ago.
Changes the configure.ldflags-append line

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by chris.lasher@…

Thanks for filing this report for me.

comment:2 Changed 11 years ago by chris.lasher@…

Cc: chris.lasher@… added

Cc Me!

comment:3 Changed 11 years ago by hai9796@…

Cc: hai9796@… added

Cc Me!

comment:4 Changed 11 years ago by abh (Ask Bjørn Hansen)

FWIW: It's working for me on Intel, but I get this error on OS X.

$ port installed | grep -E '(rlog|boost |encfs)'
  boost @1.37.0_0+darwin_9 (active)
  encfs @1.5_0 (active)
  rlog @1.4_0 (active)

10.5.6 on both systems.

comment:5 Changed 11 years ago by abh (Ask Bjørn Hansen)

Cc: ask@… added

Cc Me!

Changed 11 years ago by jlucg@…

Attachment: Portfile.diff added

Changes the configure.ldflags-append line

comment:6 Changed 11 years ago by jlucg@…

Modifying the Portfile to the following fixed the issue on my machine (see attached diff):

configure.ldflags-append    -lboost_system-mt-s -lboost_serialization-mt-s

comment:7 in reply to:  6 Changed 11 years ago by chris.lasher@…

Replying to jlucg@…:

Modifying the Portfile to the following fixed the issue on my machine (see attached diff):

configure.ldflags-append    -lboost_system-mt-s -lboost_serialization-mt-s

I can confirm this fix worked for me. Many thanks!

comment:8 Changed 11 years ago by abh (Ask Bjørn Hansen)

jlucg: Nice - that works for me too.

comment:9 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from eridius@… to macsforever2000@…
Status: newassigned

Maintainer timeout.

comment:10 Changed 11 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

Committed revision r49655. Thanks!

comment:11 Changed 11 years ago by ryandesign (Ryan Schmidt)

Bumped revision in r49657 so everyone is informed they should rebuild so everyone gets this fix.

comment:12 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.