Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18880 closed defect (duplicate)

mysql5-devel: 5.1.32 error during build stage

Reported by: senz@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: mysql mysql5 mysql5-devel error compile Cc: ryandesign (Ryan Schmidt)
Port: mysql5-devel

Description

Here's install log:

--->  Fetching mysql5-devel
--->  Verifying checksum(s) for mysql5-devel
--->  Extracting mysql5-devel
--->  Applying patches to mysql5-devel
--->  Configuring mysql5-devel
--->  Building mysql5-devel
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_mysql5-devel/work/mysql-5.1.32" && make -j2 all " returned error 2
Command output:       var_query_set(VAR*, char const*, char const**)in mysqltest.o
      var_query_set(VAR*, char const*, char const**)in mysqltest.o
      do_let(st_command*)     in mysqltest.o
      do_perl(st_command*)     in mysqltest.o
      do_system(st_command*)     in mysqltest.o
      do_exec(st_command*)     in mysqltest.o
      do_exec(st_command*)     in mysqltest.o
      run_query_stmt(st_mysql*, st_command*, char*, int, st_dynamic_string*, st_dynamic_string*)in mysqltest.o
      run_query_stmt(st_mysql*, st_command*, char*, int, st_dynamic_string*, st_dynamic_string*)in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      run_query(st_connection*, st_command*, int) in mysqltest.o
      mark_progress(st_command*, int)  in mysqltest.o
      _main in mysqltest.o
  "_insert_dynamic", referenced from:
      read_command(st_command**)      in mysqltest.o
      init_replace_regex(char*) in mysqltest.o
      dynstr_append_sorted(st_dynamic_string*, st_dynamic_string*)in mysqltest.o
ld: symbol(s) not found for architecture ppc
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//cc7q5k2J.out (No such file or directory)
make[4]: *** [mysqltest_embedded] Error 1
make[4]: *** Waiting for unfinished jobs....
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [all-recursive] Error 1

Error: Unable to upgrade port: 1

Change History (7)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to jwa@…

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:3 Changed 12 years ago by illogic-al@…

I get this too

comment:4 Changed 12 years ago by illogic-al@…

Version: 1.7.01.7.1

comment:5 Changed 12 years ago by illogic-al@…

mysql5-devel: 5.1.35 when trying universal build

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #17300.

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

Priority: HighNormal
Note: See TracTickets for help on using tickets.