Opened 12 years ago

Closed 12 years ago

#18936 closed defect (fixed)

kdebase4-runtime and hicolor-icon-theme both claim ${prefix}/share/icons/hicolor/index.theme

Reported by: ryandesign (Ryan Schmidt) Owned by: jeremy.laine@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: nerdling (Jeremy Lavergne)
Port: kdebase4-runtime, hicolor-icon-theme

Description

kdebase4-runtime and hicolor-icon-theme both want to install ${prefix}/share/icons/hicolor/index.theme:

--->  Fetching hicolor-icon-theme
--->  Verifying checksum(s) for hicolor-icon-theme
--->  Extracting hicolor-icon-theme
--->  Configuring hicolor-icon-theme
--->  Building hicolor-icon-theme
--->  Staging hicolor-icon-theme into destroot
--->  Installing hicolor-icon-theme @0.10_0
--->  Activating hicolor-icon-theme @0.10_0
Error: Target org.macports.activate returned: Image error: /mp/share/icons/hicolor/index.theme is being used by the active kdebase4-runtime port.  Please deactivate this port first, or use the -f flag to force the activation.
Error: The following dependencies failed to build: libgnomeui gnome-icon-theme hicolor-icon-theme icon-naming-utils p5-xml-simple p5-xml-namespacesupport p5-xml-sax libgphoto2
Error: Status 1 encountered during processing.

What should I do?

Attachments (1)

kdebase4-runtime.patch (801 bytes) - added by jeremy.laine@… 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by illogic-al@…

Resolution: wontfix
Status: newclosed

deactivate kdebase4-runtime? force the install? your choice really. The gnome stuff and kde stuff seems not to play together nicely.

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:3 Changed 12 years ago by mf2k (Frank Schima)

Cc: illogic-al@… removed
Resolution: wontfix
Status: closedreopened

comment:4 Changed 12 years ago by mf2k (Frank Schima)

Cc: snc@… added
Owner: changed from macports-tickets@… to jeremy.laine@…
Status: reopenednew

comment:5 Changed 12 years ago by jeremy.laine@…

kdebase4-runtime is the one at fault here, it should not be install the index.theme file. This is confirmed by the following comment in the Debian packaging for kdebase4-runtime:

# Files not installed because they conflict with hicolor-icon-theme: ./usr/share/icons/hicolor/index.theme

I will post a patch to fix this issue as soon as I have finished rebuilding.

Changed 12 years ago by jeremy.laine@…

Attachment: kdebase4-runtime.patch added

comment:6 Changed 12 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

Committed revision r59011. Thanks!

Note: See TracTickets for help on using tickets.