Opened 10 years ago

Closed 10 years ago

#18980 closed submission (fixed)

Add py25-paver port

Reported by: arthur@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: paver Cc:
Port: py25-paver

Description


Attachments (1)

Portfile (1.6 KB) - added by arthur@… 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by arthur@…

Attachment: Portfile added

comment:1 Changed 10 years ago by blb@…

Hmm, looks like its setup.py isn't a distutils-based one, which would explain why --no-user-cfg doesn't work...

comment:2 Changed 10 years ago by arthur@…

The setup.py file calls the pavement.py file which then installs the package using Paver. Paver is a wrapper around some tools such as Sphinx, Subversion, Virtualenv and Distutils/Setuptools (see paver.setuputils). The Paver website even states "Completely encompasses distutils and setuptools so that you can customize behavior as you need to."

So, not supporting '--no-user-cfg' is actually a bug in Paver. I filed a ticket in Paver's issue system: http://code.google.com/p/paver/issues/detail?id=26

comment:3 Changed 10 years ago by blb@…

Note that --no-user-cfg isn't in the official python yet, so probably not a bug with Paver until then; see our ticket #9831 and python's 1180.

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Type: enhancementsubmission

comment:5 Changed 10 years ago by (none)

Milestone: Port Submissions

Milestone Port Submissions deleted

comment:6 Changed 10 years ago by arthurk@…

Resolution: fixed
Status: newclosed

Committed in r54474.

Note: See TracTickets for help on using tickets.