Opened 12 years ago

Closed 12 years ago

#19032 closed defect (duplicate)

flow-tools: non-root install fails during destroot

Reported by: ryandesign (Ryan Schmidt) Owned by: markd@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: flow-tools

Description

flow-tools cannot be installed as a non-root user because the doc directory is being created with the wrong permissions:

$ port install flow-tools
--->  Fetching flow-tools
--->  Attempting to fetch flow-tools-0.68.tar.gz from http://leopard.local/distfiles/flow-tools
--->  Verifying checksum(s) for flow-tools
--->  Extracting flow-tools
--->  Applying patches to flow-tools
--->  Configuring flow-tools
--->  Building flow-tools
--->  Staging flow-tools into destroot
Error: Target org.macports.destroot returned: xinstall: Unable to create new file for: /mp/var/macports/build/_Users_rschmidt_macports_dports_net_flow-tools/work/destroot/mp/share/doc/flow-tools/INSTALL, Permission denied
Error: Status 1 encountered during processing.
$

Fix attached.

Attachments (1)

flow-tools-directory-permissions.diff (435 bytes) - added by ryandesign (Ryan Schmidt) 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by ryandesign (Ryan Schmidt)

comment:1 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #19100.

Note: See TracTickets for help on using tickets.