Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19160 closed defect (fixed)

spidermonkey: can't locate file for: -lnspr4

Reported by: ryandesign (Ryan Schmidt) Owned by: akitada@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: spidermonkey

Description

I'm unable to install spidermonkey:

$ port installed spidermonkey
The following ports are currently installed:
  spidermonkey @1.7.0_1 (active)
$ port -ux upgrade spidermonkey
--->  Fetching spidermonkey
--->  Attempting to fetch js-1.7.0.tar.gz from http://distfiles.macports.org/spidermonkey
--->  Verifying checksum(s) for spidermonkey
--->  Extracting spidermonkey
--->  Applying patches to spidermonkey
--->  Configuring spidermonkey
--->  Building spidermonkey
Error: Target org.macports.build returned: shell command " cd "/mp/var/macports/build/_Users_rschmidt_macports_dports_lang_spidermonkey/work/js/src" && nice -n 10 make all -f Makefile.ref LIBDIR="/lib" SO_SUFFIX=dylib JS_THREADSAFE=1 CC=/usr/bin/gcc-4.0 DEFINES=-DJS_C_STRINGS_ARE_UTF8 " returned error 2
Command output: /usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsmath.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsmath.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsnum.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsnum.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsobj.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsobj.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsopcode.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsopcode.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsparse.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsparse.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsprf.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsprf.c -fPIC
jsprf.c: In function 'dosprintf':
jsprf.c:952: warning: pointer targets in passing argument 1 of 'js_OneUcs4ToUtf8Char' differ in signedness
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsregexp.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsregexp.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsscan.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsscan.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsscope.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsscope.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsscript.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsscript.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsstr.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsstr.c -fPIC
jsstr.c: In function 'js_InflateStringToBuffer':
jsstr.c:2971: warning: pointer targets in passing argument 1 of 'Utf8ToOneUcs4Char' differ in signedness
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsutil.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsutil.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsxdrapi.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsxdrapi.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/jsxml.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  jsxml.c -fPIC
/usr/bin/gcc-4.0 -o Darwin_OPT.OBJ/prmjtime.lo -c -Wall -Wno-format -no-cpp-precomp -fno-common -pipe -O -DJS_THREADSAFE -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DDARWIN -DJS_C_STRINGS_ARE_UTF8 -DJS_C_STRINGS_ARE_UTF8 -IDarwin_OPT.OBJ -I/mp/include/nspr  prmjtime.c -fPIC
/usr/bin/gcc-4.0 -framework System -dynamiclib  -lm -lplds4 -lplc4 -lnspr4  -o Darwin_OPT.OBJ/libjs.dylib Darwin_OPT.OBJ/jsapi.lo Darwin_OPT.OBJ/jsarena.lo Darwin_OPT.OBJ/jsarray.lo Darwin_OPT.OBJ/jsatom.lo Darwin_OPT.OBJ/jsbool.lo Darwin_OPT.OBJ/jscntxt.lo Darwin_OPT.OBJ/jsdate.lo Darwin_OPT.OBJ/jsdbgapi.lo Darwin_OPT.OBJ/jsdhash.lo Darwin_OPT.OBJ/jsdtoa.lo Darwin_OPT.OBJ/jsemit.lo Darwin_OPT.OBJ/jsexn.lo Darwin_OPT.OBJ/jsfun.lo Darwin_OPT.OBJ/jsgc.lo Darwin_OPT.OBJ/jshash.lo Darwin_OPT.OBJ/jsinterp.lo Darwin_OPT.OBJ/jsiter.lo Darwin_OPT.OBJ/jslock.lo Darwin_OPT.OBJ/jslog2.lo Darwin_OPT.OBJ/jslong.lo Darwin_OPT.OBJ/jsmath.lo Darwin_OPT.OBJ/jsnum.lo Darwin_OPT.OBJ/jsobj.lo Darwin_OPT.OBJ/jsopcode.lo Darwin_OPT.OBJ/jsparse.lo Darwin_OPT.OBJ/jsprf.lo Darwin_OPT.OBJ/jsregexp.lo Darwin_OPT.OBJ/jsscan.lo Darwin_OPT.OBJ/jsscope.lo Darwin_OPT.OBJ/jsscript.lo Darwin_OPT.OBJ/jsstr.lo Darwin_OPT.OBJ/jsutil.lo Darwin_OPT.OBJ/jsxdrapi.lo Darwin_OPT.OBJ/jsxml.lo Darwin_OPT.OBJ/prmjtime.lo   -L/mp/lib -lnspr4 -install_name /mp/lib/libjs.dylib
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for: -lplds4
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lplds4 is not an object file (not allowed in a library)
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for: -lplc4
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lplc4 is not an object file (not allowed in a library)
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for: -lnspr4
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lnspr4 is not an object file (not allowed in a library)
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for: -lnspr4
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lnspr4 is not an object file (not allowed in a library)
make[1]: *** [Darwin_OPT.OBJ/libjs.dylib] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

Probably caused by r49079.

Change History (2)

comment:1 Changed 12 years ago by akitada@…

Resolution: fixed
Status: newclosed

seems already fixed in r49100

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.