Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19478 closed defect (invalid)

Amarok install not finishing. Issue with URW-FONTS CHECKSUM issue?

Reported by: stinsonp@… Owned by: takanori@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: urw-fonts, port install Cc:
Port: urw-fonts

Description

Hi new to the world of unix on mac but have sucessfully setup using macports updated via subversion ( as i have a corp proxy to tunnel through that rsync doesn't work with).

Never had an issue install any apps till trying amarok.

It gets to the following package and errors saying there is a mismatch checksum. Just wondering if anyone can give me some points as to why it is happening and if there are any steps i can do to rectify the matter. From other checksum tickets i have seen in the past it is either an issue with the package that needs to be fixed by the author or and update is not downloading to my portfile correctly ( I think the terminology is correct but don't shoot me if it isn't please ). Latest dports update downloaded via subversion. If you need more info or want me to collect more info please let me know what you need. Thanks.

Snippet from the command 'sudo port -v install amarok' below:

--->  Fetching urw-fonts
--->  Verifying checksum(s) for urw-fonts
--->  Checksumming urw-fonts-1.0.7pre44.tar.bz2
Error: Checksum (md5) mismatch for urw-fonts-1.0.7pre44.tar.bz2
Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 md5 51c6c2690593cd9bd92f197a6f2ff8bd
Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 md5 9a8e035a7e6acec192afb8e55e017084
Error: Checksum (sha1) mismatch for urw-fonts-1.0.7pre44.tar.bz2
Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 sha1 465fd5faab9ba9e7590f1bf761015862eb09748d
Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 sha1 d8922880f9ee72b6749450844ceb7e85940d698e
Error: Checksum (rmd160) mismatch for urw-fonts-1.0.7pre44.tar.bz2
Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 rmd160 52bddb1e267e6aa3cace9197293718e4919384bd
Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 rmd160 7a12fb599bd5d6aee97adef8606df32d0746387e
The correct checksum line may be:
checksums           md5     9a8e035a7e6acec192afb8e55e017084 \
                    sha1    d8922880f9ee72b6749450844ceb7e85940d698e \
                    rmd160  7a12fb599bd5d6aee97adef8606df32d0746387e
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for urw-fonts): org.macports.activate org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: The following dependencies failed to build: doxygen graphviz urw-fonts xorg-libXaw xorg-libXmu xorg-libXt xorg-libsm xorg-libice xorg-util-macros kdebase4-runtime kdelibs4 aspell texinfo lzmautils aspell-dict-en enchant flex giflib libart_lgpl libidn openexr ilmbase phonon soprano clucene redland raptor rasqal strigi kdepimlibs4 akonadi boost boost-jam gmake gpgme gnupg libgpg-error pth libical openldap db44 qimageblitz libmp4v2 mysql5-devel taglib-devel
Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Milestone: MacPorts 1.8.0
Owner: changed from macports-tickets@… to takanori@…

comment:2 Changed 12 years ago by takanori@…

Resolution: invalid
Status: newclosed

I cannot reproduce the problem. Please try:

$ sudo port clean --all urw-fonts
$ sudo port -d install urw-fonts

comment:3 Changed 12 years ago by stinsonp@…

Just thought I'd add this. It's still an issue fetching the said file and obviously not working through the proxy for some reason. I thought i'd check manually a the location detailed below "ftp://ftp.gnome.ru/fonts/urw/release/" and there is NO file there. So i guess this is why it is failing. It downloads a 4kb file to the /opt/local/var/macports/distfiles/urw-fonts directory.

Following Error Message when manually going to ftp://ftp.gnome.ru/fonts/urw/release/

ISA Server: extended error message :

200 Okay, using binary. 200 Okay. 550 Sorry, I don't see that file. �

I fixed the issue by downloading the file from http://distfiles.macports.org/urw-fonts/ directly to /opt/local/var/macports/distfiles/urw-fonts. Running the install after this works.

I have the debug info for you anyway before i fixed it manually below if it helps.

$ sudo port clean --all urw-fonts ---> Cleaning urw-fonts

$ sudo port -d install urw-fonts DEBUG: Found port in file:///opt/mports/trunk/dports/x11/urw-fonts DEBUG: Changing to port directory: /opt/mports/trunk/dports/x11/urw-fonts DEBUG: OS Platform: darwin DEBUG: OS Version: 9.6.0 DEBUG: Mac OS X Version: 10.5 DEBUG: System Arch: i386 DEBUG: setting option os.universal_supported to yes DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: 'universal_variant no' specified, so not adding the default universal variant DEBUG: Requested variant darwin is not provided by port urw-fonts. DEBUG: Requested variant i386 is not provided by port urw-fonts. DEBUG: Requested variant macosx is not provided by port urw-fonts. DEBUG: changing euid/egid - current euid: 0 - current egid: 0 DEBUG: egid changed to: -1 DEBUG: euid changed to: 0 DEBUG: Privileges successfully de-escalated. Unable to write to default workpath. DEBUG: Attempting ln -sf /opt/local/var/macports/build/_opt_mports_trunk_dports_x11_urw-fonts/work /opt/mports/trunk/dports/x11/urw-fonts/work ---> Computing dependencies for urw-fonts DEBUG: Found port in file:///opt/mports/trunk/dports/graphics/fontconfig DEBUG: Changing to port directory: /opt/mports/trunk/dports/graphics/fontconfig DEBUG: OS Platform: darwin DEBUG: OS Version: 9.6.0 DEBUG: Mac OS X Version: 10.5 DEBUG: System Arch: i386 DEBUG: setting option os.universal_supported to yes DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: Using group file /opt/mports/trunk/dports/_resources/port1.0/group/muniversal-1.0.tcl DEBUG: Reading variant descriptions from /opt/mports/trunk/dports/_resources/port1.0/variant_descriptions.conf DEBUG: universal variant already exists, so not adding the default one DEBUG: Requested variant darwin is not provided by port fontconfig. DEBUG: Requested variant i386 is not provided by port fontconfig. DEBUG: Executing variant macosx provides macosx DEBUG: Searching for dependency: fontconfig DEBUG: Found Dependency: receipt exists for fontconfig

DEBUG: Executing org.macports.main (urw-fonts) DEBUG: changing euid/egid - current euid: 0 - current egid: -1 DEBUG: egid changed to: -1 DEBUG: euid changed to: 0 ---> Fetching urw-fonts DEBUG: Executing org.macports.fetch (urw-fonts) ---> urw-fonts-1.0.7pre44.tar.bz2 doesn't seem to exist in /opt/local/var/macports/distfiles/urw-fonts DEBUG: Pinging ftp.gnome.ru... DEBUG: Pinging distfiles.macports.org... DEBUG: Pinging trd.no.distfiles.macports.org... DEBUG: Pinging arn.se.distfiles.macports.org... DEBUG: ftp.gnome.ru ping time is 10000 DEBUG: distfiles.macports.org ping time is 10000 DEBUG: trd.no.distfiles.macports.org ping time is 10000 DEBUG: arn.se.distfiles.macports.org ping time is 10000 ---> Attempting to fetch urw-fonts-1.0.7pre44.tar.bz2 from ftp://ftp.gnome.ru/fonts/urw/release/

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 280 0 280 0 0 47 0 --:--:-- 0:00:05 --:--:-- 71 DEBUG: changing euid/egid - current euid: 0 - current egid: -1 DEBUG: egid changed to: -1 DEBUG: euid changed to: 0 ---> Verifying checksum(s) for urw-fonts DEBUG: Executing org.macports.checksum (urw-fonts) ---> Checksumming urw-fonts-1.0.7pre44.tar.bz2 Error: Checksum (md5) mismatch for urw-fonts-1.0.7pre44.tar.bz2 Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 md5 51c6c2690593cd9bd92f197a6f2ff8bd Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 md5 9a8e035a7e6acec192afb8e55e017084 Error: Checksum (sha1) mismatch for urw-fonts-1.0.7pre44.tar.bz2 Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 sha1 465fd5faab9ba9e7590f1bf761015862eb09748d Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 sha1 d8922880f9ee72b6749450844ceb7e85940d698e Error: Checksum (rmd160) mismatch for urw-fonts-1.0.7pre44.tar.bz2 Portfile checksum: urw-fonts-1.0.7pre44.tar.bz2 rmd160 52bddb1e267e6aa3cace9197293718e4919384bd Distfile checksum: urw-fonts-1.0.7pre44.tar.bz2 rmd160 7a12fb599bd5d6aee97adef8606df32d0746387e The correct checksum line may be: checksums md5 9a8e035a7e6acec192afb8e55e017084 \

sha1 d8922880f9ee72b6749450844ceb7e85940d698e \ rmd160 7a12fb599bd5d6aee97adef8606df32d0746387e

Error: Target org.macports.checksum returned: Unable to verify file checksums DEBUG: Backtrace: Unable to verify file checksums

while executing

"$procedure $name" Warning: the following items did not execute (for urw-fonts): org.macports.activate org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install Error: Status 1 encountered during processing.

Note: See TracTickets for help on using tickets.