Opened 12 years ago

Closed 12 years ago

#19725 closed defect (invalid)

Error building gmp 4.3.1

Reported by: jon.hermansen@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: gmp

Description (last modified by mf2k (Frank Schima))

Build failure, gmp-4.3.1. I found other build failures like this (both with FFmpeg), but no solution was ever found...

ffmpeg - unable to install: http://www.mail-archive.com/macports-users@lists.macosforge.org/msg05259.html

BUG: Error building ffmpeg: #12191

I made sure to clean the work directory after first seeing this issue, and then tried it again. It is reproducible every time I try to install gmp on my machine. I have attached the full build log, here's the tail end of the build where it aborts.

Making all in mpn
/bin/sh ../libtool --mode=compile --tag=CC ../mpn/m4-ccas --m4="m4" /usr/bin/gcc-4.0 -c -DHAVE_CONFIG_H -I. -I. -I.. -D__GMP_WITHIN_GMP -I.. -DOPERATION_`echo gcd_1 | sed 's/_$//'`  -I/opt/local/include  -m32 -O2 -pedantic -fomit-frame-pointer -mtune=k8 -march=k8  `test -f 'gcd_1.asm' || echo './'`gcd_1.asm
 ../mpn/m4-ccas --m4=m4 /usr/bin/gcc-4.0 -c -DHAVE_CONFIG_H -I. -I. -I.. -D__GMP_WITHIN_GMP -I.. -DOPERATION_gcd_1 -I/opt/local/include -m32 -O2 -pedantic -fomit-frame-pointer -mtune=k8 -march=k8 gcd_1.asm  -fno-common -DPIC -o .libs/gcd_1.o
m4  -DHAVE_CONFIG_H -D__GMP_WITHIN_GMP -DOPERATION_gcd_1 -DPIC gcd_1.asm >tmp-gcd_1.s
 /usr/bin/gcc-4.0 -c -DHAVE_CONFIG_H -I. -I. -I.. -D__GMP_WITHIN_GMP -I.. -DOPERATION_gcd_1 -I/opt/local/include -m32 -O2 -pedantic -fomit-frame-pointer -mtune=k8 -march=k8 tmp-gcd_1.s -fno-common -DPIC -o .libs/gcd_1.o
tmp-gcd_1.s:413:Missing operand value assumed absolute 0.
tmp-gcd_1.s:413:junk `[.-Ltable]' after expression
tmp-gcd_1.s:417:junk `@PLT' after expression
make[2]: *** [gcd_1.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Warning: the following items did not execute (for gmp): org.macports.activate org.macports.build org.macports.destroot org.macports.archive org.macports.install
Error: The following dependencies failed to build: aqbanking gmp libofx opensp qt3 Xft2 xrender xorg-renderproto gconf dbus-glib dbus orbit2 libidl policykit goffice bzip2 libart_lgpl libgsf gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo guile16 libgnomeprintui gnome-icon-theme hicolor-icon-theme icon-naming-utils p5-xml-simple p5-xml-namespacesupport p5-xml-sax libgnomecanvas libgnomeprint bison libgnomecups libgnomeui gnome-keyring libbonoboui libgnome esound audiofile libgtkhtml3 enchant libsoup libproxy sqlite3 p5-finance-quote p5-crypt-ssleay p5-datemanip p5-html-tableextract p5-html-tree p5-html-parser p5-html-tagset p5-libwww-perl p5-compress-zlib p5-compress-raw-zlib p5-io-compress-base p5-io-compress-zlib p5-uri slib slib-guile16
desktop:~ jherm$ port version
Version: 1.710

desktop:~ jherm$ echo $PATH
/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/Users/jherm/bin

desktop:~ jherm$ which gcc
/usr/bin/gcc

desktop:~ jherm$ gcc --version | head -n 1
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5490)

desktop:~ jherm$ grep "Xcode version" /Developer/Applications/Xcode.app/Contents/Info.plist
	<string>Xcode version 3.1.2</string>

Attachments (1)

screenlog.0 (75.1 KB) - added by jon.hermansen@… 12 years ago.
Build log of gmp-4.3.1

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by jon.hermansen@…

Attachment: screenlog.0 added

Build log of gmp-4.3.1

comment:1 Changed 12 years ago by jon.hermansen@…

I'm sorry, I submitted the bug and forgot to put in a useful title.

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to mcalhoun@…
Summary: gmp-4.3.1Error building gmp 4.3.1

comment:3 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: newassigned

To get the maximum speed possible, the gmp package runs a scripts config.guess to find out as much as possible about the
type of processor.
For some reason, it thinks you are running a Athlon 64 processor from AMD.

checking build system type... athlon64-apple-darwin9.6.0
checking host system type... athlon64-apple-darwin9.6.0

This seems to be the source of your problem.

Can you think of any reason why this error would occur on your machine?

comment:4 in reply to:  3 Changed 12 years ago by jon.hermansen@…

For some reason, it thinks you are running a Athlon 64 processor from AMD.

This seems to be the source of your problem.

Can you think of any reason why this error would occur on your machine?

Yes, I am running Darwin on my AMD Phenom CPU. I can try setting "-march" in CFLAGS to a more generic instruction set, do you think that might help?

I won't have access to the machine until tomorrow evening. I'd be more than happy to triage the bug, now that I know it may be related to my architecture / CPU. If running on an AMD CPU is out of the scope of support from the MacPorts project, you can close this ticket.

Furthermore, if I can provide a Portfile patch to fix this issue, is it likely it will be accepted? (Assuming I can isolate and programatically detect when this issue will occur, and change the Portfile behavior in that case)

comment:5 Changed 12 years ago by jon.hermansen@…

I've received information from another user who claims GMP will build with this configure line:

./configure --host=none-apple-darwin ABI=long

comment:6 Changed 12 years ago by tobypeterson

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.