Opened 12 years ago

Closed 11 years ago

Last modified 9 years ago

#19838 closed defect (invalid)

gnome-keyring: gnome-keyring-2.26.1: No such file or directory

Reported by: iancsf (Ian Scott-Fleming) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: gnome-keyring

Description (last modified by mf2k (Frank Schima))

ImageMagick installation apparently uses UFRaw as a delegate for some image formats, but UFRaw was not installed.

"sudo port install ufraw" fails with:

sudo port install ufraw
Password:
--->  Configuring gnome-keyring
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1" && ./configure --prefix=/opt/local " returned error 1
Command output: sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1: No such file or directory

Error: The following dependencies failed to build: gimp2 libgnomeui gnome-keyring libbonoboui libglade2 libgnome esound audiofile libgnomecanvas libmng lcms libwmf poppler openjpeg poppler-data py25-gtk py25-cairo py25-numpy fftw-3 py25-nose py25-setuptools py25-zlib py25-gobject gtkimageview
Error: Status 1 encountered during processing.

UFRaw web pages say to install Gimp.

"sudo port install gimp" also fails with

sudo port install gimp
--->  Configuring gnome-keyring
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1" && ./configure --prefix=/opt/local " returned error 1
Command output: sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1: No such file or directory

Error: The following dependencies failed to build: gimp-app gimp2 libgnomeui gnome-keyring libbonoboui libglade2 libgnome esound audiofile libgnomecanvas libmng lcms libwmf poppler openjpeg poppler-data py25-gtk py25-cairo py25-numpy fftw-3 py25-nose py25-setuptools py25-zlib py25-gobject gimp-jp2 gimp-lqr-plugin liblqr gtk-nodoka-engine coreutils gmp gutenprint icns-gimp macclipboard-gimp macfile-gimp ufraw gtkimageview xsane sane-backends libusb
Error: Status 1 encountered during processing.

Please contact me via email at: ian.scott-fleming@…

thank you

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Port: gnome-keyring added
Summary: problem installing/upgrading: ImageMagick, Gimp, UFRaw on Mac OS X 10.5 on IMac 2.4 GHzproblem installing gnome-keyring while installing ImageMagick, Gimp, UFRaw on Mac OS X 10.5 on IMac 2.4 GHz

comment:2 Changed 12 years ago by iancsf (Ian Scott-Fleming)

This appears to be related to ticket #19717, the installation/upgrade of gnome-keyring. However, the solution supplied there does not work for me.

"sudo python_select python26" returns with: version "python26" is invalid!
"sudo python_select python25" works OK.
"python --version"  returns:  Python 2.5.4

but "sudo port install gnome-keyring" returns with:

sudo port install gnome-keyring
--->  Configuring gnome-keyring
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1" && ./configure --prefix=/opt/local " returned error 1
Command output: sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-keyring/work/gnome-keyring-2.26.1: No such file or directory

Error: Status 1 encountered during processing.

comment:3 Changed 12 years ago by mf2k (Frank Schima)

You would need to have installed python26 for it to work. In any event, you need to clean the port first.

sudo port clean gnome-keyring
sudo port install gnome-keyring

comment:4 Changed 12 years ago by iancsf (Ian Scott-Fleming)

Thanks. the last suggestion ("port clean gnome-keyring", then "port install...") seems to have fixed it.

It's not clear how one would know to do a "port clean..." in this situation. I had tried "port upgrade gnome-keyring", which returned msg about gnome-keyring not installed. So I tried "port install gnome-keyring" , which failed with error msg above.

Some clarification in the port man page on when a "port clean" is needed and when it isn't might be helpful. Or perhaps have the "port install..." scripts always to a "port clean..." before starting the install?

comment:5 Changed 11 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

"port clean" should be run when the portfile has not changed locally, but you have changed other ports that affect it.

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Summary: problem installing gnome-keyring while installing ImageMagick, Gimp, UFRaw on Mac OS X 10.5 on IMac 2.4 GHzgnome-keyring: gnome-keyring-2.26.1: No such file or directory

This problem was probably caused by #29223.

Note: See TracTickets for help on using tickets.