Opened 11 years ago

Closed 10 years ago

#19996 closed defect (worksforme)

Apache2 error: SSL/TLS libraries were missing or unusable

Reported by: jenoworld@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: apache2

Description

I am having some error when installing apache2 +universal:

--->  Fetching apache2
--->  Attempting to fetch httpd-2.2.11.tar.bz2 from http://distfiles.macports.org/apache2
--->  Verifying checksum(s) for apache2
--->  Extracting apache2
--->  Applying patches to apache2
--->  Configuring apache2
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.11" && ./configure --prefix=/opt/local/apache2 --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config --libdir=/opt/local/lib --with-expat=/opt/local --with-pcre=/opt/local --mandir=/opt/local/share/man --enable-mods-shared=all --enable-ssl --with-ssl=/opt/local --enable-cache --enable-disk_cache --enable-file_cache --enable-mem_cache --enable-deflate --enable-proxy --enable-proxy-connect --enable-proxy-http --enable-proxy-ftp --disable-dependency-tracking " returned error 1
Command output: checking whether to enable mod_version... shared (all)
checking whether to enable mod_proxy... shared (all)
checking whether to enable mod_proxy_connect... shared (all)
checking whether to enable mod_proxy_ftp... shared (all)
checking whether to enable mod_proxy_http... shared (all)
checking whether to enable mod_proxy_ajp... shared (all)
checking whether to enable mod_proxy_balancer... shared (all)
  adding "-I$(top_srcdir)/modules/proxy/../generators" to INCLUDES
checking whether to enable mod_ssl... checking dependencies
checking for SSL/TLS toolkit base... /opt/local
checking for OpenSSL version... checking openssl/opensslv.h usability... yes
checking openssl/opensslv.h presence... yes
checking for openssl/opensslv.h... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
OK
  forcing SSL_LIBS to "-lssl -lcrypto  -lpthread"
  adding "-lssl" to LIBS
  adding "-lcrypto" to LIBS
  adding "-lpthread" to LIBS
checking openssl/engine.h usability... yes
checking openssl/engine.h presence... yes
checking for openssl/engine.h... yes
checking for SSLeay_version... yes
checking for SSL_CTX_new... no
checking for ENGINE_init... yes
checking for ENGINE_load_builtin_engines... yes
checking for SSL_set_cert_store... no
configure: error: ... Error, SSL/TLS libraries were missing or unusable

Error: Status 1 encountered during processing.

Change History (6)

comment:1 Changed 11 years ago by jenoworld@…

Found a similar Apache2 error at #19595: build failure apache2 + openldap variant. They both shared the same line of error msg:

Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.11" && ./configure --prefix=/opt/local/apache2 --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config --libdir=/opt/local/lib --with-expat=/opt/local --with-pcre=/opt/local --mandir=/opt/local/share/man --enable-mods-shared=all --enable-ssl --with-ssl=/opt/local --enable-cache --enable-disk_cache --enable-file_cache --enable-mem_cache --enable-deflate --enable-proxy --enable-proxy-connect --enable-proxy-http --enable-proxy-ftp --disable-dependency-tracking " returned error 1

Also found a similar error at Installing PHP5: "Error, SSL/TLS libraries were missing or unusable" which shared the same line of error code:

configure: error: ... Error, SSL/TLS libraries were missing or unusable

Any idea?

Thanks & Regards,

comment:2 Changed 11 years ago by jenoworld@…

Cc: jenoworld@… added

Cc Me!

comment:3 Changed 11 years ago by mf2k (Frank Schima)

Cc: jenoworld@… removed
Owner: changed from macports-tickets@… to imajes@…
Port: apache2 added; apache removed

comment:4 Changed 11 years ago by jenoworld@…

any update?

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from imajes@… to macports-tickets@…

James Cox (imajes) retires as MacPorts maintainer (see macports-mgr archives)

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

Can't reproduce. Reopen and attach the config.log if you still experience the problem.

Note: See TracTickets for help on using tickets.