Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#20130 closed defect (fixed)

texshop fails to find x86_64 for extraction in 10.6

Reported by: nerdling (Nerdling) Owned by: nerdling (Nerdling)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: texshop


TeXShop fails to extract the x86_64 architecture on 10.6. This is likely because that version does not exist in the packaged binary.

Check the conditions for extracting various architectures.

--->  Extracting TeXShop
Error: Target org.macports.extract returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_TeXShop/work/texshop2.26 && lipo -thin x86_64 OgreKit.framework/Versions/A/OgreKit -output OgreKit.framework/Versions/A/OgreKit" returned error 1
Command output: lipo: fat input file (OgreKit.framework/Versions/A/OgreKit) does not contain the specified architecture (x86_64) to thin it to

Change History (3)

comment:1 Changed 7 years ago by nerdling (Nerdling)

  • Resolution set to fixed
  • Status changed from new to closed

Committed in r53285.

comment:2 Changed 7 years ago by jmroot (Joshua Root)

Won't this still fail since OgreKit will be i386 but everything else will be x86_64?

comment:3 Changed 7 years ago by nerdling (Nerdling)

The port has other build failures now – seemingly unrelated to Ogre and Sparkle – that appear to prevent it from getting to the point where everything gets put together. I'll make a new ticket for that issue evening.

Note: See TracTickets for help on using tickets.