Opened 10 years ago

Closed 10 years ago

#20211 closed update (fixed)

asterisk-1.6.1.1

Reported by: stefan.van.der.eijk@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: mr_bond@…, marc.blanchet@…
Port: asterisk

Description

Update to the asterisk port, to 1.6.1.1.

Attachments (3)

Portfile (1.4 KB) - added by stefan.van.der.eijk@… 10 years ago.
20090420__bug14930.diff (7.1 KB) - added by stefan.van.der.eijk@… 10 years ago.
Portfile.2 (1.3 KB) - added by g.vishnu@… 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by stefan.van.der.eijk@…

Attachment: Portfile added

Changed 10 years ago by stefan.van.der.eijk@…

Attachment: 20090420__bug14930.diff added

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Cc: mr_bond@… added
Owner: changed from macports-tickets@… to marc.blanchet@…
Port: asterisk added

comment:2 Changed 10 years ago by nerdling (Jeremy L)

Closed #20251 as duplicate of this ticket.

Changed 10 years ago by g.vishnu@…

Attachment: Portfile.2 added

comment:3 Changed 10 years ago by stefan.van.der.eijk@…

I don't think we're going to get a response from the maintainer(s). Can the maintainership perhaps be transferred to me?

comment:4 Changed 10 years ago by nerdling (Jeremy L)

Cc: marc.blanchet@… added
Owner: changed from marc.blanchet@… to snc@…
Status: newassigned

If you want to take over the port, file a port abandonment ticket.

Taking over this ticket, maintainer timeout.

comment:5 Changed 10 years ago by nerdling (Jeremy L)

Regarding #20251: It's a newer version, but beta. It does build, however.

I feel we should go for this port, non-beta. Does anyone have a preference?

comment:6 in reply to:  5 Changed 10 years ago by stefan.van.der.eijk@…

Replying to snc@…:

Regarding #20251: It's a newer version, but beta. It does build, however.

I feel we should go for this port, non-beta. Does anyone have a preference?

I don't mind if you got for the non-beta, as it contains 20090420bug14930.diff. Please take along the other changes I've made to the Portfile I've uploaded:

1/ Adding the startup item:

startupitem.create yes startupitem.netchange yes startupitem.executable ${prefix}/sbin/asterisk -d

2/ I think the following configure args should be sufficient:

configure.args --without-h323 --without-zaptel

It's been a while, but I think the arguments "--localstatedir=${prefix}/var --sysconfdir=${prefix}/etc/" caused a problem on my installation.

Do you have any plans to let asterisk run under it's own user account? I'd also like to see the jabber & gtalk module.

comment:7 Changed 10 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed

Updated asterisk to the non-beta version in r54184.

Included startupitem and config changes.

Note: See TracTickets for help on using tickets.