Opened 10 years ago

Closed 8 years ago

#20441 closed defect (fixed)

Quagga needs gawk as dependency

Reported by: mike-savory Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: quagga

Description

Testing on a clean install shows that gawk is a configure dependency for the port

Attachments (1)

Quagga_build_log.txt (37.6 KB) - added by mike-savory 10 years ago.
showas build failure on same sytem it previously built on…

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by mike-savory

Cc: msavory@… added

Cc Me!

comment:2 Changed 10 years ago by tobypeterson

Does it still configure properly with the system awk? No real reason to add the dependency just because it might get used.

comment:3 Changed 10 years ago by mike-savory

No, the configure phase actually fails with no gawk present, but also it looks like the build fails on macports trunk as well for some reason. Still investigating...

kernel_socket.c: In function 'bsd_linkdetect_translate':

kernel_socket.c:303: error: 'struct if_data' has no member named 'ifi_link_state'

kernel_socket.c:303: error: 'LINK_STATE_UP' undeclared (first use in this function)

kernel_socket.c:303: error: (Each undeclared identifier is reported only once

kernel_socket.c:303: error: for each function it appears in.)

kernel_socket.c:304: error: 'struct if_data' has no member named 'ifi_link_state'

kernel_socket.c:304: error: 'LINK_STATE_UNKNOWN' undeclared (first use in this function)

So the build woks OK on my Intel laptop 1.71 install (that has dozens of other ports installed), but fails on another new intel trunk install...

comment:4 Changed 10 years ago by tobypeterson

I can't reproduce the failure with trunk. Committed the gawk dependency in r54442 ...

comment:5 Changed 10 years ago by mike-savory

So I have reproduced the build failure on a clean sytem

I cloned my existing MP installation......

sudo port install quagga >> works fine

sudo port ninstall installed

sudo port install quagga >> fails

So there is obviously some other run time dependency on my previously installed packages...

Full log of the process attached...

comment:6 in reply to:  5 Changed 10 years ago by mike-savory

ninstall should read uninstall

Changed 10 years ago by mike-savory

Attachment: Quagga_build_log.txt added

showas build failure on same sytem it previously built on...

comment:7 Changed 8 years ago by jmroot (Joshua Root)

Cc: msavory@… removed
Keywords: quagga removed
Resolution: fixed
Status: newclosed

This appears to have been fixed quite a while ago.

Note: See TracTickets for help on using tickets.