Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#20501 closed defect (fixed)

pv-1.1.4 fails to build with universal_archs i386 x86_64

Reported by: boris.dusek@… Owned by: meissnem@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: universal Cc:
Port: pv

Description

I have installed MacPorts 1.7.1 with the installer, ran selfupdate, set universal_archs to "i386 x86_64" in my macports.conf, and have set +universal (and nothing else) in my variants.conf. When installing pv, all the dependencies (e.g. ncurses, expat, gettext) get compiled fine with universal, but pv itself fails. Below is the output.

Other user confirmed the same with universal_archs ppc i386.

OK, here is the Terminal output:

--->  Building pv
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_pv/work/pv-1.1.4" && nice -n 20 make all " returned error 2
Command output: /usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/main/main.o src/main/main.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/main/options.o src/main/options.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/main/remote.o src/main/remote.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/main/version.o src/main/version.c
ld -r -o src/main.o  src/main/help.o src/main/main.o src/main/options.o src/main/remote.o src/main/version.o
ld warning: -arch not specified
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/library/getopt.o src/library/getopt.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/library/gettext.o src/library/gettext.c
ld -r -o src/library.o  src/library/getopt.o src/library/gettext.o
ld warning: -arch not specified
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/cursor.o src/pv/cursor.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/display.o src/pv/display.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/file.o src/pv/file.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/loop.o src/pv/loop.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/number.o src/pv/number.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/signal.o src/pv/signal.c
/usr/bin/gcc-4.0 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk -I./src/include -Isrc/include -DHAVE_CONFIG_H -DLOCALEDIR=\"/opt/local/share/locale\" -c -o src/pv/transfer.o src/pv/transfer.c
ld -r -o src/pv.o  src/pv/cursor.o src/pv/display.o src/pv/file.o src/pv/loop.o src/pv/number.o src/pv/signal.o src/pv/transfer.o
ld warning: -arch not specified
/usr/bin/gcc-4.0 -L/opt/local/lib -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -arch x86_64 -mmacosx-version-min=10.5 -o pv src/main.o src/library.o src/pv.o  -lintl 
ld warning: in src/main.o, file is not of required architecture
ld warning: in src/library.o, file is not of required architecture
ld warning: in src/pv.o, file is not of required architecture
Undefined symbols for architecture x86_64:
  "_main", referenced from:
      start in crt1.10.5.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//ccL7Fz8Q.out (No such file or directory)
make: *** [pv] Error 1

Error: Status 1 encountered during processing.

Attachments (1)

pv.diff (257 bytes) - added by meissnem@… 12 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by boris.dusek@…

Cc: boris.dusek@… added

Cc Me!

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Cc: meissnem@… boris.dusek@… removed
Keywords: pv removed
Owner: changed from macports-tickets@… to meissnem@…

Changed 12 years ago by meissnem@…

Attachment: pv.diff added

comment:3 Changed 12 years ago by meissnem@…

This is due to a quirk in pv's makefiles. The easiest and cleanest way around seems to be to use the muniversal portgroup.

I tested this on 10.5.7 with trunk macports. I see no reason why it won't work with 1.7.1 as well, but if someone with 1.7.1 would mind testing it I'd appreciate it.

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Worked for me on 10.5.7 intel with MacPorts 1.7.1 so I committed it in r54697. Thanks.

comment:5 in reply to:  3 Changed 12 years ago by boris.dusek@…

Worked for me with 10.5.7, 1.7.1 as well. Thanks from me too.

Note: See TracTickets for help on using tickets.