Opened 11 years ago

Closed 11 years ago

#20596 closed defect (fixed)

xmedcon +fortran has never worked

Reported by: ryandesign (Ryan Schmidt) Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: xmedcon

Description

The +fortran variant of xmedcon has never worked:

$ port install xmedcon +fortran
--->  Fetching xmedcon
--->  Attempting to fetch xmedcon-0.10.4.tar.gz from http://prdownloads.sourceforge.net/xmedcon/
--->  Verifying checksum(s) for xmedcon
--->  Extracting xmedcon
--->  Configuring xmedcon
Error: Target org.macports.configure returned: Invalid value for configure.compiler
Error: Status 1 encountered during processing.

When the port was originally added in r41666, configure.compiler was specified in that variant as "/opt/local/bin/gcc-mp-4.3". This was changed in r55190 to "${prefix}/bin/gcc-mp-4.3" but this is still not right. The value for configure.compiler should be one of those listed here, for example "macports-gcc-4.3". And then it is unnecessary to set configure.f77 yourself, since the purpose of setting configure.compiler is that MacPorts will then set configure.f77 and the other related variables for you.

Even when fixing that, I am unable to determine if the variant is having any effect. For example, I would have expected the gfortran-mp-4.3 program to be used during the build phase, but it does not appear to be.

Attachments (1)

xmedcon.diff (400 bytes) - added by ryandesign (Ryan Schmidt) 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by ryandesign (Ryan Schmidt)

Attachment: xmedcon.diff added

comment:1 Changed 11 years ago by jameskyle@…

Ah yes, this was one of my first ports. I'll go back over it.

comment:2 Changed 11 years ago by jameskyle@…

Yeah, looks like it does nothing. Been too long to remember why I added it. I replaced it with gcc43 variant.

comment:3 Changed 11 years ago by jameskyle@…

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.