Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#20741 closed defect (fixed)

pan2: No package 'gmime-2.0' found

Reported by: markus.falb@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: pan gmime Cc: krischik@…, payam.minoofar@…
Port: pan2

Description

After upgrading to gmime @2.4.8_0 pan is complaining:

mac:~ mf$ pan &
[1] 80892
mac:~ mf$ dyld: Library not loaded: /opt/local/lib/libgmime-2.0.2.dylib
  Referenced from: /opt/local/bin/pan
  Reason: image not found

i tried a rebuild of pan, also complaining:

checking for GMIME... configure: error: Package requirements (gmime-2.0    >= 2.1.9) were not met:

No package 'gmime-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GMIME_CFLAGS
and GMIME_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

there is an open bug upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=541676

it seems that pan requires gmime 2.2 ?

Change History (12)

comment:1 Changed 11 years ago by markus.falb@…

Cc: markus.falb@… added

Cc Me!

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: markus.falb@… removed
Port: pan2 added

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

You should encourage the developers to support gmime 2.4. That upstream bug was filed 13 months ago and has still not been fixed. It's about time they fixed it.

comment:4 Changed 11 years ago by krischik@…

Cc: krischik@… added

Cc Me!

comment:5 Changed 11 years ago by hippallium-macports@…

For information, I was able to install manually pan2 (version 0.133) by:

  1. Installing gmime 2.1.19 in /Users/myhome/local/gmime/
  1. Typing the commands:
export PKG_CONFIG_PATH=/Users/myhome/local/gmime/lib/pkgconfig/
./configure --prefix=/Users/myhome/local/pan/
make GMSGFMT=/opt/local/bin/msgfmt
make install

Hope it helps.

comment:6 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: payam.minoofar@… ryandesign@… added
Summary: pan unmet gmime dependencypan2: No package 'gmime-2.0' found

Has duplicate #21246.

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Has duplicate #20781.

comment:8 Changed 11 years ago by dimavs@…

comment:9 Changed 11 years ago by payam.minoofar@…

Has this patch been committed to port? If not, how do I apply it? Thanks.

comment:10 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

It builds fine for me too (on Snow Leopard). I committed the patch in r58069.

comment:11 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:12 Changed 11 years ago by ryandesign (Ryan Schmidt)

The patch apparently contained a small bug:

OOPS. Commenting out of the g_free for pch in body-pane.cc line 955 was a mistake.

I've fixed that in r58070.

Note: See TracTickets for help on using tickets.