Opened 10 years ago

Closed 10 years ago

#20862 closed defect (fixed)

screen port fails to compile under Snow Leopard 10.6

Reported by: mina.macports@… Owned by: digdog@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: snowleopard Cc: tomvons@…, hiro.qli+macports@…, tharant@…, mcamou@…, bgrupe27, mccune.jeff@…, arturoc@…, greg@…, sck@…, nan.liu@…, nerdling (Jeremy L), 858wildcat@…, fracai, drkp (Dan Ports), ryandesign (Ryan Schmidt)
Port: screen

Description

This ticket is essentially a resurrection of #13009, except it's for Snow Leopard instead of Leopard this time.

Install attempt output:

t# port install screen
--->  Computing dependencies for screen
--->  Building screen
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_screen/work/screen-4.0.3" && /usr/bin/make -j2 all " returned error 2
Command output: utmp.c:499: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c: At top level:
utmp.c:639: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c:668: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c:678: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c: In function 'getutslot':
utmp.c:682: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c: In function 'pututslot':
utmp.c:691: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c: In function 'makedead':
utmp.c:710: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
utmp.c: In function 'makeuser':
utmp.c:725: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
/usr/bin/gcc-4.2 -c -I. -I.    -O2 -arch x86_64 loadav.c
In file included from screen.h:144,
                 from loadav.c:41:
display.h:182: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
In file included from screen.h:145,
                 from loadav.c:41:
window.h:247: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
/usr/bin/gcc-4.2 -c -I. -I.    -O2 -arch x86_64 pty.c
In file included from screen.h:144,
                 from pty.c:30:
display.h:182: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
In file included from screen.h:145,
                 from pty.c:30:
window.h:247: warning: 'utmp' is deprecated (declared at /usr/include/utmp.h:96)
pty.c:38:26: error: sys/stropts.h: No such file or directory
make: *** [pty.o] Error 1
make: *** Waiting for unfinished jobs....

Error: Status 1 encountered during processing.

Attachments (2)

screen-4.0.3-snowleopard.patch (11.0 KB) - added by mccune.jeff@… 10 years ago.
Patch to compile screen-4.0.3 in Mac OS X Snow Leopard
patch-screen.diff (3.7 KB) - added by raimue (Rainer Müller) 10 years ago.
Patch for Snow Leopard

Download all attachments as: .zip

Change History (35)

comment:1 Changed 10 years ago by tobypeterson

Just need to pull patches from http://www.opensource.apple.com/source/screen/screen-16/

I'll get around to it eventually, but there isn't really much reason to use screen from MacPorts on Snow Leopard.

comment:2 in reply to:  1 ; Changed 10 years ago by mina.macports@…

Replying to toby@…:

Just need to pull patches from http://www.opensource.apple.com/source/screen/screen-16/

I'll get around to it eventually, but there isn't really much reason to use screen from MacPorts on Snow Leopard.

Actually there is.

The screen that ships with Leopard, and Snow Leopard, is buggy.

It simply refuses to remember the current directory.

Every new window started within a screen session starts in ~, no matter what the original directory was when screen was started.

Just googled it actually, and people have been coming up with some nasty hacks to work around that problem.

comment:3 Changed 10 years ago by tharant@…

Cc: mcalhoun@… kentk@… mike@… alexguo@… robin@… lstoll@… tamyrvoll@… john+macports@… joshua_anderson@… huahang.liu@… faisal.moledina@… tomvons@… benjaminkreeger@… m@… andrius.laikina@… dizzyd@… xmitchx@… treaves@… shrift@… tannhaus@… added

Cc Me!

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to digdog@…

comment:5 in reply to:  2 Changed 10 years ago by tobypeterson

Replying to mina.macports@…:

The screen that ships with Leopard, and Snow Leopard, is buggy.

It simply refuses to remember the current directory.

Every new window started within a screen session starts in ~, no matter what the original directory was when screen was started.

Just googled it actually, and people have been coming up with some nasty hacks to work around that problem.

I cannot reproduce this issue.

comment:6 Changed 10 years ago by tobypeterson

Also... where did the giant list of cc'd people come from?

comment:7 Changed 10 years ago by xmitchx@…

Cc: xmitchx@… removed

Cc Me!

comment:8 in reply to:  6 Changed 10 years ago by xmitchx@…

Replying to toby@…:

Also... where did the giant list of cc'd people come from?

I'm not sure, but I was on the python26 ticket (#20284) and it looks like someone copied my email address over to this ticket when, although I use screen and I'm interested, is not nearly blocking to me as the python26 issue is.

I've removed myself. Please don't cherrypick my email and CC me on random tickets.

comment:9 Changed 10 years ago by tomvons@…

Odd, I was on the python26 ticket as well... though I actually have an interest in this ticket, coincidentally enough.

I have the same problem/motivation as mina.macports@, no matter where I start screen, new windows open in ~ and not in the directory I started screen in. This was the same for 10.5 as well, which is my only motivation for installing screen from ports.

comment:10 Changed 10 years ago by huahang.liu@…

Cc: huahang.liu@… removed

Cc Me!

comment:11 Changed 10 years ago by tobypeterson

Someone who can reproduce this, please provide more detailed steps. screen definitely preserves the working directory for me, and there's nothing particularly interesting about my shell setup.

comment:12 Changed 10 years ago by tobypeterson

(on Snow Leopard... not interested in Leopard)

comment:13 Changed 10 years ago by tomvons@…

Try adding this to your ~/.screenrc:

shell -$SHELL

Without that line, it works as it should (though screen from macports and screen on ubuntu and debian systems don't have a problem with it).

comment:14 Changed 10 years ago by lstoll@…

Cc: lstoll@… removed

Cc Me!

comment:15 Changed 10 years ago by hiro.qli+macports@…

Cc: hiro.qli+macports@… added

Cc Me!

comment:16 Changed 10 years ago by robin@…

Cc: robin@… removed

Cc Me!

comment:17 Changed 10 years ago by jmroot (Joshua Root)

Cc: tharant@… added; mcalhoun@… kentk@… mike@… alexguo@… tamyrvoll@… john+macports@… joshua_anderson@… faisal.moledina@… benjaminkreeger@… m@… andrius.laikina@… dizzyd@… treaves@… shrift@… tannhaus@… removed
Keywords: snowleopard added; screen snow leopard 10.6 sys stropts.h removed

Cleaning up after cc malfunction.

comment:18 Changed 10 years ago by mcamou@…

Cc: mcamou@… added

Cc Me!

comment:19 Changed 10 years ago by bgrupe27

Cc: bgrupe@… added

Cc Me!

Changed 10 years ago by mccune.jeff@…

Patch to compile screen-4.0.3 in Mac OS X Snow Leopard

comment:20 Changed 10 years ago by mccune.jeff@…

I created the patch based on the patches located at http://www.opensource.apple.com/source/screen/screen-16/patches/ and vproc_priv.h from http://launchd.macosforge.org/trac/browser/trunk/launchd/src/vproc_priv.h?rev=23880

Apply the patch using patch -p1 < screen-4.0.3-snowleopard.patch.

Here's how I've compiled screen while MacPorts is updated:

./configure --enable-locale --enable-telnet --enable-colors256 --enable-rxvt_osc --prefix=/usr/local

Enjoy.

comment:21 Changed 10 years ago by mccune.jeff@…

Cc: mccune.jeff@… added

Cc Me!

comment:22 Changed 10 years ago by arturoc@…

Cc: arturoc@… added

Cc Me!

comment:23 Changed 10 years ago by greg@…

Cc: greg@… added

Cc Me!

comment:24 Changed 10 years ago by sck@…

Cc: sck@… added

Cc Me!

comment:25 Changed 10 years ago by nan.liu@…

Cc: nan.liu@… added

Cc Me!

comment:26 Changed 10 years ago by nerdling (Jeremy L)

Cc: snc@… added

Cc Me!

comment:27 Changed 10 years ago by 858wildcat@…

Cc: 858wildcat@… added

Cc Me!

comment:28 Changed 10 years ago by fracai

Cc: arno+macports@… added

Cc Me!

comment:29 Changed 10 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

Changed 10 years ago by raimue (Rainer Müller)

Attachment: patch-screen.diff added

Patch for Snow Leopard

comment:30 in reply to:  29 Changed 10 years ago by drkp (Dan Ports)

attachment patch-screen.diff added

Patch for Snow Leopard

In case you missed my message on irc -- I'm using this patch now and screen builds and runs correctly with it.

comment:31 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

Committed Rainer's patch in r62349. Thanks.

comment:32 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

This breaks the build on Leopard.

comment:33 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Fixed Leopard in r62355.

Note: See TracTickets for help on using tickets.