Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#20870 closed defect (duplicate)

Missing module causes python 2.6 to fail to compile on 10.6

Reported by: treaves@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: macports@…, ed@…
Port: python26

Description (last modified by blb@…)

Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.2" && /usr/bin/make frameworkinstall maninstall MAKE="/usr/bin/make CC=/usr/bin/gcc-4.2" DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot " returned error 2
Command output: /usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/hello_world.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/index.html /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/loading_ide.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/making_new_window.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/new_ide_window.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/new_window_made.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/output_window.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/saving_edited_file.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/simple_commands.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -m 644 ./Resources/app/Resources/English.lproj/Documentation/ide/syntax_error.gif /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Resources/English.lproj/Documentation/ide
/usr/bin/install -c -s ../python.exe "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python"
sed -e "s!%bundleid%!org.python.python!g" \
		-e "s!%version%!`DYLD_FRAMEWORK_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.2: ../python.exe \
		-c 'import platform; print(platform.python_version())'`!g" \
		< "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Info.plist.in" \
		> "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Info.plist"
rm "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/Info.plist.in"
PYTHONHOME=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6 DYLD_FRAMEWORK_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.2: arch -i386 ../python.exe ./scripts/BuildApplet.py \
		--destroot "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot" \
		--python=/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python`test -f "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python-32" && echo "-32"`  \
		--output "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/Applications/MacPorts/Python 2.6/Build Applet.app" \
		./scripts/BuildApplet.py
Traceback (most recent call last):
  File "./scripts/BuildApplet.py", line 15, in <module>
    import EasyDialogs
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac/EasyDialogs.py", line 34, in <module>
    import Nav
ImportError: No module named Nav
make[1]: *** [install_BuildApplet] Error 1
make: *** [frameworkinstallapps] Error 2
Error: Status 1 encountered during processing.
Executing: /opt/local/bin/port install python26 +universal

Change History (9)

comment:1 Changed 8 years ago by blb@…

  • Description modified (diff)
  • Port python26 added
  • Resolution set to duplicate
  • Status changed from new to closed

Dup of #20284.

comment:2 Changed 8 years ago by treaves@…

If this is a duplicate of #20284 (which I saw before creating this one), why is the stack different?

comment:3 Changed 8 years ago by blb@…

The specific trace may differ some, but the basic issue of python26 + Mac OS X 10.6 is #20284; hopefully they can all be handled together.

comment:4 Changed 8 years ago by macports@…

I just fixed this by editing /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.2/Lib/plat-mac/EasyDialogs.py and removing the "import Nav" line.

Also, you'll need to build zlib with +universal to overcome a missing _crc32 symbol error later.

comment:5 Changed 8 years ago by treaves@…

That fixed it for me too. This needs to be re-opened.

comment:6 Changed 8 years ago by jim@…

Worked for me too. python26 +universal installed using tips above.

comment:7 Changed 8 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:8 Changed 8 years ago by mattias@…

To remove that import is not a good idea, as it will pretty much break easydialogs and render it unusable.

comment:9 Changed 8 years ago by ed@…

  • Cc ed@… added

Cc Me!

Note: See TracTickets for help on using tickets.