Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#20912 closed defect (fixed)

wine, wine-devel: configure failure when freetype is 64-bit

Reported by: dackze+macports@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: snowleopard Cc: jyrkiwahlstedt, lhunath@…, avs@…, Damien@…, macports.users@…, marco.stankowitz@…, skaimauve@…, sawtdk@…, justin.kinglacroix@…, pjkixx@…
Port: wine, wine-devel

Description

$ sudo port install wine-devel
--->  Computing dependencies for wine-devel
--->  Configuring wine-devel
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_wine-devel/work/wine-1.1.28" && ./configure --prefix=/opt/local --x-include=/opt/local/include --x-lib=/opt/local/lib --disable-win16 " returned error 1
Command output: checking for xmlParseMemory in -lxml2... no
checking for xmlReadMemory in -lxml2... no
checking for xmlNewDocPI in -lxml2... no
checking for libxslt/pattern.h... yes
checking for libxslt/transform.h... yes
checking for -lxslt... not found
checking dbus/dbus.h usability... no
checking dbus/dbus.h presence... no
checking for dbus/dbus.h... no
checking hal/libhal.h usability... no
checking hal/libhal.h presence... no
checking for hal/libhal.h... no
checking gnutls/gnutls.h usability... no
checking gnutls/gnutls.h presence... no
checking for gnutls/gnutls.h... no
checking for -lncurses... not found
checking for mousemask... no
checking for sane-config... no
checking sane/sane.h usability... no
checking sane/sane.h presence... no
checking for sane/sane.h... no
checking for gphoto2-config... no
checking for gphoto2-port-config... no
checking gphoto2-camera.h usability... no
checking gphoto2-camera.h presence... no
checking for gphoto2-camera.h... no
checking for freetype-config... freetype-config
checking for -lfreetype... not found
configure: error: FreeType 32-bit development files not found. Fonts will not be built.
Use the --without-freetype option if you really want this.

Error: Status 1 encountered during processing.
$ port installed | grep freetype
  freetype @2.3.9_0+macosx (active)

I'm guessing the wine port has the same issue, but I haven't tried building it yet.

Attachments (1)

wine-devel.debug (112.4 KB) - added by justin.kinglacroix@… 11 years ago.

Download all attachments as: .zip

Change History (33)

comment:1 Changed 12 years ago by nerdling (Jeremy Lavergne)

Cc: jwa@… added
Keywords: snowleopard added
Owner: changed from macports-tickets@… to ryandesign@…
Port: freetype wine added

Yes, wine has the same issue.

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

There is no issue, really. wine and wine-devel cannot be built 64-bit, so they force themselves to 32-bit. That means you must build all the dependencies 32-bit too, or universal 32-/64-bit

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

So this is to be fixed by MacPorts base. See #20728.

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Summary: wine-devel fails to build on 10.6wine-devel fails to build when freetype is 64-bit

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Keywords: wine freetype removed
Port: freetype removed
Summary: wine-devel fails to build when freetype is 64-bitwine, wine-devel: configure failure when freetype is 64-bit

comment:6 Changed 12 years ago by lhunath@…

Cc: lhunath@… added

Cc Me!

comment:7 Changed 12 years ago by lhunath@…

Cc: lhunath@… removed

Cc Me!

comment:8 Changed 12 years ago by lhunath@…

Cc: lhunath@… added

Cc Me!

comment:9 Changed 11 years ago by avs@…

Cc: avs@… added

Cc Me!

comment:10 in reply to:  2 ; Changed 11 years ago by avs@…

Replying to ryandesign@…:

There is no issue, really. wine and wine-devel cannot be built 64-bit, so they force themselves to 32-bit. That means you must build all the dependencies 32-bit too, or universal 32-/64-bit

I have all wine-devel deps +universal but configure still fails as per the original comment. Is there something more to that?

comment:11 in reply to:  10 ; Changed 11 years ago by avs@…

Replying to avs@…:

I have all wine-devel deps +universal but configure still fails as per the original comment. Is there something more to that?

Sorry, fontconfig wasn't +universal, it fails to build if freetype is +universal.

comment:12 Changed 11 years ago by Damien@…

Cc: Damien@… added

Cc Me!

comment:13 Changed 11 years ago by tobypeterson

Cc: macports.users@… added

comment:14 in reply to:  11 ; Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to avs@…:

Replying to avs@…:

I have all wine-devel deps +universal but configure still fails as per the original comment. Is there something more to that?

Sorry, fontconfig wasn't +universal, it fails to build if freetype is +universal.

It works fine for me. Feel free to file a new bug for fontconfig, or send a message to the macports-users mailing list, either way including the full debug output of your failed fontconfig build attempt.

comment:15 Changed 11 years ago by macports.users@…

This works too!

# port install wine-devel configure.args=--without-freetype

comment:16 Changed 11 years ago by ryandesign (Ryan Schmidt)

...but then your wine isn't using freetype, which is presumably beneficial.

comment:17 in reply to:  14 ; Changed 11 years ago by avs@…

It works fine for me. Feel free to file a new bug for fontconfig, or send a message to the macports-users mailing list, either way including the full debug output of your failed fontconfig build attempt.

I got it to build after doing port selfupdate - I don't know what was wrong for the first time. I upgraded all wine-devel deps to +universal with --enforce-variants and wine-devel now builds smoothly (even with freetype) and works. So just like you said on comment 2.

comment:18 in reply to:  17 ; Changed 11 years ago by Mills00013@…

Replying to avs@…:

It works fine for me. Feel free to file a new bug for fontconfig, or send a message to the macports-users mailing list, either way including the full debug output of your failed fontconfig build attempt.

I got it to build after doing port selfupdate - I don't know what was wrong for the first time. I upgraded all wine-devel deps to +universal with --enforce-variants and wine-devel now builds smoothly (even with freetype) and works. So just like you said on comment 2.

Would it be possible for you to display your entire command set to get this to work? I am having trouble getting the usage right on the --enforce-varients command. I dont know where or when its appropriate to use it.

comment:19 Changed 11 years ago by tobypeterson

Cc: marco.stankowitz@… added

comment:20 Changed 11 years ago by skaimauve@…

Cc: skaimauve@… added

Cc Me!

comment:21 Changed 11 years ago by sawtdk@…

Cc: sawtdk@… added

Cc Me!

comment:22 Changed 11 years ago by justin.kinglacroix@…

Same issue - all deps are +universal, but get the same error as above. Attached debug log.

Changed 11 years ago by justin.kinglacroix@…

Attachment: wine-devel.debug added

comment:23 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: justin.kinglacroix@… added

Justin, your output:

checking for freetype-config... no
checking for freetype2-config... no
checking for -lfreetype... libfreetype.6.dylib
checking for ft2build.h... no
checking for freetype/freetype.h... no
checking for freetype/ftglyph.h... no
checking for freetype/fttypes.h... no
checking for freetype/tttables.h... no
checking for freetype/ftsnames.h... no
checking for freetype/ttnameid.h... no
checking for freetype/ftoutln.h... no
checking for freetype/ftwinfnt.h... no
checking for freetype/ftmodapi.h... no
checking for freetype/ftlcdfil.h... no
checking for freetype/internal/sfnt.h... no
checking for FT_TrueTypeEngineType... no
checking for FT_Load_Sfnt_Table... yes
configure: error: FreeType 32-bit development files not found. Fonts will not be built.
Use the --without-freetype option if you really want this.

is different than that originally reported in this ticket, which was:

checking for freetype-config... freetype-config
checking for -lfreetype... not found
configure: error: FreeType 32-bit development files not found. Fonts will not be built.
Use the --without-freetype option if you really want this.

So you are experiencing a different issue. Somehow it appears that your freetype-config program and all the freetype headers are missing. Try rebuilding your freetype:

sudo port clean freetype
sudo port -n upgrade --force freetype

Then try wine-devel again:

sudo port clean wine-devel
sudo port install wine-devel

comment:24 in reply to:  18 Changed 11 years ago by avs@…

Replying to Mills00013@…:

Would it be possible for you to display your entire command set to get this to work? I am having trouble getting the usage right on the --enforce-varients command. I dont know where or when its appropriate to use it.

Sure. There was some sort of problem with building fontconfig, so I uninstalled it and rebuilt it first

sudo port selfupdate
sudo port uninstall -f freetype
sudo port uninstall -f fontconfig

..Then I upgraded all wine-devel deps

sudo port clean wine-devel
sudo port deps wine-devel

..for every dep listed by the above command (I am not sure if you could do this in another way)

sudo port upgrade --enforce-variants <dep-name> +universal

..and finally installed fontconfig and freetype back

sudo port install freetype +universal
sudo port install fontconfig +universal
sudo port install wine-devel

and it worked.

comment:25 Changed 11 years ago by justin.kinglacroix@…

Thanks Ryan! Worked a charm. Apologies to all for the spam.

comment:26 Changed 11 years ago by Jens_Abraham@…

Cc: Jens_Abraham@… added

Cc Me!

comment:27 Changed 11 years ago by Jens_Abraham@…

Cc: Jens_Abraham@… removed

Cc Me!

comment:28 in reply to:  3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to ryandesign@…:

So this is to be fixed by MacPorts base. See #20728.

I've worked around it for now in r58381. wine and wine-devel should now alert you if you try to install and a dependency doesn't have the right architectures.

comment:29 Changed 11 years ago by ryandesign (Ryan Schmidt)

comment:30 Changed 11 years ago by pjkixx@…

Cc: pjkixx@… added

Cc Me!

comment:31 Changed 11 years ago by pjkixx@…

i'm having trouble getting this to build as well but i'm getting a different error altogether.

i've followed all instructions and have rebuilt all deps using --enforce-variants and +universal with no luck.

here is the output i get.


$ sudo port install wine-devel
Password:
--->  Computing dependencies for wine-devel
--->  Building wine-devel
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_wine-devel/work/wine-1.1.34" && /usr/bin/make -j1 depend all " returned error 2
Command output: authors.c:772: error: stray '\204' in program
authors.c:786: error: stray '\303' in program
authors.c:786: error: stray '\251' in program
authors.c:821: error: stray '\303' in program
authors.c:821: error: stray '\262' in program
authors.c:844: error: stray '\303' in program
authors.c:844: error: stray '\251' in program
authors.c:926: error: stray '\303' in program
authors.c:926: error: stray '\274' in program
authors.c:937: error: stray '\303' in program
authors.c:937: error: stray '\274' in program
authors.c:985: error: stray '\303' in program
authors.c:985: error: stray '\270' in program
authors.c:1123: error: stray '\305' in program
authors.c:1123: error: stray '\202' in program
authors.c:1133: error: stray '\305' in program
authors.c:1133: error: stray '\201' in program
authors.c:1133: error: stray '\305' in program
authors.c:1133: error: stray '\202' in program
authors.c:1155: error: stray '\305' in program
authors.c:1155: error: stray '\202' in program
authors.c:1172: error: stray '\303' in program
authors.c:1172: error: stray '\205' in program
authors.c:1172: error: stray '\303' in program
authors.c:1172: error: stray '\266' in program
authors.c:1173: error: stray '\303' in program
authors.c:1173: error: stray '\205' in program
make[2]: *** [authors.o] Error 1
make[1]: *** [shell32] Error 2
make: *** [dlls] Error 2

Error: Status 1 encountered during processing.

comment:32 in reply to:  31 Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to pjkixx@…:

i'm having trouble getting this to build as well but i'm getting a different error altogether.

Please file a new ticket, including complete debug output. (The output you provided above is not sufficient to determine where the problem is.)

Note: See TracTickets for help on using tickets.