Opened 7 years ago

Closed 7 years ago

#21007 closed defect (fixed)

mp4v2 build fails on Tiger (libtool: more than one: -current_version option specified)

Reported by: vinc17@… Owned by: cedric.luthi@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: tiger Cc: dbevans (David B. Evans), h8spawn@…, gale@…, ultrajoe@…, hydrocell@…, boydb@…, Mobius.fr@…, fang@…, ryandesign (Ryan Schmidt), logan@…, dougmencken@…
Port: mp4v2

Description

I get the following error on Tiger (PowerPC):

/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: more than one: -current_version option specified
Usage: /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool -static [-] file [...] [-filelist listfile[,dirname]] [-arch_only arch] [-sacLT]
Usage: /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool -dynamic [-] file [...] [-filelist listfile[,dirname]] [-arch_only arch] [-o output] [-install_name name] [-compatibility_version #] [-current_version #] [-seg1addr 0x#] [-segs_read_only_addr 0x#] [-segs_read_write_addr 0x#] [-seg_addr_table <filename>] [-seg_addr_table_filename <file_system_path>] [-all_load] [-noall_load]
make: *** [libmp4v2.la] Error 1

The libtool command line that leads to the error is:

/bin/sh ./libtool --tag=CXX --mode=link /usr/bin/g++-4.0 -Wall -Wformat -O2 -arch ppc -fvisibility=hidden  -L/opt/local/lib -o libmp4v2.la -rpath /opt/local/lib -version-number 1:9:1 -Wl,-current_version,1.9.1 -Wl,-compatibility_version,1.0.0 src/3gp.lo [...]

Attachments (4)

hack-verstring.patch (3.0 KB) - added by stephen@… 7 years ago.
mp4v2-1.9.1-libversion.patch (1.8 KB) - added by holin@… 7 years ago.
fix libtool versioning conflict
mp4v2.txt (92.7 KB) - added by gale@… 7 years ago.
Yes, the build still fails. Here is the debugging output.
mp4v2_patched.txt (56.2 KB) - added by gale@… 7 years ago.
And here is the debugging output from the successful build after applying holin's patch.

Download all attachments as: .zip

Change History (48)

comment:1 Changed 7 years ago by tobypeterson

  • Owner changed from cedric.luthi@… to cedric.luthi@…

comment:2 Changed 7 years ago by tobypeterson

  • Keywords tiger added
  • Version 1.8.0 deleted

comment:3 Changed 7 years ago by nerdling (Nerdling)

Just an FYI, I can build this on 10.5 PPC.

comment:4 follow-up: Changed 7 years ago by stephen@…

This seems to be breakage in GNU libtool. The link command used is

/usr/bin/g++-4.0 -dynamiclib ${wl}-undefined ${wl}dynamic_lookup -o .libs/libmp4v2.1.9.1.dylib
src/.libs/3gp.o src/.libs/atom_ac3.o src/.libs/atom_amr.o src/.libs/atom_avc1.o src/.libs/atom_avcC.o src/.libs/atom_chpl.o src/.libs/atom_colr.o src/.libs/atom_d263.o src/.libs/atom_dac3.o src/.libs/atom_damr.o src/.libs/atom_dref.o src/.libs/atom_elst.o src/.libs/atom_enca.o src/.libs/atom_encv.o src/.libs/atom_free.o src/.libs/atom_ftyp.o src/.libs/atom_ftab.o src/.libs/atom_gmin.o src/.libs/atom_hdlr.o src/.libs/atom_hinf.o src/.libs/atom_hnti.o src/.libs/atom_href.o src/.libs/atom_mdat.o src/.libs/atom_mdhd.o src/.libs/atom_meta.o src/.libs/atom_mp4s.o src/.libs/atom_mp4v.o src/.libs/atom_mvhd.o src/.libs/atom_nmhd.o src/.libs/atom_ohdr.o src/.libs/atom_pasp.o src/.libs/atom_root.o src/.libs/atom_rtp.o src/.libs/atom_s263.o src/.libs/atom_sdp.o src/.libs/atom_sdtp.o src/.libs/atom_smi.o src/.libs/atom_sound.o src/.libs/atom_standard.o src/.libs/atom_stbl.o src/.libs/atom_stdp.o src/.libs/atom_stsc.o src/.libs/atom_stsd.o src/.libs/atom_stsz.o src/.libs/atom_stz2.o src/.libs/atom_text.o src/.libs/atom_tfhd.o src/.libs/atom_tkhd.o src/.libs/atom_treftype.o src/.libs/atom_trun.o src/.libs/atom_tx3g.o src/.libs/atom_udta.o src/.libs/atom_url.o src/.libs/atom_urn.o src/.libs/atom_uuid.o src/.libs/atom_video.o src/.libs/atom_vmhd.o src/.libs/cmeta.o src/.libs/descriptors.o src/.libs/exception.o src/.libs/isma.o src/.libs/mp4.o src/.libs/mp4atom.o src/.libs/mp4container.o src/.libs/mp4descriptor.o src/.libs/mp4file.o src/.libs/mp4file_io.o src/.libs/mp4info.o src/.libs/mp4meta.o src/.libs/mp4property.o src/.libs/mp4track.o src/.libs/mp4util.o src/.libs/ocidescriptors.o src/.libs/odcommands.o src/.libs/qosqualifiers.o src/.libs/rtphint.o src/.libs/text.o src/bmff/.libs/typebmff.o src/itmf/.libs/CoverArtBox.o src/itmf/.libs/Tags.o src/itmf/.libs/generic.o src/itmf/.libs/type.o src/qtff/.libs/ColorParameterBox.o src/qtff/.libs/PictureAspectRatioBox.o src/qtff/.libs/coding.o libplatform/io/.libs/File.o libplatform/io/.libs/FileSystem.o libplatform/prog/.libs/option.o libplatform/sys/.libs/error.o libplatform/time/.libs/time.o libplatform/io/.libs/File_posix.o libplatform/io/.libs/FileSystem_posix.o libplatform/number/.libs/random_posix.o libplatform/process/.libs/process_posix.o libplatform/time/.libs/time_posix.o libutil/.libs/Database.o libutil/.libs/Timecode.o libutil/.libs/TrackModifier.o libutil/.libs/Utility.o libutil/.libs/crc.o libutil/.libs/other.o 
-L/opt/local/lib  -arch i386 -Wl,-current_version -Wl,1.9.1 -Wl,-compatibility_version -Wl,1.0.0
-install_name  /opt/local/lib/libmp4v2.1.dylib -compatibility_version 11 -current_version 11.1 -Wl,-single_module

Note how the shell variables aren't expanded in line 1. Line 2 contains all the object files, probably not interesting. Line 3 contains the flags from X_libmp4v2_la_LDFLAGS, which is populated by configure. The stuff about -install_name, and the offending -current_version flag in the last line, evidently comes from the variable archive_cmds in ./libtool.

I did succeed in building this on 10.5.8 Intel. However, the exact same bogus link line is used there (except that the -arch flag is i386)! The /usr/bin/libtool seems to be a more recent vintage, though.

comment:5 follow-up: Changed 7 years ago by stephen@…

Uploading a patch. I get a build, but I have no idea whether it actually works (mp4v2 is pulled in by the gimp port). Warning: merely looking at this patch may cause your dog to leave you and your wife to get worms. Yes, it's that gross.

Changed 7 years ago by stephen@…

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by dbevans (David B. Evans)

  • Cc devans@… added

Replying to stephen@…:

Uploading a patch. I get a build, but I have no idea whether it actually works (mp4v2 is pulled in by the gimp port).

To be more precise, the immediate dependent of mp4v2 is faac which is reguired by gimp-gap and ffmpeg.

gimp2 depends on gegl which in turn depends on ffmpeg

The metaport gimp depends on gimp2 and possibly gimp-gap (through the +animation variant).

comment:7 Changed 7 years ago by h8spawn@…

  • Cc h8spawn@… added

Cc Me!

comment:8 in reply to: ↑ 6 Changed 7 years ago by stephen@…

Replying to devans@…:

Replying to stephen@…:

Uploading a patch. I get a build, but I have no idea whether it actually works (mp4v2 is pulled in by the gimp port).

To be more precise, the immediate dependent of mp4v2 is faac which is reguired by gimp-gap and ffmpeg.

gimp2 depends on gegl which in turn depends on ffmpeg

The metaport gimp depends on gimp2 and possibly gimp-gap (through the +animation variant).

Strange. gimp2 (for sure, I watched it succeed) and maybe gegl built *without* pulling in ffmpeg or mp4v2, but port balked at building gimp without mp4v2.

comment:9 Changed 7 years ago by gale@…

  • Cc gale@… added

Cc Me!

comment:10 Changed 7 years ago by vinc17@…

The patch is incorrect as it makes the build require the autotools.

comment:11 Changed 7 years ago by pony777@…

  • Cc pony777@… added

Cc Me!

comment:12 Changed 7 years ago by ultrajoe@…

  • Cc ultrajoe@… added

Cc Me!

comment:13 Changed 7 years ago by hydrocell@…

I have the same problem, how can use the patch, sorry I'm n00b and I'm trying to build ffmpeg for use with vlc, but I am now stuck...

comment:14 Changed 7 years ago by hydrocell@…

okay... I did this:

$ cd /opt/local/var/macports/sources/rsync.macports.org/release/ports/multimedia/mp4v2/work/mp4v2-1.9.1/
$ patch -p0 < ~/Desktop/hack-verstring.patch

then it gave this error:

Error: Target org.macports.activate returned: Image error: /opt/local/bin/mp4art is being used by the active libmp4v2 port.  Please deactivate this port first, or use 'port -f activate mp4v2' to force the activation.

So I did this:

$ sudo port deactivate libmp4v2

then it worked... but what if i need libmp4v2?

(i used instrcuctions here <http://guide.macports.org/#development.patches> for patching, even though the filename was not .diff)

comment:15 Changed 7 years ago by hydrocell@…

  • Cc hydrocell@… added

Cc Me!

comment:16 follow-up: Changed 7 years ago by cedric.luthi@…

mp4v2 is just the new version of libmp4v2

comment:17 in reply to: ↑ 16 Changed 7 years ago by hydrocell@…

Replying to cedric.luthi@…:

mp4v2 is just the new version of libmp4v2

ah, cool. sorry for the n00b question.

comment:18 in reply to: ↑ 4 Changed 7 years ago by brune@…

Another n00b question: Will this ever be fixed in macports, or is this patch the only option?

comment:19 Changed 7 years ago by boydb@…

  • Cc boydb@… added

Cc Me!

comment:20 Changed 7 years ago by Mobius.fr@…

  • Cc Mobius.fr@… added

Cc Me!

comment:21 Changed 7 years ago by fang@…

  • Cc fang@… added

Cc Me!

comment:22 follow-up: Changed 7 years ago by bigger-picture@…

Replying to fang@…:

Cc Me!

"CC Me" too please!

Hi :o) - forgive please any newbie MacPorts-Trac-ticket-system protocol faux-pas on my part,
but having done already _loads_ of Googling and reading so far, without resolution, head now
spinning, this is just to add my "Ditto" to this bug-report and hopefully 'bump' the thread.
I'm just sorry that I don't have the necessary up-to-date programming fluency (yet?) to trace
the error-message through to a solution. For completeness' sake (and Google-searches) my route
here is as follows..

Apple Macintosh PowerBook (FireWire, 2000, Pismo 500) PPC G3-500 1GB-RAM
Tiger 10.4.11 Xcode 2.5 MacPorts 1.8.1

The sudden failure on 2009.10.02 of Paul Battley's (po-ru.com) hitherto extremely useful iPlayer-dl
(following changes _at_the_BBC's_end_ not his), and with the earliest prospect of a fix more than a
(vacation) week away, the race is on to get an alternative downloader installed. A tip in his site's
comments mentioned "get_iplayer" (linuxcentre.net/getiplayer) which looks promising. Unfortunately,
despite finding requests for it here, searching MacPorts shows it unavailable as a direct install.

Hmm, okay, so trying a roll-yer-own, one-by-one DIY-components approach, starting with "FFMPEG" as
one of the prerequisites/dependencies for get_iplayer I tried that : "sudo port install ffmpeg"

And that's where I fell into this mp4v2 libtool make-error hole as per the thread title above. My
error-messages at the compiler bailout point have been more like Stephen's 2009.09.02 code-snippet
above, except obviously not the i386 references.

From attempting ffmpeg I dropped to mp4v2 directly, firstly trying it within MacPorts, then even
outside directly from source. Much reading and Googling and thrashing about in ignorance, I tried
upgrading "make" to v3.81. I tried doing everything in short simple folder-paths without spaces or
other iffy characters, and I re-checked and simplified my bash $PATH environment, wondering if the
"more than one current version" might be related to having MacPorts stuff in the /opt tree
duplicating up on normal system files. I tried using the readme-recommended strategy of a clean new
/build folder with "mkdir /build ; cd build/ ; ../configure" rather than my hitherto usual simple
./configure ... all so far without success.

I started looking inside config.log, aclocal.m4, configure.ac, autoaux/*.*, GNUmakefile*.* and so
forth, searching for any and all references to darwin, ppc, libtool etc, really grasping at straws,
hoping for enough of a foothold for the old IQ to use, but very quickly realised I'm out of my
depth, not having any fluency in modern programming contexts, not even sufficient conceptual
overview of the landscape, let alone the particulars of often-dense and obfuscating syntax. So no,
not able to trace the error through, sorry. Younger more familiar eyes are needed.

Given vinc17's comment above, and even Stephen's own caveat, I have not tried said patch. I did try
some explicit command-line options just in case, and my last (failed) command-line in a direct build-
from-source folder was : "../configure --enable-bi=32 --enable-ub=ppc" which fell over similar to
Stephen's, to wit :

g++ -dynamiclib  ${wl}-flat_namespace  ${wl}-undefined  ${wl}suppress  -o .libs/libmp4v2.1.9.1.dylib  src/.libs/3gp.o  src/.libs/atom_ac3.o  
( ( ( ...snip... ) ) ) 
libutil/.libs/crc.o  libutil/.libs/other.o  -arch ppc  -m32  -Wl,-current_version  -Wl,1.9.1  -Wl,-compatibility_version  -Wl,1.0.0  -install_name  /usr/local/lib/libmp4v2.1.dylib  -compatibility_version 11  -current_version 11.1  -Wl,-single_module 
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool:  more than one:  -current_version option specified 
Usage: /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool -static [-] file [...]  [-filelist listfile[,dirname]]   [-arch_only arch] [-sacLT] 
Usage: /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool -dynamic [-] file [...]  [-filelist listfile[,dirname]]  [-arch_only arch] [-o output] [-install_name name]  [-compatibility_version #] [-current_version #] [-seg1addr 0x#]   [-segs_read_only_addr 0x#] [-segs_read_write_addr 0x#]  [-seg_addr_table <filename>]  [-seg_addr_table_filename <file_system_path>]  [-all_load] [-noall_load] 
make: *** [libmp4v2.la] Error 1

Following the MacPorts FAQs and Guides etc, and more for rigour than in expectation, after a
successful "sudo port -d selfupdate" I'm presently doing the "sudo port -d upgrade outdated" - it's
been chugging away for a long time already and I suspect it'll be several days yet before it's
finished on my poor old rig, albeit a faithful old girl. :D

Still, given the 'urgency' of a fix (as the BBC iPlayer streams only last a week), I thought I'd
at least register and add my slightly different setup case-notes here, hoping it bumps the thread,
hoping it saves other people wasted hours of thrashing, and hoping it all maybe snags Googlers
better placed than us to pore over the code.

Thanks to all so far. Keep up the good work.

Fingers crossed.. :o)

..

comment:23 in reply to: ↑ 22 Changed 7 years ago by gale@…

Replying to bigger-picture@…:

Given vinc17's comment above, and even Stephen's own caveat, I have not tried said patch.

No, use the patch. It works.

vinc17's comment just means that there might be a problem with incorporating the patch officially in MacPorts at the moment.

Stephen's caveat just means... well, be nice to your dog and your wife.

comment:24 Changed 7 years ago by pony777@…

  • Cc pony777@… removed

Cc Me!

comment:25 Changed 7 years ago by holin@…

Here's a better patch. The versioning consistency breaks, for the better imho, but you should rebuild all dependent ports.

Changed 7 years ago by holin@…

fix libtool versioning conflict

comment:26 Changed 7 years ago by holin@…

(I suggested the fix to upstream as well)

comment:27 Changed 7 years ago by pedrolito@…

Hi,

I run into that exact same problem with my Tiger. And using holin's patch made mp4v2 finally compile! Thank you all for supporting macports. Oh, my wife and dog are still doing fine ;-)

comment:28 Changed 7 years ago by macsforever2000@…

  • Cc this.brack@… added

Cc reporter of duplicate #22190.

comment:29 Changed 7 years ago by this.brack@…

  • Cc this.brack@… removed

Cc Me!

comment:30 Changed 7 years ago by this.brack@…

  • Cc this.brack@… added

Cc Me!

comment:31 Changed 7 years ago by this.brack@…

  • Cc this.brack@… removed

Cc Me!

comment:32 Changed 7 years ago by this.brack@…

Forgive my simpleness but how do I apply this patches? I downloaded mp4v2-1.9.1-libversion.patch to Downloads folder and tried to follow documentation by doing the following:

cd $(port dir postfix)

and then

patch -p0 < ~/Downloads/mp4v2-1.9.1-libversion.patch 

and I et the following respond:

can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nru ../mp4v2-1.9.1-orig/GNUmakefile.in ./GNUmakefile.in
|--- ../mp4v2-1.9.1-orig/GNUmakefile.in 2009-07-14 02:25:44.000000000 +0300
|+++ ./GNUmakefile.in   2009-10-10 11:12:15.000000000 +0300

I'm sure that I'm doing something wrong but could somebody point me what?

comment:33 follow-up: Changed 7 years ago by myrrhlin@…

I was able to build this port using the uploaded patch. For those who'd like a little handholding to try the same, this comment describes what I did.

On my iBook G4 running 10.4.11 with Xcode 2.5 dev tools (and Apple's X11) installed, and it failed with a libtool error similar to those described above.

--->  Building mp4v2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_mp4v2/work/mp4v2-1.9.1" && /usr/bin/make -j1 all " returned error 2
   [ . . snip . . ]
mkdir .libs
/usr/bin/g++-4.0 -dynamiclib ${wl}-undefined ${wl}dynamic_lookup -o .libs/libmp4v2.1.9.1.dylib  src/.libs/3gp.o src/.libs/atom_ac3.o src/.libs/atom_amr.o src/.libs/atom_avc1.o src/.libs/atom_avcC.o src/.libs/atom_chpl.o src/.libs/atom_colr.o src/.libs/atom_d263.o src/.libs/atom_dac3.o src/.libs/atom_damr.o src/.libs/atom_dref.o src/.libs/atom_elst.o src/.libs/atom_enca.o src/.libs/atom_encv.o src/.libs/atom_free.o src/.libs/atom_ftyp.o src/.libs/atom_ftab.o src/.libs/atom_gmin.o src/.libs/atom_hdlr.o src/.libs/atom_hinf.o src/.libs/atom_hnti.o src/.libs/atom_href.o src/.libs/atom_mdat.o src/.libs/atom_mdhd.o src/.libs/atom_meta.o src/.libs/atom_mp4s.o src/.libs/atom_mp4v.o src/.libs/atom_mvhd.o src/.libs/atom_nmhd.o src/.libs/atom_ohdr.o src/.libs/atom_pasp.o src/.libs/atom_root.o src/.libs/atom_rtp.o src/.libs/atom_s263.o src/.libs/atom_sdp.o src/.libs/atom_sdtp.o src/.libs/atom_smi.o src/.libs/atom_sound.o src/.libs/atom_standard.o src/.libs/atom_stbl.o src/.libs/atom_stdp.o src/.libs/atom_stsc.o src/.libs/atom_stsd.o src/.libs/atom_stsz.o src/.libs/atom_stz2.o src/.libs/atom_text.o src/.libs/atom_tfhd.o src/.libs/atom_tkhd.o src/.libs/atom_treftype.o src/.libs/atom_trun.o src/.libs/atom_tx3g.o src/.libs/atom_udta.o src/.libs/atom_url.o src/.libs/atom_urn.o src/.libs/atom_uuid.o src/.libs/atom_video.o src/.libs/atom_vmhd.o src/.libs/cmeta.o src/.libs/descriptors.o src/.libs/exception.o src/.libs/isma.o src/.libs/mp4.o src/.libs/mp4atom.o src/.libs/mp4container.o src/.libs/mp4descriptor.o src/.libs/mp4file.o src/.libs/mp4file_io.o src/.libs/mp4info.o src/.libs/mp4meta.o src/.libs/mp4property.o src/.libs/mp4track.o src/.libs/mp4util.o src/.libs/ocidescriptors.o src/.libs/odcommands.o src/.libs/qosqualifiers.o src/.libs/rtphint.o src/.libs/text.o src/bmff/.libs/typebmff.o src/itmf/.libs/CoverArtBox.o src/itmf/.libs/Tags.o src/itmf/.libs/generic.o src/itmf/.libs/type.o src/qtff/.libs/ColorParameterBox.o src/qtff/.libs/PictureAspectRatioBox.o src/qtff/.libs/coding.o libplatform/io/.libs/File.o libplatform/io/.libs/FileSystem.o libplatform/prog/.libs/option.o libplatform/sys/.libs/error.o libplatform/time/.libs/time.o libplatform/io/.libs/File_posix.o libplatform/io/.libs/FileSystem_posix.o libplatform/number/.libs/random_posix.o libplatform/process/.libs/process_posix.o libplatform/time/.libs/time_posix.o libutil/.libs/Database.o libutil/.libs/Timecode.o libutil/.libs/TrackModifier.o libutil/.libs/Utility.o libutil/.libs/crc.o libutil/.libs/other.o  -L/opt/local/lib  -arch ppc -Wl,-current_version -Wl,1.9.1 -Wl,-compatibility_version -Wl,1.0.0 -install_name  /opt/local/lib/libmp4v2.1.dylib -compatibility_version 11 -current_version 11.1 -Wl,-single_module
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: more than one: -current_version option specified
   [ . . snip . . ]
make: *** [libmp4v2.la] Error 1

As someone earlier commented here, first I tried:

$ port dir mp4v2
/opt/local/var/macports/sources/rsync.macports.org/release/ports/multimedia/mp4v2
$ cd $(port dir mp4v2)
$ patch -p0 < ~/incoming/mp4v2-1.9.1-libversion.patch
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nru ../mp4v2-1.9.1-orig/GNUmakefile.in ./GNUmakefile.in
|--- ../mp4v2-1.9.1-orig/GNUmakefile.in 2009-07-14 02:25:44.000000000 +0300
|+++ ./GNUmakefile.in   2009-10-10 11:12:15.000000000 +0300
--------------------------
File to patch: ^C

To apply the patch, clearly I needed to find the file GNUmakefile.in, and examining the directory structure, got there this way instead:

$ port work mp4v2
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_mp4v2/work
$ cd $(port work mp4v2)
$ cd mp4v2-1.9.1
$ patch -p0 < ~/incoming/mp4v2-1.9.1-libversion.patch 
patching file ./GNUmakefile.in
patching file ./configure

(Note: So when patching a file in the failed build, you want to patch the work directory for the port, and not the directory containing the Portfile.)

The port was then able to build and install (I would guess you only need to type the third line below, and the other two steps will be completed automatically):

$ sudo port build mp4v2
$ sudo port destroot mp4v2
$ sudo port install mp4v2

comment:34 Changed 7 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added

Cedric, is there any remaining reason why this patch should not be applied now?

comment:35 Changed 7 years ago by cedric.luthi@…

I don't have a 10.4 ppc machine, so I could not test it. But as it appears to solve the problems people are encountering, I'm fine.

Also related to mp4v2, could you please remove the false dependencies in the aacgain and faac ports, as explained in #19141 please?

comment:36 Changed 7 years ago by logan@…

  • Cc logan@… added

Cc Me!

comment:37 Changed 7 years ago by logan@…

Would it be possible to get this patch pushed out? I can confirm it does indeed work.

comment:38 Changed 7 years ago by macsforever2000@…

  • Cc dougmencken@… added

cc reporter of dup #23124.

comment:39 in reply to: ↑ 33 Changed 7 years ago by sasaki.takeru@…

Replying to myrrhlin@…:

macbook CoreDuo 10.4.11, Xcode 2.5

$ port work mp4v2
   ... snip ...
$ sudo port install mp4v2

It is works for me very good. thank you.

comment:40 Changed 7 years ago by dougmencken@…

Oh, I reported a dup. I just wonder why the bug reported (and even fixed by patch) FOUR months ago isn't in macports now? I was sure my problem is a regression, the new one, again.

comment:41 follow-ups: Changed 7 years ago by ryandesign (Ryan Schmidt)

mp4v2 installs fine for me on Tiger on both PowerPC and Intel, so I'm not sure why it fails for you. Someone who experiences the problem should please clean mp4v2 and try again with the debug switch:

sudo port clean mp4v2
sudo port -d install mp4v2 2>&1 | tee ~/Desktop/mp4v2.txt

Then attach mp4v2.txt from your desktop to this ticket so I can compare it with my system, and add a note here to say you did so so I'll know to come back and check.

Changed 7 years ago by gale@…

Yes, the build still fails. Here is the debugging output.

Changed 7 years ago by gale@…

And here is the debugging output from the successful build after applying holin's patch.

comment:42 in reply to: ↑ 41 ; follow-up: Changed 7 years ago by gale@…

Replying to ryandesign@…:

Someone who experiences the problem should please clean mp4v2 and try again with the debug switch...

OK, I did:

sudo port uninstall mp4v2
sudo port clean --all mp4v2
sudo port -d install mp4v2 2>&1 | tee ~/temp/mp4v2.txt # failed
# applied holin's patch as per myrrhlin's instructions
sudo port -d install mp4v2 2>&1 | tee ~/temp/mp4v2_patched.txt # succeeded

I have attached the two debugging output files, as you requested.

comment:43 in reply to: ↑ 42 Changed 7 years ago by gale@…

Replying to gale@…:

OK, I did... I have attached the two debugging output files, as you requested.

Sorry, this is a long thread. I forgot that I haven't specified my platform yet here. It's an Intel MacBook with Mac OS X 10.4.11 and MacPorts 1.8.2.

comment:44 in reply to: ↑ 41 Changed 7 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from new to closed

Replying to ryandesign@…:

mp4v2 installs fine for me on Tiger on both PowerPC and Intel

...ahem: because I had already applied the patch on both of those systems. :/ Committed in r65108.

Note: See TracTickets for help on using tickets.