Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#21204 closed defect (fixed)

odcctools extract failure: tar: Option --strip-path=1 is not supported

Reported by: fechner.michael@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jdfrens@…, ryandesign (Ryan Schmidt)
Port: odcctools

Description (last modified by mf2k (Frank Schima))

--->  Computing dependencies for odcctools
--->  Fetching odcctools
--->  Verifying checksum(s) for odcctools
--->  Extracting odcctools
Error: Target org.macports.extract returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_odcctools/work/odcctools && ./extract.sh " returned error 1
Command output: tar: Option --strip-path=1 is not supported
Usage:
  List:    tar -tf <archive-filename>
  Extract: tar -xf <archive-filename>
  Create:  tar -cf <archive-filename> [filenames...]
  Help:    tar --help

Error: Status 1 encountered during processing.

Change History (7)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)
Version: 1.8.0

comment:2 Changed 11 years ago by jdfrens@…

Cc: jdfrens@… added

Cc Me!

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: Problem with extracting package for odcctoolsodcctools extract failure: tar: Option --strip-path=1 is not supported

Confirmed on Snow Leopard. The extract script tries to pick either --strip-path or --strip-components, whichever the current version of tar supports; tar on Snow Leopard appears to support neither. tar on Leopard is GNU tar 1.15.1 but on Snow Leopard it's BSD tar 2.6.2, and presumably this option is a GNU tar extension. The port already has a patch that it uses on Panther to use the gnutar port; we could use that on Snow Leopard as well.

Which software are you actually trying to install that requires odcctools? The port is very old and I would not expect it to work on Snow Leopard even if we resolve this extract failure, considering it already did not work on Leopard.

comment:4 in reply to:  3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

The port already has a patch that it uses on Panther to use the gnutar port; we could use that on Snow Leopard as well.

Done in r57347.

comment:5 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Now that that's fixed, I get the same as #13148.

comment:6 Changed 11 years ago by tobypeterson

Huh? --strip-components works fine in bsdtar... of course, extract fails because it's trying to do something with the 10.4 SDK, but that's a different problem altogether.

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

The extract.sh script checks whether --strip-components is listed in the output of tar --help; if not, it uses --strip-path.

Note: See TracTickets for help on using tickets.