Opened 10 years ago

Closed 10 years ago

#21402 closed update (fixed)

kile-devel update to 2.1b2

Reported by: jgosmann (Jan Gosmann) Owned by: nicos_pavlov@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: TeX, LaTeX, KDE, KDE4, kile, editor Cc: jgosmann (Jan Gosmann)
Port: kile-devel

Description

I've created a portfile for the TeX/LaTeX editor Kile.

Attachments (1)

Portfile (849 bytes) - added by jgosmann (Jan Gosmann) 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by jgosmann (Jan Gosmann)

Cc: jan@… added

Cc Me!

comment:2 Changed 10 years ago by mf2k (Frank Schima)

Cc: jan@… removed
Owner: changed from macports-tickets@… to nicos_pavlov@…
Port: kile-devel added; kile removed
Summary: New port: kile 2.1b2kile-devel update to 2.1b2
Type: submissionupdate

There is already a kile and kile-devel port. kile-devel is at version 2.1b1 so that port could be updated.

comment:3 Changed 10 years ago by jgosmann (Jan Gosmann)

Cc: jan@… added

Cc Me!

Changed 10 years ago by jgosmann (Jan Gosmann)

Attachment: Portfile added

comment:4 Changed 10 years ago by jgosmann (Jan Gosmann)

I must have overseen the existing port somehow. Anyways, I looked at the original portfile and updated that one (I replaced the attachment with the new version). Changes include:

  • Use Kile version 2.1b2
  • Use PortGroup kde4 to get rid of all the compile stuff. We only have to insert an addition to the configure args now, all the other stuff is done by the port group.
  • Added categories kde and kde4 (since it is a KDE4 program)
  • Changed dependencies to kdelibs4 and kdebase4-runtime. Removed the dependency kdegraphics4, because it seems to bet unnecessary (I was able to install kile with this portfile and deactivated kdegraphics4 port.)

comment:5 Changed 10 years ago by nicos_pavlov@…

Thanks for the changes. I had tried to use the kde4 Portgroup, but I encountered some issues when compiling, but if it is working, that's great. I am not able to test it, being now with SL where kde cannot be compiled yet.

The kdegraphics4 port is however in my opinion required. Kile can compile without it, but it relies heavily on a dvi-pdf previewer, which is preferably Okular, contained in kdegraphics4. Without it, it is not possible to preview any tex documents with kile.

comment:6 Changed 10 years ago by jgosmann (Jan Gosmann)

I did not think about Okular. With your explanation I think the dependency should be added again. By the way, I've added the kdebase4-runtime dependency. Kile would also work without this dependency, but you will not see any icons.

comment:7 Changed 10 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: newclosed

Committed in r58436 (with kdegraphics4).

Note: See TracTickets for help on using tickets.