Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#21408 closed defect (fixed)

boost 1.40.0 +universal build fails on Snow Leopard

Reported by: blakharaz@… Owned by: nox@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt), petr@…, bgrupe27, dbsgeo@…
Port: boost

Description (last modified by mf2k (Frank Schima))

I wanted to build boost for both 32bit and 64bit, but the build fails with the error

--->  Building boost
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_40_0" && bjam -j2 -d2 --layout=tagged --debug-configuration --ignore-site-config --user-config=user-config.jam --without-python --without-mpi -sBZIP2_INCLUDE=/opt/local/include -sBZIP2_LIBPATH=/opt/local/lib -sZLIB_INCLUDE=/opt/local/include -sZLIB_LIBPATH=/opt/local/lib architecture=x86 address-model=32_64 " returned error 1
Command output: lipo: /var/tmp//ccjstpEy.out and /var/tmp//cc3dMZ8C.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/token_ids.o...
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/wave_config_constant.o

    "/usr/bin/g++-4.2"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -arch i386 -arch x86_64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/wave_config_constant.o" "libs/wave/src/wave_config_constant.cpp"

lipo: /var/tmp//cc5GRoAa.out and /var/tmp//cccShCx4.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/wave_config_constant.o...
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/aq.o

    "/usr/bin/g++-4.2"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -arch i386 -arch x86_64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/aq.o" "libs/wave/src/cpplexer/re2clex/aq.cpp"

lipo: /var/tmp//cczeDfyu.out and /var/tmp//cchFEdEO.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/aq.o...
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/instantiate_re2c_lexer_str.o

    "/usr/bin/g++-4.2"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -arch i386 -arch x86_64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/instantiate_re2c_lexer_str.o" "libs/wave/src/instantiate_re2c_lexer_str.cpp"

lipo: /var/tmp//ccvNF8h9.out and /var/tmp//ccSLZ03L.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/instantiate_re2c_lexer_str.o...
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/cpp_re.o

    "/usr/bin/g++-4.2"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -w -no-cpp-precomp -gdwarf-2 -arch i386 -arch x86_64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -c -o "bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/cpp_re.o" "libs/wave/src/cpplexer/re2clex/cpp_re.cpp"

lipo: /var/tmp//cc0C1Ip9.out and /var/tmp//ccCBTh1t.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi/cpplexer/re2clex/cpp_re.o...
...skipped <pbin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi>libboost_wave-mt.a for lack of <pbin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi>instantiate_cpp_exprgrammar.o...
...skipped <pstage/lib>libboost_wave-mt.a for lack of <pbin.v2/libs/wave/build/darwin-4.2.1/release/address-model-32_64/architecture-x86/link-static/threading-multi>libboost_wave-mt.a...
...failed updating 233 targets...
...skipped 338 targets...

Attachments (4)

Portfile.diff (475 bytes) - added by Veence (Vincent) 11 years ago.
patch_gcc_jam.diff (1.1 KB) - added by Veence (Vincent) 11 years ago.
boost.txt.bz2 (11.5 KB) - added by ryandesign (Ryan Schmidt) 11 years ago.
boost_universal_failure_on10.5.txt (309.6 KB) - added by dbsgeo@… 11 years ago.
leopard failure with trunk macports when building universal

Download all attachments as: .zip

Change History (29)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to nox@…

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

comment:3 Changed 11 years ago by petr@…

Cc: petr@… added

Cc Me!

comment:4 Changed 11 years ago by Veence (Vincent)

As you see there is a stray -m64 in the compile options that seems to override arch choices

comment:5 Changed 11 years ago by Veence (Vincent)

Try the appended two patches and tell me. For me, it works:

-> port installed boost
The following ports are currently installed:
  boost @1.40.0_0+graphml+icu+python26+universal (active)

Changed 11 years ago by Veence (Vincent)

Attachment: Portfile.diff added

Changed 11 years ago by Veence (Vincent)

Attachment: patch_gcc_jam.diff added

comment:6 Changed 11 years ago by bgrupe27

Cc: bgrupe@… added

Cc Me!

comment:7 in reply to:  5 Changed 11 years ago by thequestor@…

Replying to vince@…:

Try the appended two patches and tell me. For me, it works:

-> port installed boost
The following ports are currently installed:
  boost @1.40.0_0+graphml+icu+python26+universal (active)

please help, which 2 files need patched exactly? I can probably figure out how to patch the file with the provided diffs but I can't figure out by reading them exactly which files need patched. Please help. I do nightly builds of xbmc for all platforms and my build enviroment is borked and I can't get boost to install. Thanks

comment:8 Changed 11 years ago by Veence (Vincent)

Normally, you need to patch the Portfile with the Portfile.diff, and just put the patch_gcc_jam.diff file in the "files" directory located at the same place than the Portfile. If this directory does not exist, create it.

comment:9 in reply to:  8 Changed 11 years ago by thequestor@…

Replying to vince@…:

Normally, you need to patch the Portfile with the Portfile.diff, and just put the patch_gcc_jam.diff file in the "files" directory located at the same place than the Portfile. If this directory does not exist, create it.

I'm sorry for the confusion, the problem is I don't know where the port file is physcially located. when I search for them in finder there are about 200 :(

comment:10 Changed 11 years ago by ryandesign (Ryan Schmidt)

The command "port file boost" shows you where the portfile is. The command "port dir boost" shows you were its directory is. The command "cd $(port dir boost)" takes you to the directory.

comment:11 Changed 11 years ago by blakharaz@…

boost +universal works for me with the patch, but +universal+icu fails (I guess because icu itself has no +universal).

comment:12 Changed 11 years ago by stephan.diederich@…

confirmed. Above 2 patches fix universal build for me:

-> port installed boost
The following ports are currently installed:
  boost @1.39.0_3+universal
  boost @1.40.0_1+universal (active)

comment:13 Changed 11 years ago by dbsgeo@…

Note the discussion of this same issue amongst boost users/developers who don't quite yet seem to have the optimal solution across os 10.4->10.6:

http://groups.google.com/group/boost-list/browse_thread/thread/1c25c10e37a0466a/2e1f62e1e33efe9f?#2e1f62e1e33efe9f

comment:14 Changed 11 years ago by dbsgeo@…

Cc: dbsgeo@… added

Cc Me!

comment:15 Changed 11 years ago by dbsgeo@…

Cc: dbsgeo@… removed

Cc Me!

comment:16 Changed 11 years ago by nox@…

Resolution: fixed
Status: newclosed

Should be fixed by r58424

Changed 11 years ago by ryandesign (Ryan Schmidt)

Attachment: boost.txt.bz2 added

comment:17 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

It doesn't work for me. I get this output.

comment:18 Changed 11 years ago by nox@…

Resolution: fixed
Status: reopenedclosed
Version: 1.8.0

Precompiled headers are disabled by r58535

comment:19 Changed 11 years ago by dbsgeo@…

I can confirm that this now works for me as well on snow leopard building universal with universal_archs x86_64 i386 in macports.conf

But now testing +universal on leopard(10.5) with {{{universal_archs x86_64 i386 ppc}} I get:

--->  Building boost
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_mports_trunk_dports_devel_boost/work/boost_1_40_0" && bjam -j2 -d2 --layout=tagged --debug-configuration --ignore-site-config --user-config=user-config.jam --without-mpi -sBZIP2_INCLUDE=/opt/local/include -sBZIP2_LIBPATH=/opt/local/lib -sZLIB_INCLUDE=/opt/local/include -sZLIB_LIBPATH=/opt/local/lib -sICU_PATH=/opt/local pch=off architecture=combined --disable-long-double address-model=32_64 " returned error 1
Command output: darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/mapped_file.o

    "/usr/bin/g++-4.0"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -Wno-long-double -arch i386 -arch ppc -arch x86_64 -arch ppc64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -I"/opt/local/include" -c -o "bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/mapped_file.o" "libs/iostreams/src/mapped_file.cpp"

lipo: /var/tmp//cc5bxv86.out and /var/tmp//ccMMEpCO.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/mapped_file.o...
darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/zlib.o

    "/usr/bin/g++-4.0"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -Wno-long-double -arch i386 -arch ppc -arch x86_64 -arch ppc64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -I"/opt/local/include" -c -o "bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/zlib.o" "libs/iostreams/src/zlib.cpp"

lipo: /var/tmp//ccIRtSRy.out and /var/tmp//cctm8NO9.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/zlib.o...
darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/bzip2.o

    "/usr/bin/g++-4.0"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -no-cpp-precomp -gdwarf-2 -Wno-long-double -arch i386 -arch ppc -arch x86_64 -arch ppc64 -m64  -DBOOST_ALL_NO_LIB=1 -DNDEBUG  -I"." -I"/opt/local/include" -c -o "bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/bzip2.o" "libs/iostreams/src/bzip2.cpp"

lipo: /var/tmp//ccEJ4jNt.out and /var/tmp//ccTgGc5Q.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi/bzip2.o...
...skipped <pbin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi>libboost_iostreams-mt.a for lack of <pbin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi>file_descriptor.o...
...skipped <pstage/lib>libboost_iostreams-mt.a for lack of <pbin.v2/libs/iostreams/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/link-static/pch-off/threading-multi>libboost_iostreams-mt.a...
darwin.compile.c++ bin.v2/libs/graph/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/pch-off/threading-multi/read_graphviz_new.o

    "/usr/bin/g++-4.0"  -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall -dynamic -no-cpp-precomp -gdwarf-2 -Wno-long-double -arch i386 -arch ppc -arch x86_64 -arch ppc64 -fPIC -m64  -DBOOST_ALL_NO_LIB=1 -DBOOST_GRAPH_DYN_LINK=1 -DBOOST_GRAPH_NO_LIB=1 -DNDEBUG  -I"." -I"libs/graph/src" -c -o "bin.v2/libs/graph/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/pch-off/threading-multi/read_graphviz_new.o" "libs/graph/src/read_graphviz_new.cpp"

lipo: /var/tmp//ccLvrxsQ.out and /var/tmp//ccACpR1p.out have the same architectures (x86_64) and can't be in the same fat output file
...failed darwin.compile.c++ bin.v2/libs/graph/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/pch-off/threading-multi/read_graphviz_new.o...
...skipped <pstage/lib>libboost_graph-mt.dylib for lack of <pbin.v2/libs/graph/build/darwin-4.0.1/release/address-model-32_64/architecture-combined/pch-off/threading-multi>read_graphviz_new.o...
...failed updating 453 targets...
...skipped 69 targets...
...updated 181 targets...

Error: Status 1 encountered during processing.

comment:20 Changed 11 years ago by dbsgeo@…

Cc: dbsgeo@… added

Cc Me!

comment:21 Changed 11 years ago by nox@…

dbsgeo: As always, could you give me the output of sudo port -v build boost +universal?

Changed 11 years ago by dbsgeo@…

leopard failure with trunk macports when building universal

comment:22 Changed 11 years ago by dbsgeo@…

output now attached showing the first 20 minutes of the broken 10.5 universal boost build.

comment:23 Changed 11 years ago by nox@…

r58798 shoud work.

comment:24 Changed 11 years ago by dbsgeo@…

Great, re-installing a clean boost +universal port and it is looking good!

comment:25 Changed 11 years ago by dbsgeo@…

yes, this is fixed now on leopard. thanks.

Note: See TracTickets for help on using tickets.