Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#21487 closed defect (fixed)

VLC fails to build on Snow Leopard

Reported by: nefar@… Owned by: mnick@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: snowleopard Cc: whcordis@…, ryandesign (Ryan Schmidt), francesco086@…, rod-macports@…, alexangas@…, muchatel@…, maxime.turlot@…, llformiga@…, royliu@…
Port: VLC

Description

Recently started afresh with 1.8 and VLC fails to build.

Attachments (5)

vlc.log.txt (375.3 KB) - added by nefar@… 9 years ago.
build log
patch-fdatasync_sl.diff (622 bytes) - added by mnick@… 9 years ago.
Portfile.diff (577 bytes) - added by mnick@… 9 years ago.
vlc_patched_build.log (695.4 KB) - added by whcordis@… 9 years ago.
Log of build with proposed patch
VLC-10.6-qtcapture.diff (1.1 KB) - added by mnick@… 9 years ago.

Download all attachments as: .zip

Change History (38)

Changed 9 years ago by nefar@…

Attachment: vlc.log.txt added

build log

comment:1 Changed 9 years ago by nefar@…

summary

make[4]: *** Waiting for unfinished jobs....
libtool: compile:  /Developer/usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 -std=gnu99 -mmacosx-version-min=10.6 -DHAVE_CONFIG_H -I. -I.. -I../include -I../include -I/opt/local/include -DSYS_DARWIN -I/opt/local/include -D_FILE_OFFSET_BITS=64 -D__USE_UNIX98 -D_LARGEFILE64_SOURCE -D_REENTRANT -D_THREAD_SAFE -DHAVE_RELEASE -D__LIBVLC__ -I../src/misc -O4 -ffast-math -funroll-loops -fno-omit-frame-pointer -DMODULE_STRING=\"main\" -DLOCALEDIR=\"/opt/local/share/locale\" -DSYSCONFDIR=\"/opt/local/etc\" -DDATA_PATH=\"/opt/local/share/vlc\" -DLIBDIR=\"/opt/local/lib\" -DPLUGIN_PATH=\"/opt/local/lib/vlc\" -O2 -arch x86_64 -D_INTL_REDIRECT_MACROS -DMACOSX_DEPLOYMENT_TARGET=10.6 -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -Werror-implicit-function-declaration -MT config/libvlccore_la-intf.lo -MD -MP -MF config/.deps/libvlccore_la-intf.Tpo -c config/intf.c  -fno-common -DPIC -o config/.libs/libvlccore_la-intf.o
mv -f config/.deps/libvlccore_la-intf.Tpo config/.deps/libvlccore_la-intf.Plo
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for VLC): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

comment:2 Changed 9 years ago by tobypeterson

Owner: changed from macports-tickets@… to mnick@…
Summary: vcl fails to buildvlc fails to build

comment:3 Changed 9 years ago by tobypeterson

The relevant error is actually:

config/file.c: In function 'SaveConfigFile':
config/file.c:687: error: implicit declaration of function 'fdatasync'

comment:4 Changed 9 years ago by mnick@…

Status: newassigned

Changed 9 years ago by mnick@…

Attachment: patch-fdatasync_sl.diff added

Changed 9 years ago by mnick@…

Attachment: Portfile.diff added

comment:5 Changed 9 years ago by mnick@…

Keywords: snowleopard added
Version: 1.8.0

For some reason autconf seems to report that fdatasync is available on SL while it actually isn't. Could you please test the attached patches if they fix the problem?

comment:6 Changed 9 years ago by nefar@…

libtool: compile:  /Developer/usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 -mmacosx-version-min=10.6 -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include -I/opt/local/include -DSYS_DARWIN -I/opt/local/include -D_FILE_OFFSET_BITS=64 -D__USE_UNIX98 -D_LARGEFILE64_SOURCE -D_REENTRANT -D_THREAD_SAFE -DHAVE_RELEASE -D__LIBVLC__ -D__PLUGIN__ -DMODULE_NAME=qtcapture -DMODULE_NAME_IS_qtcapture -DMODULE_STRING=\"qtcapture\" -O4 -ffast-math -funroll-loops -fno-omit-frame-pointer -O2 -arch x86_64 -D_INTL_REDIRECT_MACROS -std=gnu99 -DMACOSX_DEPLOYMENT_TARGET=10.6 -MT libqtcapture_plugin_la-qtcapture.lo -MD -MP -MF .deps/libqtcapture_plugin_la-qtcapture.Tpo -c qtcapture.m  -fno-common -DPIC -o .libs/libqtcapture_plugin_la-qtcapture.o
qtcapture.m: In function 'qtchroma_to_fourcc':
qtcapture.m:174: error: 'k422YpCbCr8CodecType' undeclared (first use in this function)
qtcapture.m:174: error: (Each undeclared identifier is reported only once
qtcapture.m:174: error: for each function it appears in.)
qtcapture.m:175: error: 'kComponentVideoCodecType' undeclared (first use in this function)
qtcapture.m:176: error: 'kComponentVideoUnsigned' undeclared (first use in this function)
qtcapture.m: In function 'Open':
qtcapture.m:227: warning: format not a string literal and no format arguments
qtcapture.m:263: warning: format not a string literal and no format arguments
qtcapture.m:264: warning: format not a string literal and no format arguments
make[5]: *** [libqtcapture_plugin_la-qtcapture.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Got this error now.

comment:7 Changed 9 years ago by whcordis@…

Cc: whcordis@… added

Cc Me!

Changed 9 years ago by whcordis@…

Attachment: vlc_patched_build.log added

Log of build with proposed patch

comment:8 in reply to:  6 Changed 9 years ago by whcordis@…

Replying to nefar@…:

Got this error now.

Same for me. Log attached FWIW.

comment:9 in reply to:  5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Port: VLC added; vlc removed
Summary: vlc fails to buildVLC fails to build on Snow Leopard

Replying to mnick@…:

For some reason autconf seems to report that fdatasync is available on SL while it actually isn't. Could you please test the attached patches if they fix the problem?

mnick applied the patch in r58112.

I'm closing #21189 as a duplicate of this one.

comment:10 Changed 9 years ago by francesco086@…

Cc: francesco086@… added

Cc Me!

comment:11 Changed 9 years ago by bloosqr@…

Cc: bloosqr@… added

Cc Me!

comment:12 Changed 9 years ago by bloosqr@…

Cc: bloosqr@… removed

Cc Me!

comment:13 Changed 9 years ago by rod-macports@…

Cc: rod-macports@… added

Cc Me!

comment:14 Changed 9 years ago by felix@…

Cc Me!

comment:15 Changed 9 years ago by alexangas@…

Cc: alexangas@… added

Cc Me!

comment:16 Changed 9 years ago by muchatel@…

Cc: muchatel@… added

Cc Me!

comment:17 Changed 9 years ago by davidfavor (David Favor)

Cc: david@… added

Cc Me!

comment:18 Changed 9 years ago by davidfavor (David Favor)

Cc: david@… removed

Cc Me!

comment:19 Changed 9 years ago by davidfavor (David Favor)

Cc: david@… added

Cc Me!

comment:20 Changed 9 years ago by davidfavor (David Favor)

Can someone update this ticket with the exact steps for installing the patch.

Also please update the ticket about if the patch fixes the qtcapture error also.

comment:21 Changed 9 years ago by davidfavor (David Favor)

Looks like the current 1.8.1 contains the fdatasync patch and the patch works.

The second qtcapture error is a complete different problem.

Most likely this ticket is best served closed as fixed.

I'll open a new ticket with the qtcapture data.

comment:22 Changed 9 years ago by davidfavor (David Favor)

Cc: david@… removed

Cc Me!

Changed 9 years ago by mnick@…

Attachment: VLC-10.6-qtcapture.diff added

comment:23 Changed 9 years ago by mnick@…

It seems like 'k422YpCbCr8CodecType' isn't defined anymore in 10.6.sdk. I've just attached a patch (VLC-10.6-qtcapture.diff) that forces VLC to use the 10.5.sdk. Could you please check if that patch fixes the problem? I still don't have access 10.6.

comment:24 Changed 9 years ago by maxime.turlot@…

May I kindly ask you how to install this patch?

I googled that but when I try to install it I get " Only garbage was found in the patch input."

comment:25 Changed 9 years ago by maxime.turlot@…

Cc: maxime.turlot@… added

Cc Me!

comment:26 Changed 9 years ago by mnick@…

Enter the toplevel portstree directory and run

patch -p0 < path_to_VLC-10.6-qtcapture.diff

also make sure you have dowloaded the raw attachment (Original Format link at the bottom of the patch)

comment:27 Changed 9 years ago by maxime.turlot@…

Thank you for your reply. Your explanation look like to be what I did.


  • Running the patch:
mtumac-4:VLC mturlot$ pwd
/opt/local/var/macports/sources/rsync.macports.org/release/ports/multimedia/VLC
mtumac-4:VLC mturlot$  patch -p0 < /Users/mturlot/Desktop/VLC-10.6-qtcapture.diff 
patch: **** Only garbage was found in the patch input.
mtumac-4:VLC mturlot$ 

comment:28 in reply to:  26 Changed 9 years ago by llformiga@…

Patch worked... still having problems with quicktime:

/bin/sh ../../libtool  --tag=CC   --mode=compile /Developer/usr/bin/llvm-gcc-4.2 -std=gnu99 -isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -DHAVE_CONFIG_H -I. -I../..   -I../../include -I../../include -I/opt/local/include -DSYS_DARWIN `top_srcdir="../.." top_builddir="../.." ../../vlc-config --cflags plugin libquicktime_plugin_la-quicktime.lo` -O2 -arch x86_64 -D_INTL_REDIRECT_MACROS -DMACOSX_DEPLOYMENT_TARGET=10.5 -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -Werror-implicit-function-declaration -MT libquicktime_plugin_la-quicktime.lo -MD -MP -MF .deps/libquicktime_plugin_la-quicktime.Tpo -c -o libquicktime_plugin_la-quicktime.lo `test -f 'quicktime.c' || echo './'`quicktime.c
libtool: compile:  /Developer/usr/bin/llvm-gcc-4.2 -std=gnu99 -isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include -I/opt/local/include -DSYS_DARWIN -I/opt/local/include -D_FILE_OFFSET_BITS=64 -D__USE_UNIX98 -D_LARGEFILE64_SOURCE -D_REENTRANT -D_THREAD_SAFE -DHAVE_RELEASE -D__LIBVLC__ -D__PLUGIN__ -DMODULE_NAME=quicktime -DMODULE_NAME_IS_quicktime -DMODULE_STRING=\"quicktime\" -O4 -ffast-math -funroll-loops -fno-omit-frame-pointer -O2 -arch x86_64 -D_INTL_REDIRECT_MACROS -DMACOSX_DEPLOYMENT_TARGET=10.5 -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -Werror-implicit-function-declaration -MT libquicktime_plugin_la-quicktime.lo -MD -MP -MF .deps/libquicktime_plugin_la-quicktime.Tpo -c quicktime.c  -fno-common -DPIC -o .libs/libquicktime_plugin_la-quicktime.o
quicktime.c:126: warning: type defaults to ‘int’ in declaration of ‘SoundComponentData’
quicktime.c:126: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
quicktime.c:129: error: expected ‘;’ before ‘int’
quicktime.c: In function ‘Close’:
quicktime.c:341: error: ‘decoder_sys_t’ has no member named ‘SoundConverterEndConversion’
quicktime.c:341: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:346: error: ‘decoder_sys_t’ has no member named ‘SoundConverterClose’
quicktime.c:346: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:349: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:353: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c:361: error: implicit declaration of function ‘ExitMovies’
quicktime.c: In function ‘OpenAudio’:
quicktime.c:400: error: implicit declaration of function ‘EnterMovies’
quicktime.c:418: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:419: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:420: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:421: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:422: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:423: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:424: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:425: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:428: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:429: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:430: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:431: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:432: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:433: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:434: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:435: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:438: error: ‘decoder_sys_t’ has no member named ‘SoundConverterOpen’
quicktime.c:438: error: ‘decoder_sys_t’ has no member named ‘InputFormatInfo’
quicktime.c:439: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:440: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:455: error: ‘decoder_sys_t’ has no member named ‘SoundConverterSetInfo’
quicktime.c:455: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:462: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:463: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:464: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:466: error: ‘decoder_sys_t’ has no member named ‘SoundConverterGetBufferSizes’
quicktime.c:466: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:468: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:472: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:477: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:477: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:478: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:479: error: ‘decoder_sys_t’ has no member named ‘OutFrameSize’
quicktime.c:479: error: ‘decoder_sys_t’ has no member named ‘FramesToGet’
quicktime.c:481: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:481: error: ‘decoder_sys_t’ has no member named ‘OutFrameSize’
quicktime.c:484: error: ‘decoder_sys_t’ has no member named ‘SoundConverterBeginConversion’
quicktime.c:484: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:493: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:494: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:497: error: ‘decoder_sys_t’ has no member named ‘OutputFormatInfo’
quicktime.c:499: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:501: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:502: error: ‘decoder_sys_t’ has no member named ‘i_buffer_size’
quicktime.c:503: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:503: error: ‘decoder_sys_t’ has no member named ‘i_buffer_size’
quicktime.c:504: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:507: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:508: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c: In function ‘DecodeAudio’:
quicktime.c:556: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:556: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:556: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:559: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:560: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:566: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:568: error: ‘decoder_sys_t’ has no member named ‘pts’
quicktime.c:582: error: ‘decoder_sys_t’ has no member named ‘i_buffer_size’
quicktime.c:582: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:584: error: ‘decoder_sys_t’ has no member named ‘i_buffer_size’
quicktime.c:584: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:585: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:585: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:585: error: ‘decoder_sys_t’ has no member named ‘i_buffer_size’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:587: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:589: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:591: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:591: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:593: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:593: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:597: error: ‘decoder_sys_t’ has no member named ‘SoundConverterConvertBuffer’
quicktime.c:597: error: ‘decoder_sys_t’ has no member named ‘myConverter’
quicktime.c:598: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:600: error: ‘decoder_sys_t’ has no member named ‘out_buffer’
quicktime.c:613: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:613: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:614: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘p_buffer’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘InFrameSize’
quicktime.c:616: error: ‘decoder_sys_t’ has no member named ‘i_buffer’
quicktime.c:621: error: ‘decoder_sys_t’ has no member named ‘pts’
quicktime.c:622: error: ‘decoder_sys_t’ has no member named ‘pts’
quicktime.c:622: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:624: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:624: error: ‘decoder_sys_t’ has no member named ‘pts’
quicktime.c:626: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:634: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:635: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:640: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:640: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:643: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:643: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:643: error: ‘decoder_sys_t’ has no member named ‘i_out_frames’
quicktime.c:643: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:649: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:650: error: ‘decoder_sys_t’ has no member named ‘date’
quicktime.c:652: error: ‘decoder_sys_t’ has no member named ‘out_buffer’
quicktime.c:652: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:652: error: ‘decoder_sys_t’ has no member named ‘out_buffer’
quicktime.c:652: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c:656: error: ‘decoder_sys_t’ has no member named ‘i_out’
quicktime.c: In function ‘OpenVideo’:
quicktime.c:678: error: ‘ImageSubCodecDecompressCapabilities’ undeclared (first use in this function)
quicktime.c:678: error: (Each undeclared identifier is reported only once
quicktime.c:678: error: for each function it appears in.)
quicktime.c:678: error: expected ‘;’ before ‘icap’
quicktime.c:679: error: ‘CodecInfo’ undeclared (first use in this function)
quicktime.c:679: error: expected ‘;’ before ‘cinfo’
quicktime.c:680: error: ‘ImageDescription’ undeclared (first use in this function)
quicktime.c:680: error: ‘id’ undeclared (first use in this function)
quicktime.c:688: error: ‘decoder_sys_t’ has no member named ‘i_late’
quicktime.c:730: error: ‘decoder_sys_t’ has no member named ‘FindNextComponent’
quicktime.c:737: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:737: error: ‘decoder_sys_t’ has no member named ‘OpenComponent’
quicktime.c:738: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:740: error: ‘icap’ undeclared (first use in this function)
quicktime.c:741: error: ‘decoder_sys_t’ has no member named ‘ImageCodecInitialize’
quicktime.c:741: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:745: error: ‘cinfo’ undeclared (first use in this function)
quicktime.c:746: error: ‘decoder_sys_t’ has no member named ‘ImageCodecGetCodecInfo’
quicktime.c:746: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:757: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:758: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:759: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:760: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:800: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:800: error: ‘ImageDescriptionHandle’ undeclared (first use in this function)
quicktime.c:800: error: expected ‘;’ before ‘NewHandleClear’
quicktime.c:801: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:801: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:801: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:801: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:804: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c:805: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c:808: error: ‘decoder_sys_t’ has no member named ‘QTNewGWorldFromPtr’
quicktime.c:808: error: ‘decoder_sys_t’ has no member named ‘OutBufferGWorld’
quicktime.c:813: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:815: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c:821: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:821: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:821: error: ‘CodecDecompressParams’ undeclared (first use in this function)
quicktime.c:821: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:821: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:822: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:822: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:823: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:824: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:824: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:825: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:826: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:827: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:828: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:829: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:829: error: ‘decoder_sys_t’ has no member named ‘codeccap’
quicktime.c:830: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:830: error: ‘codecNormalQuality’ undeclared (first use in this function)
quicktime.c:831: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:831: error: ‘decoder_sys_t’ has no member named ‘OutBufferRect’
quicktime.c:832: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:833: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:833: error: ‘decoder_sys_t’ has no member named ‘GetGWorldPixMap’
quicktime.c:833: error: ‘decoder_sys_t’ has no member named ‘OutBufferGWorld’
quicktime.c:835: error: ‘decoder_sys_t’ has no member named ‘ImageCodecPreDecompress’
quicktime.c:835: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:835: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c: In function ‘DecodeVideo’:
quicktime.c:901: error: ‘decoder_sys_t’ has no member named ‘i_late’
quicktime.c:905: error: ‘decoder_sys_t’ has no member named ‘i_late’
quicktime.c:911: error: ‘decoder_sys_t’ has no member named ‘i_late’
quicktime.c:922: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:923: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:924: error: ‘decoder_sys_t’ has no member named ‘framedescHandle’
quicktime.c:926: error: ‘decoder_sys_t’ has no member named ‘ImageCodecBandDecompress’
quicktime.c:926: error: ‘decoder_sys_t’ has no member named ‘ci’
quicktime.c:926: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:928: error: ‘decoder_sys_t’ has no member named ‘decpar’
quicktime.c:937: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c:937: error: ‘decoder_sys_t’ has no member named ‘plane’
quicktime.c: In function ‘QTAudioInit’:
quicktime.c:957: error: ‘decoder_sys_t’ has no member named ‘SoundConverterOpen’
quicktime.c:957: error: ‘SoundConverterOpen’ undeclared (first use in this function)
quicktime.c:958: error: ‘decoder_sys_t’ has no member named ‘SoundConverterClose’
quicktime.c:958: error: ‘SoundConverterClose’ undeclared (first use in this function)
quicktime.c:959: error: ‘decoder_sys_t’ has no member named ‘SoundConverterSetInfo’
quicktime.c:959: error: ‘SoundConverterSetInfo’ undeclared (first use in this function)
quicktime.c:960: error: ‘decoder_sys_t’ has no member named ‘SoundConverterGetBufferSizes’
quicktime.c:960: error: ‘SoundConverterGetBufferSizes’ undeclared (first use in this function)
quicktime.c:961: error: ‘decoder_sys_t’ has no member named ‘SoundConverterConvertBuffer’
quicktime.c:961: error: ‘SoundConverterConvertBuffer’ undeclared (first use in this function)
quicktime.c:962: error: ‘decoder_sys_t’ has no member named ‘SoundConverterBeginConversion’
quicktime.c:962: error: ‘SoundConverterBeginConversion’ undeclared (first use in this function)
quicktime.c:963: error: ‘decoder_sys_t’ has no member named ‘SoundConverterEndConversion’
quicktime.c:963: error: ‘SoundConverterEndConversion’ undeclared (first use in this function)
quicktime.c: In function ‘QTVideoInit’:
quicktime.c:1025: error: ‘decoder_sys_t’ has no member named ‘FindNextComponent’
quicktime.c:1026: error: ‘decoder_sys_t’ has no member named ‘OpenComponent’
quicktime.c:1027: error: ‘decoder_sys_t’ has no member named ‘ImageCodecInitialize’
quicktime.c:1027: error: ‘ImageCodecInitialize’ undeclared (first use in this function)
quicktime.c:1028: error: ‘decoder_sys_t’ has no member named ‘ImageCodecGetCodecInfo’
quicktime.c:1028: error: ‘ImageCodecGetCodecInfo’ undeclared (first use in this function)
quicktime.c:1029: error: ‘decoder_sys_t’ has no member named ‘ImageCodecPreDecompress’
quicktime.c:1029: error: ‘ImageCodecPreDecompress’ undeclared (first use in this function)
quicktime.c:1030: error: ‘decoder_sys_t’ has no member named ‘ImageCodecBandDecompress’
quicktime.c:1030: error: ‘ImageCodecBandDecompress’ undeclared (first use in this function)
quicktime.c:1031: error: ‘decoder_sys_t’ has no member named ‘GetGWorldPixMap’
quicktime.c:1031: error: ‘GetGWorldPixMap’ undeclared (first use in this function)
quicktime.c:1032: error: ‘decoder_sys_t’ has no member named ‘QTNewGWorldFromPtr’
quicktime.c:1032: error: ‘QTNewGWorldFromPtr’ undeclared (first use in this function)
quicktime.c:1033: error: ‘decoder_sys_t’ has no member named ‘NewHandleClear’
make[5]: *** [libquicktime_plugin_la-quicktime.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

comment:29 Changed 9 years ago by llformiga@…

Cc: llformiga@… added

Cc Me!

comment:30 Changed 9 years ago by maxime.turlot@…

I was finally able to apply the patch, thanks.

I got the same issue reported by llformiga now:

--->  Building VLC
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_VLC/work/vlc-1.0.2" && /usr/bin/make all " returned error 2
Command output: quicktime.c:960: error: 'decoder_sys_t' has no member named 'SoundConverterGetBufferSizes'
quicktime.c:960: error: 'SoundConverterGetBufferSizes' undeclared (first use in this function)
quicktime.c:961: error: 'decoder_sys_t' has no member named 'SoundConverterConvertBuffer'
quicktime.c:961: error: 'SoundConverterConvertBuffer' undeclared (first use in this function)
quicktime.c:962: error: 'decoder_sys_t' has no member named 'SoundConverterBeginConversion'
quicktime.c:962: error: 'SoundConverterBeginConversion' undeclared (first use in this function)
quicktime.c:963: error: 'decoder_sys_t' has no member named 'SoundConverterEndConversion'
quicktime.c:963: error: 'SoundConverterEndConversion' undeclared (first use in this function)
quicktime.c: In function 'QTVideoInit':
quicktime.c:1025: error: 'decoder_sys_t' has no member named 'FindNextComponent'
quicktime.c:1026: error: 'decoder_sys_t' has no member named 'OpenComponent'
quicktime.c:1027: error: 'decoder_sys_t' has no member named 'ImageCodecInitialize'
quicktime.c:1027: error: 'ImageCodecInitialize' undeclared (first use in this function)
quicktime.c:1028: error: 'decoder_sys_t' has no member named 'ImageCodecGetCodecInfo'
quicktime.c:1028: error: 'ImageCodecGetCodecInfo' undeclared (first use in this function)
quicktime.c:1029: error: 'decoder_sys_t' has no member named 'ImageCodecPreDecompress'
quicktime.c:1029: error: 'ImageCodecPreDecompress' undeclared (first use in this function)
quicktime.c:1030: error: 'decoder_sys_t' has no member named 'ImageCodecBandDecompress'
quicktime.c:1030: error: 'ImageCodecBandDecompress' undeclared (first use in this function)
quicktime.c:1031: error: 'decoder_sys_t' has no member named 'GetGWorldPixMap'
quicktime.c:1031: error: 'GetGWorldPixMap' undeclared (first use in this function)
quicktime.c:1032: error: 'decoder_sys_t' has no member named 'QTNewGWorldFromPtr'
quicktime.c:1032: error: 'QTNewGWorldFromPtr' undeclared (first use in this function)
quicktime.c:1033: error: 'decoder_sys_t' has no member named 'NewHandleClear'
make[5]: *** [libquicktime_plugin_la-quicktime.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.
mtumac-4:VLC mturlot$ 

comment:31 Changed 9 years ago by royliu@…

Cc: royliu@… added

Cc Me!

comment:32 Changed 9 years ago by mnick@…

Resolution: fixed
Status: assignedclosed

Fixed in r61267

It seems that the quicktime plugin where the error occurs has been deprecated. Therefore i've disabled it in the port, what should make it build in 10.6.

comment:33 Changed 9 years ago by ryandesign (Ryan Schmidt)

I increased the revision in r61273 so everyone who already had VLC @1.0.3_0 installed with the quicktime plugin will now get it rebuilt without that plugin.

Note: See TracTickets for help on using tickets.